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Introduction 

There are 3 periods allocated to a laboratory session in Digital Electronics. It is a necessary 

part of the course at which attendance is compulsory.  

Here are some guidelines to help you perform the experiments and to submit the reports: 

1. Read all instructions carefully and carry them all out. 

2. Ask a demonstrator if you are unsure of anything. 

3. Record actual results (comment on them if they are unexpected!) 

4. Write up full and suitable conclusions for each experiment. 

5. If you have any doubt about the safety of any procedure, contact the demonstrator 

beforehand. 

6. THINK about what you are doing! 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



SYLLABUS 

 

 
Basic Electrical and Electronics Engineering-I 
Code      : ES191 
Contacts: 
Credits  : 2 
 
 
Basic   Electronics  Engineering  Laboratory - I 
 
• There will be a couple of familiarization lectures before the practical classes are undertaken 
   where basic concept of the instruments handled Egg: CRO, Multimeters etc will be given. 
   Lectures on measurement techniques and error calculation will also have to be organized. 
• 3 hours per week must be kept, initially for practical lectures, and later for tutorials. 
 
 
 
List  of  Experiments  : 
 
 
1. Familiarisation with passive and active electronic components such as Resistors, Inductors, 
    Capacitors, Diodes, Transistors (BJT) and electronic equipment like DC power supply,multimeters 
etc. 
2. Familiarization with measuring and testing equipment like CRO, Signal generators etc. 
3. Study of I-V characteristics of Junction diodes. 
4. Study of I-V characteristics of Zener diodes. 
5. Study of Half and Full wave rectifiers with Regulation and Ripple factors. 
6. Study of I-V characteristics of BJTs. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



INTRODUCTION -1 

 AIM: Familiarisation with passive and active electronic components. 

 

What is electronics components? 

Electronic components have a number of electrical terminals or leads. These leads connect 

to other electrical components, often over wire, to create an electronic circuit with a 

particular function (for example an amplifier, radio receiver, or oscillator). Basic electronic 

components may be packaged discretely, as arrays or networks of like components, or 

integrated inside of packages such as semiconductor integrated circuits, hybrid integrated 

circuits, or thick film devices. The following list of electronic components focuses on the 

discrete version of these components, treating such packages as components in their own 

right. 

 

Components can be classified as  

I) Passive components,  

II) Active components 

 

 

PASSIVE COMPONENTS 

 

These types of components cannot use mesh energy into the electronic circuit because they 

don’t rely on a power source, excluding what is accessible from the AC circuit they are allied 

to. As a result, they cannot amplify, although they can increase a current otherwise voltage 

or current. These components mainly include two-terminals like resistors, inductors, 

transformers & capacitors 

 

ACTIVE COMPONENT 

 

These components are used to amplify electrical signals to generate electric power. The 

functioning of these components can be done like an AC circuit within electronic devices to 

protect from voltage and enhanced power. An active component executes its functions 

because it is power-driven through an electricity source. All these components require 

some energy source that is normally removed from a DC circuit. Any quality type of active 

component will include an oscillator, IC (integrated circuit) & 
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AIM: 

 Measure the value of a Resistor, Capacitor. 

 Measure the Tolerance of a Resistor. 

 Explain the types of Resistors, Capacitor. 

What is resistor? 

Pass current in proportion to voltage (Ohm's law) and oppose current. 

 

Types of Resistors 
 

 

 

Carbon Film Resistors: 

 

o Most general purpose ,cheap resistor 

o Tolerance of Resistance value is usually +/- 5% 

o Power ratings of 1/8 W ,1/4 W and ½ W are usually used . 

    

 

Metal Film Resistor 

 

o Used when higher tolerance is needed , ie more value. 

o They have about +/- 0.05% tolerance 
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Wire Wound Resistors: 

o A wire wound resistor is made of metal resistance wire, and because of this 

they can be manufactured to precise values 

o Also, high wattage resistors can be made by thick wire material 

o Wire wound resistors in a ceramic case are called as ceramic resistors 

o Wire wound resistors in a ceramic case are called as ceramic resistors 

 

 

 

 

 

Variable resistors 

 

 

 

 

 

 

 

 

 

 

Page-3 



 

Reading Value of Fixed Resistors:: 

 
 

 

 Resistors are colour coded as they are too small for the value to be written on them. 

 There are 4 or 5 bands of colour . Value of a Resistor is decoded from these band of 

colours. 
 

  

 
 

 If your resistor has four colour bands ,turn the resistor so that the gold or silver band 

is on right hand side or the end with more bands should point left. 

 

 

The first band is now on the left hand side. This represents the first digit .Based on the 

colour make a note of the digit .In this case- 4 band its ‘5’ and for 5 band its ‘2’. 
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The second band represents the second digit. The colours represent the same numbers as 

did the first digit .In this case -4 band its’6’ and for 5 band its’3’. 

 

 

 

 

 

The third band divulges how many zeros to add/divide to the first two numbers –for a 4 

band Resistor . In this case – 4 band its ‘4’ zeroes to be added . So value is 560K. 
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The third band denotes the 3rd digit – for a 5 band Resistor. In this case -5 band its ‘7’ . So 

the value of the 5 band resistor is 237 Ohms as its multiplier digit is ‘0. 

 

 

The last band denotes the tolerance. So the value of the 4 band resistor it is +/- 10% while 

for the 5 band resistor it is +/- 1%. 

 

 

 

o Tolerance of a Resistor is also an important property to consider . 

o A 100 ohm resistor with a 10 % tolerance can mean its value can be any fixed 

value between 90 to 110 Ohms. 
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o A 120 Ohm resistor with a 10 % tolerance can mean its value can be any fixed 

value between 108 and 132 Ohms. 

                                                         

                                                                

Mnemonic to Remember 
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What is Capacitor? 

 

It is one of the passive components like resistor. Capacitor is also known as condenser. 

Capacitor is generally used to store the charge. The charge is stored in the form of 

“electrical field”. Capacitors play a major role in many electrical and electronic circuits. 

 

Classification of Capacitors 
 

UN-POLARIZED POLARIZED 

Ceramic Electrolytic 

Multilayer Tantalum 

Polystyrene Film Super 

Polyster Film They have positive and negative 

electrode 

Polypropylene 

Mica 

They don't have positive and negative 

electrode 

 

 

Ceramic Capacitors: 
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Ceramic capacitors are the most used capacitors in the electronics industry. Ceramic 

capacitors are fixed capacitance type capacitors and they are usually very small (in terms of 

both physical dimensions and capacitance). The capacitance of ceramic capacitors is usually 

in the range of pico farads to few micro farads (less than 10µF). They are non-polarised 

type capacitors and hence can be used in both DC as well as AC circuits 

. 

Electrolytic Capacitor 

 

Electrolytic capacitors are polarized and they must be connected the correct way round , at 

least one of their leads will be marked + or – . It is very easy to find the  

 

values of electrolytic capacitors because they are clearly printed with their capacitance and 

voltage rating. 

 

Tantalum Capacitor: 

 

 

Tantalum bead capacitors are polarized and have low voltage ratings like electrolytic 

capacitors . Usually , the “+” symbol is used to show the positive component lead . Modern 

tantalum bead capacitors are printed with their capacitance voltage and polarity in full. 

However older ones use a colour – code systems which has two stripes (for the two digits) 

and a spot of colour for the number of zeros to give the value in fun. 
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Un-polarized Capacitors- small values(up to 1uF) 

 

 

The value printed but without a multiplier, so you need to use experience to work out what 

the multiplier should be! For example 0.1 means 0.1 pF. Sometimes the multiplier is used in 

place of the decimal point: For example: 4n7 means 4.7n 

 

Un-polarized Capacitors — Capacitor Number Code 
 

 

 

 

 

A number code is often used on small capacitors where printing is difficult: The 1st number 

is the 1st digit, the 2nd number is the 2nd digit, the 3rd number is the number of zeros to 

give the capacitance in pF. Ignore any letters - they just indicate tolerance and voltage 

rating. For example: 102 means 1000pF (not 102pF!) For example: 472J means 4700pF (J 

means 5% tolerance).  

Un-polarized Capacitors — Capacitor Colour Code 
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Structure of an Inductor 

 

  

Inductance 

1. No of turns of wire wound around the coil 

2. Cross sectional area of the coil 

3. The material type of the coil 

4. The Length of the coil 

                                             

Transformers 
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Various transformers 
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INTRODUCTION-2  

AIM: 

Familiarization with measuring and testing equipment like CRO, Signal generators etc. 

 

Digital Multimeter 
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The Breadboard 

The breadboard consists of two terminal strips and two bus strips (often broken in the 

centre). Each bus strip has two rows of contacts. Each of the two rows of contacts are a 

node. That is, each contact along a row on a bus strip is connected together (inside the 

breadboard). Bus strips are used primarily for power supply connections, but are also used 

for any node requiring a large number of connections. Each terminal strip has 60 rows and5 

columns of contacts on each side of the centre gap. Each row of 5 contactsis a node.You will 

build your circuits on the terminal strips by inserting the leads ofcircuit components into 

the contact receptacles and making connections with22-26 gauge wire. There are wire 

cutter/strippers and a spool of wire in thelab. It is a good practice to wire +5V and 0V 

power supply connections toseparate bus strips. 

 

   Fig 1. The breadboard. The lines indicate connected holes. 
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CATHODE RAY TUBE 

The screen is cathode ray tube found in most television sets where the face of the screen is 

divided up into a 2 dimensional grid (or axes or scale); In this experiment we consider 8x10 

grid. The vertical grid is divided up into 8 (major) divisions and the horizontal grid is 

divided into 10 major divisions. To improve the precision, each of these divisions is further 

broken up into 5 minor divisions. The horizontal axis (X-axis) represents time and the 

vertical axis (Y-axis) represents voltage. The scope displays (also called a signal trace or 

trace) the input signal voltage along the vertical (or Y-axis) while an internally generated 

signal (called the horizontal sweep or sweep signal) is simultaneously produced along the 

X-axis creating a 2- dimensional time trace of the input signal. 

 

 

 

volts/div- This control lets you change how many volts are represented by each vertical 

increment of grid (vertical axis) on the screen. Basically, it allows you to zoom in and out 

along the y axis. 

time/div- This control lets you change how much time is represented by each horizontal 

increment of the grid overlay on the screen. It allows you to zoom in and out along the x 

axis. 
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If volt/div is set to 1 volt which implies each major vertical division is 1 volt where as each 

minor vertical division is 0.2 volt. And time/div is set to 0.1ms/div which implies each major 

horizontal division is 0.1ms. Voltage on the vertical scale is 1 volt/div multiply by (number 

of division). Time on the horizontal scale is 0.1msec multiply by (number of division). In the 

figure 2, 1 volt/div and amplitude of the input signal is 1 volt. Here 0.1mses/div, the 

frequency is 1 kHz and its period is 1 complete cycle in 1m sec.if volt/div is set to 2volt/div, 

which implies each major division is 2 volt where as each minor division is 0.5volt. 

Note: If you set the Volts/Div too low, you’ll clip the signal. Similarly, setting it too high, and 

you’ll won’t find the signal, i.e. the signal will b flat. Increasing the Timebase will display 

more cycles of a periodic signal. Conversely, reducing the Timebase, fewer cycles will be 

displayed. 
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DC power supply 



A regulated power supply is an embedded circuit; it converts unregulated AC (Alternating Current) 

into a constant DC. With the help of a rectifier it converts AC supply into DC. Its function is to supply 

a stable voltage (or less often current), to a circuit or device that must be operated within certain 

power supply limits. The output from the regulated power supply may be alternating or 

unidirectional, but is nearly always DC (Direct Current).[1] The type of stabilization used may be 

restricted to ensuring that the output remains within certain limits under various load conditions, or 

it may also include compensation for variations in its own supply source. The latter is much more 

common today. 

 

Signal generator 

A signal generator is one of a class of electronic devices that generates electronic signals 

with set properties of amplitude, frequency, and wave shape. These generated signals are 

used as a stimulus for electronic measurements, typically used in designing, testing, 

troubleshooting, and repairing electronic or electroacoustic devices, though it often has 

artistic uses as well.There are many different types of signal generators with different 

purposes and applications and at varying levels of expense. These types include function 

generators, RF and microwave signal generators, pitch generators, arbitrary waveform 

generators, digital pattern generators, and frequency generators. In general, no device is 

suitable for all possible applications. 
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Experiment-1 

 AIM:     Study  the V-I characteristics of a p-n junction diode. 

Component used: 

1. IN4007 

2. Bread Board 

3. Power supply 

4. DMM 

5. Connecting wire 

The diode is a device formed from a junction of n-type and p-type semiconductor material. 

The lead connected to the p-type material is called the anode and the lead connected to the 

n-type material is the cathode. In general, the cathode of a diode is marked by a solid line 

on the diode. 

 

 

 

THEORY: 
 

The positive terminal of battery is connected to the P side (anode) and the negative terminal of 

battery is connected to the N side (cathode) of a diode, the holes in the p-type region and the 

electrons in the n-type region are pushed toward the junction and start to neutralize the 

depletion zone, reducing its width. The positive potential applied to the p-type material repels 

the holes, while the negative potential applied to the n-type material repels the electrons. The 

change in potential between the p side and the n side decreases or switches sign. With 

increasing forward-bias voltage, the depletion zone eventually becomes thin enough that the 

zone's electric field cannot counteract charge carrier motion across the p–n junction, which as a 

consequence reduces electrical resistance. The electrons that cross the p–n junction into the p-

type material (or holes that cross into the n-type material) will diffuse into the nearby neutral 

region. The amount of minority diffusion in the near-neutral zones determines the amount of 

current that may flow through the diode. 
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In forward biasing, the positive terminal of battery is connected to the P side and the negative 

terminal of battery is connected to the N side of the diode. Diode will conduct in forward 

biasing because the forward biasing will decrease the depletion region width and overcome the 

barrier potential. In order to conduct, the forward biasing voltage should be greater than the 

barrier potential. During forward biasing the diode acts like a closed switch with a potential 

drop of nearly 0.6 V across it for a silicon diode. The forward and reverse bias characteristics of 

a silicon diode. From the graph, you may notice that the diode starts conducting when the 

forward bias voltage exceeds around 0.6 volts (for Si diode). This voltage is called cut-in 

voltage. 

 

Procedure  

1. Set DC voltage to 0.2 V . 

2. Select the diode. 

3. Set the resistor. 

4. Voltmeter is placed parallel to Silicon diode and ammeter series with resistor. 

5. The positive side of battery to the P side (anode) and the negative of battery to the N 

side (cathode) of the diode. 

6. Now vary the voltage up to 5V and note the Voltmeter and Ammeter reading for 

particular DC voltage . 

7. Take the readings and note Voltmeter reading across Silicon diode and Ammeter 

reading. 
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8. Plot the V-I graph and observe the change. 

9. Calculate the dynamic resistance of the diode. rd.=ΔV/ΔI 

10. Therefore from the graph we see that the diode starts conducting when the forward 

bias voltage exceeds around 0.6 volts (for Si diode). This voltage is called cut-in 

voltage. 

 

 

  

 

OBSERVATION TABLE 

Serial 

No. 

Forward 

Voltage(Volt) 

Forward Current(m -

Amp) 
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Experiment-2 

 AIM:     Study of I-V characteristics of Zener diodes. 

Component used: 

1. Zenger diode 

2. Bread Board 

3. Power supply 

4. Connecting wire 

6. DMM 

THEORY: 

In reverse biasing, the positive terminal of battery is connected to the N side and the 

negative terminal of battery is connected to the P side of a diode. In reverse biasing, the 

diode does not conduct electricity, since reverse biasing leads to an increase in the 

depletion region width; hence current carrier charges find it more difficult to overcome the 

barrier potential. The diode will act like an open switch and there is no current flow.  

 
 

When a diode is reverse biased a leakage current flows through the device. This current can 

be effectively ignored as long as the reverse breakdown voltage of the diode is not 

exceeded. At potentials greater than the reverse breakdown voltage, charge is pulled 

through the p-n junction by the strong electric fields in the device and large reverse current 

flows. This usually destroys the device. There are special diodes that are designed to 

operate in breakdown. Such diodes are called sneer diodes and used as voltage regulators. 
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 Zener Diode As A Voltage Regulator 

A voltage regulator is an electronic circuit that provides a stable DC voltage independent of 

the load current, temperature and AC line voltage variations. A Zener diode of break down 

voltage \(V_Z\) is reverse connected to an input voltage source \(V_I\) across a load 

resistance \(R_L\) and a series resistor \(R_S\). The voltage across the zener will remain 

steady at its break down voltage \(V_Z\) for all the values of zener current \(I_Z\)  as long as 

the current remains in the break down region. Hence a regulated DC output voltage \(V_0 = 

V_Z\) is obtained across \(R_L\), whenever the input voltage remains within a minimum and 

maximum voltage. Basically there are two type of regulations such as: 

Line Regulation: In this type of regulation, series resistance and load resistance are fixed, 

only input voltage is changing. Output voltage remains the same as long as the input 

voltage is maintained above a minimum value. 

Load Regulation: In this type of regulation, input voltage is fixed and the load resistance is 

varying. Output volt remains same, as long as the load resistance is maintained above a 

minimum value. 

 

 Line Regulation 
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Load Regulation 

 

 

 

Procedure 

Reverse Bias-Diode 

1. Set DC voltage to 0.2 V . 

2. Select the diode. 

3. Set the resistor. 

4. Voltmeter is placed parallel to diode and ammeter series with resistor. 

5. The positive side of battery to the P side(anode) and the negative of battery to the N 

side(cathode) of the diode. 

6. Now vary the voltage upto 5V and note the Voltmeter and Ammeter reading for 

particular DC voltage . 

7. Take the readings and note Voltmeter reading across diode and Ammeter reading. 

8. Plot the V-I graph and observe the change.  
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OBSERVATION TABLE 

Serial 

No. 

Reverse 

Voltage(Volt) 

Reverse 

Current(mAmp) 

   

   

   

   

   

 

 

OBSERVATION TABLE ( Line Regulation) 

Serial No. Supply Voltage(Volt) 

Diode 

 Voltage(Volt) 
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Experiment-3 

AIM:  Study thewave form of half wave and full wave rectifier  and determine its ripple 

factor.  

Component used: 

1.IN4007 

2.Bread Board 

3.Transformer 

4.Connecting wire 

6.DMM 

7. Capacitor 

8. Resistor 

Rectification 

 

A rectifier is a device that converts alternating current (AC) to direct current (DC), a process 

known as rectification. Rectifiers are essentially of two types – a half wave rectifier and a full 

wave rectifier. 

Half Wave Rectification 
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On the positive cycle the diode is forward biased and on the negative cycle the diode is 

reverse biased. By using a diode we have converted an AC source into a pulsating DC 

source. In summary we have ‘rectified’ the AC signal. 

 

 
 

 

The simplest kind of rectifier circuit is the half-wave rectifier .The half-wave rectifier is a 

circuit that allows only part of an input signal to pass. The circuit is simply the combination 

of a single diode in series with a resistor, where the resistor is acting as a load. 

 

Half Wave Rectifiers – Waveforms 

 

 

 

Half Wave Rectification: For Positive Half Cycle 
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Half Wave Rectification: For Negative Half Cycle 

 

Full Wave Rectifier 

A full-wave rectifier is exactly the same as the half-wave, but allows unidirectional current 

through the load during the entire sinusoidal cycle (as opposed to only half the cycle in the 

half-wave). A full-wave rectifier converts the whole of the input waveform to one of 

constant polarity (positive or negative) at its output.  

  

For a half wave Rectifier this is what we have observed 
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If we change the phase of the input waveform by 180 degrees 

 

Now if we add these two circuits, we would get 

 

Full Wave Rectifier - Circuit 

So, we have seen that this rectifier circuit consists of two sources which have a phase 

difference along with two diodes. When V1 is positive, V2 is negative. Hence the top 

diode(D1) will be a short and the bottom diode(D2) will be an open. On the other hand, 

when V1 is negative, V2 is positive. Hence the bottom diode(D2) will be on and the top 

diode(D1) will be an open circuit.  
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Ripple Voltage and Ripple Factor 

Assuming a finite capacitor is connected, since a new charging pulse occurs every half cycle 

the capacitor charges and discharges very frequently. We can observe that smaller the Vpp, 

the more the waveform will resemble a pure DC voltage. The variable portion is known as 

‘ripple’ and the value Vpp is known as the ripple voltage. Further the ratio of the ripple 

voltage to the DC or average voltage is known as the ripple factor. 

 

Half Wave vs Full Wave Capacitive Rectification 

If the capacitance and voltage sources used are the same, which one among the two – half 

wave or full wave gives lesser ripple effectThe advantage of a full-wave rectifier over a half-

wave is quite clear. The capacitor can more effectively reduce the ripple when the time 

between peaks is shorter. 
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  Combine circuit of Full Wave and Half wave 

 

 

    

OBSERVATION TABLE:       

Sl no. Vrms(Volt) VDC(Volt) Ripple factor 
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IDENTIFICATION OF BJT (PIN) 

  

 

 

 

characteristics of Bipolar junction transistor in various mode 
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Experiment-4 

AIM: To study the VI charecteistics of Bipolar junction transistor in CE mode and calculate 

the following: 

1. Voltage gain  

2. Current gain 

3. Input impedance 

4. Output impedance 

Component used: 

1.BC107 

2.Bread Board 

3.Connecting wire 

4.DMM 

5. Resistor 

Theory 

The common emitter configuration is widely used as a basic amplifier as it has both voltage 

and current amplification. Resistors \(R_{B1}\) and \(R_{B2}\) form a voltage divider across 

the base of the transistor. The function of this network is to provide necessary bias 

condition and ensure that emitter-base junction is operating in the proper region. In order 

to operate transistor as an amplifier, biasing is done in such a way that the operating point 

is in the active region. For an amplifier the Q-point is placed so that the load line is 

bisected. Therefore, in practical design \(V_{CE}\) is always set to \(V_{CC}/2\). This will 

confirm that the Q-point always swings within the active region. This limitation can be 

explained by maximum signal handling capacity. For the maximum input signal, output is 

produced without any distortion and clipping. 
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           Circuit diagram 

 

 

 

 

-  
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OBSERVATION TABLE: Input characteristic 

 

 

 

OBSERVATION TABLE: Output characteristic 

 

Sl no. IB=10µA IB=20µA 

 

 VCE   (volt)             IC (mA) VCE   (volt)          IC (mA) 
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Introduction 

There are 3 periods allocated to a laboratory session in Digital Electronics. It is a necessary 

part of the course at which attendance is compulsory.  

Here are some guidelines to help you perform the experiments and to submit the reports: 

1. Read all instructions carefully and carry them all out. 

2. Ask a demonstrator if you are unsure of anything. 

3. Record actual results (comment on them if they are unexpected!) 

4. Write up full and suitable conclusions for each experiment. 

5. If you have any doubt about the safety of any procedure, contact the demonstrator 

beforehand. 

6. THINK about what you are doing! 

 

 

 

 

 

 

 

 

 

 

 

 



SYLLABUS 

Basic Electronics Engineering Laboratory-I I 

There will be a couple of familiarization lectures before the practical classes are undertaken  

where basic concept of the instruments handled will be given.  

3 hours per week must be kept, initially for practical lectures, and later for tutorials.  

List of Experiments:  

1.Study of I-V characteristics of Field Effect Transistors. 

2.Determination of input-offset voltage, input bias current and Slew rate of OPAMPs.  

3.Determination of Common-mode Rejection ratio, Bandwidth and Off-set null of OPAMPs.  

4.Study of OPAMP circuits: Inverting and Non-inverting amplifiers, Adders, Integrators and 

Differentiators.  

5.Study of Logic Gates and realization of Boolean functions using Logic Gates.  

6.Study of Characteristic curves for CB, CE and CC mode transistors 

 

 

 

 

 

 

 

 

 

                                      Experiment-1 



AIM: To study the VI charecteistics of Bipolar junction transistor in CE mode and calculate 

the following: 

1. Voltage gain 

2. Current gain 

3. Input impedance 

4. Output impedance 

Component used: 

1.BC107 

2.Bread Board 

3.Connecting wire 

4.DMM 

5. Resistor 

6. Power supply 

 

Theory 

The common emitter configuration is widely used as a basic amplifier as it has both voltage 

and current amplification. Resistors \(R_{B1}\) and \(R_{B2}\) form a voltage divider across 

the base of the transistor. The function of this network is to provide necessary bias 

condition and ensure that emitter-base junction is operating in the proper region. In order 

to operate transistor as an amplifier, biasing is done in such a way that the operating point 

is in the active region. For an amplifier the Q-point is placed so that the load line is 

bisected. Therefore, in practical design \(V_{CE}\) is always set to \(V_{CC}/2\). This will 

confirm that the Q-point always swings within the active region. This limitation can be 

explained by maximum signal handling capacity. For the maximum input signal, output is 

produced without any distortion and clipping. 
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           Circuit diagram 



 

 

 

 

-  
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OBSERVATION TABLE: Input characteristic 



 

 

 

OBSERVATION TABLE: Output characteristic 

 

Sl no. IB=10µA IB=20µA 

 

 VCE   (volt)             IC (mA) VCE   (volt)          IC (mA) 
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Experiment-2 



AIM: To study the VI characteristics of Field effect transistor in n-channel mode and 

calculate the following: 

1. Drain resistance(rd) 

2. Amplification factor(µ)  

3. Transconductance (gm) 

Component used: 

1.BFW10 

2.Bread Board 

3.Connecting wire 

4.DMM 

5. Resistor 

6. Power supply 

 

THEORY 

The field-effect transistor (FET) is a type of transistor that uses an electric field to control 

the flow of current. FETs are devices with three terminals: source, gate, and drain. FETs 

control the flow of current by the application of a voltage to the gate, which in turn alters 

the conductivity between the drain and source. 

In an n-channel "depletion-mode" device, a negative gate-to-source voltage causes a 

depletion region to expand in width and encroach on the channel from the sides, narrowing 

the channel. If the active region expands to completely close the channel, the resistance of 

the channel from source to drain becomes large, and the FET is effectively turned off like a 

switch (see right figure, when there is very small current). This is called "pinch-off", and the 

voltage at which it occurs is called the "pinch-off voltage". Conversely, a positive gate-to-

source voltage increases the channel size and allows electrons to flow easily (see right 

figure, when there is a conduction channel and current is large). 
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In an n-channel "enhancement-mode" device, a conductive channel does not exist naturally 

within the transistor, and a positive gate-to-source voltage is necessary to create one. The 



positive voltage attracts free-floating electrons within the body towards the gate, forming a 

conductive channel. But first, enough electrons must be attracted near the gate to counter 

the dopant ions added to the body of the FET; this forms a region with no mobile carriers 

called a depletion region, and the voltage at which this occurs is referred to as the threshold 

voltage of the FET. Further gate-to-source voltage increase will attract even more electrons 

towards the gate which are able to create a conductive channel from source to drain; this 

process is called inversion. 
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Drain Characteristic 

 

SL no. VGS= 1V VGS = 2V 

 VDS  (V)             ID  ( mA) VDS  (V)             ID  ( mA) 

   

   

 

 

 

  Transfer characteristics 

 

Sl no. VDS= (V) 

  VGS   (V)     ID( (mA) 
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Experiment-3 
 

Experiment Name:  Realization of Basic gates using universal logic gates.  

 components used:  

  

1. Digital I.C Trainer Kit. 

2. Single strand wire. 

3. Cutter. 

4. Tweezers. 

5. I.C.—i) 7408 –AND ii) 7432-OR, iii)  7404-NOT ,iv) v) 7400-  NAND v) 7402- NOR 

 

THEORY:         BASIC GATES-       i) AND,  ii) OR, iii) NOT 

    

AND gate-    The AND gate is a basic digital logic gate that implements logical conjunction - it 

behaves according to the truth table to the right. A HIGH output (1) results only if all the inputs 

to the AND gate are HIGH (1). If none or not all inputs to the AND gate are HIGH, LOW 

output results. 

   Truth Table 

 
 

OR gate-    The AND gate is an electronic circuit that gives a high output (1) only if all its inputs 

are high.  A dot (.) is used to show the AND operation i.e. A.B.  Bear in mind that this dot is 

sometimes omitted i.e. AB                                                                                                                                                                                            

   Truth Table 

            

    

 

 

 

Input O/P 

X Y Z 

0 0 0 

0 1 0 

1 0 0 

1 1 1 

Input O/P 

X Y Z 

0 0 0 

0 1 1 

1 0 1 

1 1 1 
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NOT gate-     The NOT gate is an electronic circuit that produces an inverted version of the 

input at its output.  It is also known as an inverter.  If the input variable is A, the inverted 

output is known as NOT A.  This is also shown as A', or A with a bar over the top, as shown 

at the outputs. The diagrams below show two ways that the NAND logic gate can be 

configured to produce a NOT gate. It can also be done using NOR logic gates in the same 

way. 
 

  

 
    UNIVERSAL GATES-      i) NAND     ii) NOR 

 

NAND gate-  This is a NOT-AND gate which is equal to an AND gate followed by a NOT gate.  

The outputs of all NAND gates are high if any of the inputs are low. The symbol is an AND 

gate with a small circle on the output. The small circle represents inversion

Truth Table 

 

   
 NOR gate-   This is a NOT-OR gate which is equal to an OR gate followed by a NOT 

gate.  The outputs of all NOR gates are low if any of the inputs are high. 

The symbol is an OR gate with a small circle on the output. The small circle represents 

inversion. 

 

 
 

      

 

 

Input Output 

X Y 

0 1 

1 0 

Input O/P 

X Y Z 

0 0 1 

0 1 1 

1 0 1 

1 1 0 

Input O/P 

 X Y Z 

0 0 1 

0 1 0 

1 0 0 

1 1 0 
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CIRCUIT:    Basic gates using NAND  gates 

 

 

        

1

2
3

4

5
6

9

10
8

                                               

1

2
3

4

5
6

 
        OR gate using NAND gate                                                      AND gate using NAND  gate       

                                                         

1

2
3

 
                                                 NOT gate using NAND gate 

 

Basic gates using NOR gates 

 

2

3
1

5

6
4

8

9
10

                                      

2

3
1

5

6
4

 
 
AND gate using NOR gate                                                         OR gate using NOR gate 

 

     

2

3
1

 
     NOT gate using NOR gate 
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Experiment-4 

AIM: To study  and calculate the gain of different types of op-amp. They are 

1. INVERTING AMPLIFIER 

2. NON- INVERTING AMPLIFIER 

3. SUMMING AMPLIFIER 

4. INTEGRATING AMPLIFIER 

5. DIFFERENTIATOR 

components used: 

1. Op –amp Ic-741 

2. Bread board 

3. Resistor 

4. Capacitor 

5. Connecting wires 

THEORY 

Operational Amplifier commonly known as Op-Amp, is a linear electronic device 

having three terminals, two high impedance input and one output terminal. Op-Amp 

can perform multiple function when attached to different feedback combinations like 

resistive, capacitive or both. Generally it is used as voltage amplifier and the output 

voltage of the Op-Amp is the difference between the voltages at its two input 

terminals. 

  

 

Op-Amp shows some properties that make it an ideal amplifier, its open loop gain 

and input impedance is infinite (i.e. Practically very high), Output impedance and 

offset voltage is zero(i.e. Practically very low) and bandwidth is infinite(i.e. Practically 

limited to frequency where its gain become unity). 

Page-10 



Inverting Op-Amp: 

The open loop gain(Ao) of the Om-Amp is very high which makes it very unstable, 

so to make it stable with a controllable gain, a feed back is applied through some 

external resistor(Fry) from its output to inverting input terminal(i.e. Also known as 

negative feedback) resulting in reduced gain(closed loop gain, Av). So the voltage at 

inverting terminal is now the sum of the actual input and feedback voltages, and to 

separate both a input resistor(RI) is introduced in the circuit. The non inverting 

terminal of the pomp is grounded, and the inverting terminal behaves like a virtual 

ground as the junction of the input and feedback signal are at the same potential. 

 

 

The close loop gain (Acl) is given by :-    Acl=VoutVin=−RF/Rin 

Output voltage (Vout) is given by :-   Vout=−RF/Rin×Vin 

 

OBSERVATION TABLE: 

Sl no. Vin(volt) Av=-RF/Rin Vout (volt) 
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Non-Inverting Op-Amp 

In this configuration of Op-amp the input signal is directly fed to the non inverting 

terminal resulting in a positive gain and output voltage in phase with input as 

compared to inverting Op-amp where the gain is negative and output voltage is out 

of phase with input , and to stabalize the circuit a negative feedback is applied 

through a resistor(Rf) and the inverting terminal is grounded with input 

resistor(R2).This inverting Op-Amp like layout the at inverting terminal creates a 

virtual ground at the summing point make the Rf and R2 a potential divider across 

inverting terminal, Hence determines the gain of the circuit. 

 

    

 

Output Voltage (Vout) is given by: 

OBSERVATION TABLE: 

Sl no. Vin(volt) Av=1+RF/Rin Vout  (volt) 
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Summing amplifier 

Summing amplifier is basically an op amp circuit that can combine numbers of input 

signal to a single output that is the weighted sum of the applied inputs. The 

summing Amplifier is one variation of inverting amplifier. In inverting amplifier there 

is only one voltage signal applied to the inverting input as shown below, 

 

Summing Amplifier or Op Amp Adder Circuit Diagram 

 

 

 

 

OBSERVATION TABLE: 

Sl no. Vin(volt) Vout  (volt) 
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The Integrator 

It is a circuit designed with Op-Amp in such a way that it performs the mathematical 

Integration operation, its output is proportional to the amplitude and time duration 

of the input applied. The integrator circuit layout is same as a inverting amplifier but 

the feedback resistor is replaced by a capacitor which make the circuit frequency 

dependent. In this case the circuit is derived by the time duration of input applied 

which results in the charging and discharging of the capacitor. Initially when the 

voltage is applied to integrator the uncharged capacitor allows maximum current to 

pass through it and no current flows through the Op-Amp due to the presence of 

virtual ground, the capacitor starts to charge at the rate of RC time constant and its 

impedance starts to increase with time and a potential difference is develops across 

the capacitor resulting in charging current to decrease. This results in the ratio of 

capacitor's impedance and input resistance increasing causing a linearly increasing 

ramp output voltage that continues to increase until the capacitor becomes fully 

charged. 

 

Wave forms-  
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The Differentiator 

In the differentiator circuit the input is connected to the inverting output of the Op-

Amp through a capacitor(C) and a negetive feedback is provided to the inverting 

input terminal through a resistor(Rf), which is same as an integrator circuit with 

feedback capacitor and input resistor being replaced with each other. Here the 

circuit performs a mathematical differentiation operation, and the output is the first 

derivative of the input signal, 180' out of phase and amplified with a factor Rf*C. 

The capacitor on the input allows only the AC component and restrict the DC, at low 

frequency the reactance of capacitor is very high causing a low gain and high 

frequency vice versa but and high frequency the circuit becomes unstable. 

 

Wave forms 
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EXPERIMENT NO: 1 
 

Aim: - Introduction to Digital Electronics Lab- Nomenclature of Digital Ics, Specifications, 

Study of the Data Sheet, Concept of Vcc and Ground, Verification of the Truth Tables of 

Logic Gates using TTL Ics. 
 

APPARATUS REQUIRED: Power Supply, Digital Trainer Kit., Connecting Leads, IC’s (7400, 7402, 

7404, 7408, 7432, and 7486) 

 

BRIEF THEORY: 

 

AND Gate: The AND operation is defined as the output as (1) one if and only if all the inputs are (1) one. 

7408 is the two Inputs AND gate IC.A&B are the Input terminals &Y is the Output terminal. 

Y = A.B 

OR Gate: The OR operation is defined as the output as (1) one if one or more than 0 inputs are (1) one. 

7432 is the two Input OR gate IC. A&B are the input terminals & Y is the Output terminal. 

Y = A + B 

NOT GATE: The NOT gate is also known as Inverter. It has one input (A) & one output (Y). IC No. is 

7404. Its logical equation is, 

Y = A NOT B, Y = A’ 

NAND GATE: The IC no. for NAND gate is 7400. The NOT-AND operation is known as NAND 

operation. If all inputs are 1 then output produced is 0. NAND gate is inverted AND gate. 

Y = (A. B)’ 

NOR GATE: The NOR gate has two or more input signals but only one output signal. IC 7402 is two I/P 

IC. The NOT- OR operation is known as NOR operation. If all the inputs are 0 then the O/P is 1. NOR gate 

is inverted OR gate. 

 

Y = (A+B)’ 

 

EX-OR GATE: The EX-OR gate can have two or more inputs but produce one output. 7486 is two inputs 

IC. EX-OR gate is not a basic operation & can be performed using basic gates. 

Y = A B 
 

 

LOGIC SYMBOL:  
. Logic Symbol of Gates 
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1 

2 

3 

 

 

 
  1  

   3  3  
  2  

 

 
  1 2  

 

OR AND NOT 

 
 
 
 

 
  1      1  

   3  
  2      2  

 

NAND 

 

 

PIN CONFIGURATION: 

 
NOR XOR 

7400(NAND) 7402(NOR) 
 

 

7404(NOT) 7408 (AND) 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1 
3 

2 

   

   



                                         DSD LAB (EC392) 
  

DEPARTMENT OF ELECTRONICS & COMMUNICATION ENGINEERING  

SILIGURI INSTITUTE OF TECHNOLOGY  

 

5 

 

 
 

 

 

 
 

 

 

7486(EX-OR) 7432(OR) 
 

 
 

PROCEDURE:  
(a) Fix the IC’s on breadboard & give the supply. 

(b) Connect the +ve terminal of supply to pin 14 & -ve to pin 7. 

(c) Give input at pin 1, 2 & take output from pin 3. It is same for all except NOT & 

NOR IC. 

(d) For NOR, pin 1 is output & pin 2&3 are inputs. 

(e) For NOT, pin 1 is input & pin 2 is output. 

(f) Note the values of output for different combination of inputs & draw the 

TRUTH TABLE. 
 

OBSERVATION TABLE: 

 

INPUTS OUTPUTS 

A B A’ A+B (A+B)’ (A*B) (A*B )’ (A B) 
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  NOT OR NOR AND NAND Ex-OR 

0 0 1 0 1 0 1 0 

0 1 1 1 0 0 1 1 

1 0 0 1 0 0 1 1 

1 1 0 1 0 1 0 0 
 

 

RESULT: We have learnt all the gates ICs according to the IC pin diagram. 

 

PRECAUTIONS: 

 

1. Make the connections according to the IC pin diagram. 

2. The connections should be tight. 

3. The Vcc and ground should be applied carefully at the specified pin only. 

 

 

 

 

Quiz Questions with answer. 

 

 Define gates ? 

 

Ans. Gates are the digital circuits, which perform a specific type of logical operation. 

 

 Define IC? 

Ans. IC means integrated circuit. It is the integration of no. of components on a common substrate. 

 Give example of Demorgan’s theorem. 

Ans. (AB)’=A’+B’ 

(A+B)’=A’.B’ 

 (A+A) A =? 

Ans. A. 

Q5 Define Universal gates. 

Ans. Universal gates are those gates by using which we can design any type of logical expression. 

Q6.Write the logical equation for AND gate. 

Ans. Y=A.B 

Q7 How many no. of input variables can a NOT Gate have? 

Ans. One. 

Q8.Under what conditions the output of a two input AND gate is one? 

Ans. Both the inputs are one. 

Q9.1+0 =? 

Ans. 1 

Q10.When will the output of a NAND Gate be 0? 

Ans. When all the inputs are 1. 
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EXPERIMENT NO: 2 
 

Aim: Implementation of the Given Boolean Function using Logic Gates in Both Sop 

and Pos Forms. 

 

APPARATUS REQUIRED: Power Supply, Digital Trainer, IC’s (7404, 7408, 7432) Connecting 

leads. 

 

BRIEF THEORY: Karnaugh maps are the most extensively used tool for simplification of Boolean 

functions. It is mostly used for functions having up to six variables beyond which it becomes very 

cumbersome. In an n-variable K-map there are 2ⁿ cells. Each cell corresponds to one of the combination of n 

variable, since there are 2ⁿ combinations of n-variables. Gray code has been used for the identification of 

cells. 

 

Example- f (A, B, C, D) =A’BC+AB’C+ABC’+ABC (SOP) 

 

Reduced form is BC+AC+AB and POS form is f(X, Y, Z) = Y’ (X’+Y+Z’) (X+Z) 
 

LOGIC DIAGRAM  
SOP form 

 
 

 

POS Form 
 

 



DSD LAB (EC392) 
 

DEPARTMENT OF ELECTRONICS & COMMUNICATION ENGINEERING 

 SILIGURI INSTITUTE OF TECHNOLOGY  

 

8 

 

 

 

 

 

 

 

 

 

PROCEDURE: 
 

(a) With given equation in SOP/POS forms first of all draw a K-map. 

(b) Enter the values of the O/P variable in each cell corresponding to its Min/Max 

term. 

(c) Make group of adjacent ones. 

(d) From group write the minimized equation. 

(e) Design the ckt. of minimized equation & verify the truth table. 
 

RESULT/CONCLUSION: Implementation of SOP and POS form is obtained with AND and OR gates. 

 

PRECAUTIONS: 

1) Make the connections according to the IC pin diagram. 

2) The connections should be tight. 

3) The Vcc and ground should be applied carefully at the specified pin only. 

 

Quiz Questions with answer. 

 

 Define K-map ? 

Ans. It is a method of simplifying Boolean Functions in a systematic mathematical way. 

Define SOP ? Ans. 

Sum of Product. 

Define POS ? Ans. 

Product of Sum. 

 What are combinational circuits? 

Ans. These are those circuits whose output depends upon the inputs present at that instant of time. 

 What are sequential circuits? 

Ans. These are those circuits whose output depends upon the input present at that time as well as the 

previous output. 

If there are four variables how many cells the K-map will have? 

Ans. 16. 

When two min-terms can be adjacent? 

Ans. 2 to the power n. 

Which code is used for the identification of cells? 

Ans8. Gray Code. 

 Define Byte? 

Ans. Byte is a combination of 8 bits. 

When simplified with Boolean Algebra (x + y)(x + z) simplifies to Ans. 

x + yz 
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 EXPERIMENT NO: 3 
 

Aim: Verification of State Tables of Rs, J-k, T and D Flip-Flops using NAND & NOR 

Gates 
 

APPARATUS REQUIRED: IC’ S 7400, 7402 Digital Trainer & Connecting leads. 

 

BRIEF THEORY: 

 

• RS FLIP-FLOP:    There are two inputs to the flip-flop defined as R and S. When I/Ps R = 0 and S 

= 0 then O/P remains unchanged. When I/Ps R = 0 and S = 1 the flip-flop is switches to the stable 

state where O/P is 1 i.e. SET. The I/P condition is R = 1 and S = 0 the flip-flop is switched to the 

stable state where O/P is 0 i.e. RESET. The    I/P condition is R = 1 and S = 1 the flip-flop is 

switched to the stable state where O/P is forbidden. 

 

• JK FLIP-FLOP:  For purpose of counting, the JK flip-flop is the ideal element to use. The 

variable J and K are called control I/Ps because they determine what the flip- flop does when 

a positive edge arrives. When J and K are both 0s, both AND gates are disabled and Q retains its last 

value. 

 

• D FLIP –FLOP:     This kind of flip flop prevents the value of D from reaching the Q output 

until clock pulses occur. When the clock is low, both AND gates are disabled D can change 

value without affecting the value of Q. On the other hand, when the clock is high, both AND 

gates are enabled. In this case, Q is forced to equal the value of D. When the clock again goes 

low, Q retains or stores the last value of D. a D flip flop is a bistable circuit whose D input is 

transferred to the output after a clock pulse is received. 

 
 

• T FLIP-FLOP: The T or "toggle" flip-flop changes its output on each clock edge, giving an 

output which is half the frequency of the signal to the T input. It is useful for constructing binary 

counters, frequency dividers, and general binary addition devices. It can be made from a J-K flip- 

flop by tying both of its inputs high. 

 

CIRCUIT DIAGRAM: 

SR Flip Flop D Flip Flop 
 

JK Flip Flop T Flip Flop 
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DRONACHARA 

 

 

 

 
 

 
 

PROCEDURE: 

1. Connect the circuit as shown in figure. 

2. Apply Vcc & ground signal to every IC. 

3. Observe the input & output according to the truth table. 

 

TRUTH TABLE: 

SR FLIP FLOP: 

 

CLOCK S R Qn+1 

1 0 0 NO CHANGE 

1 0 1 0 

1 1 0 1 

1 1 1 ? 

 

D FLIPFLOP: 

 

INPUT OUTPUT 

0 0 

1 1 

 

JK FLIPFLOP 

 

CLOCK S R Qn+1 

1 0 0 NO CHANGE 

1 0 1 0 

1 1 0 1 

1 1 1 Qn’ 

 

T FLIPFLOP 

 

CLOCK S R Qn+1 
 



                                         DSD LAB (EC392) 
  

DEPARTMENT OF ELECTRONICS & COMMUNICATION ENGINEERING  

SILIGURI INSTITUTE OF TECHNOLOGY  

 

11 

 

DRONACHARA 

 

 

 

1 0 1 NO CHANGE 

1 1 0 Qn’ 

RESULT: Truth table is verified on digital trainer. 

 

 

PRECAUTIONS: 

 

1) Make the connections according to the IC pin diagram. 

2) The connections should be tight. 

3) The Vcc and ground should be applied carefully at the specified pin only. 

 

 

 

Quiz Questions with answer. 

 

Q 1.Flip flop is Astable or Bistable? 

Ans. Bistable. 

Q2.What are the I/Ps of JK flip–flop where this race round condition occurs? 

Ans. Both the inputs are 1. 

Q3.When RS flip-flop is said to be in a SET state? 

Ans. When the output is 1. 

Q4.When RS flip-flop is said to be in a RESET state? 

Ans. When the output is 0. 

Q5.What is the truth table of JK flip-flop? 

J K Qn+1 

0 0 Qn 

0 1 0 

1 0 1 

1 1 Qn,
’
 

Q6.What is the function of clock signal in flip-flop? 

Ans. To get the output at known time. 

Q7.What is the advantage of JK flip-flop over RS flip-flop? 

Ans. In RS flip-flop when both the inputs are 1 output is undetermined. 

Q8.In D flip-flop I/P = 0 what is O/P? 

Ans.0 

Q9.In D flip-flop I/P = 1 what is O/P? 

Ans.1 

Q10.In T flip-flop I/P = 1 what is O/P? 

Ans. Qn 
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  EXPERIMENT NO: 4 

Aim:- Implementation and Verification of Decoder/De-Multiplexer and Encoder using 

Logic Gates. 
 

APPARATUS REQUIRED: IC 7447, 7-segment display, IC 74139 and connecting leads. 
 

BRIEF THEORY: 

 

ENCODER: An encoder is a device, circuit, transducer, software program, algorithm or person that 

converts information from one format or code to another, for the purposes of standardization, speed, 

secrecy, security, or saving space by shrinking size. An encoder has M input and N output lines. Out of M 

input lines only one is activated at a time and produces equivalent code on output N lines. If a device output 

code has fewer bits than the input code has, the device is usually called an encoder. For example Octal-to- 

Binary Encoder take 8 inputs and provides 3 outputs, thus doing the opposite of what the 3-to-8 decoder 

does. At any one time, only one input line has a value of 1. The figure below shows the truth table of an 

Octal-to-binary encoder. 

 

For an 8-to-3 binary encoder with inputs I0-I7 the logic expressions of the outputs Y0-Y2 are: 

 
 

Y0 = I1 + I3 + I5 + I7 

Y1= I2 + I3 + I6 + I7 

Y2 = I4 + I5 + I6 +I7 

DECODER: A decoder is a device which does the reverse operation of an encoder, undoing the encoding 

so that the original information can be retrieved. The same method used to encode is usually just reversed in 

order to decode. It is a combinational circuit that converts binary information from n input lines to a 

maximum of 2n unique output lines. In digital electronics, a decoder can take the form of a multiple-input, 

multiple-output logic circuit that converts coded inputs into coded outputs, where the input and output codes 

are different. e.g. n-to-2n, binary-coded decimal decoders. Enable inputs must be on for the decoder to 

function, otherwise its outputs assume a single "disabled" output code word. In case of decoding all 

combinations of three bits eight (23=8) decoding gates are required. This type of decoder is called 3-8 

decoder because 3 inputs and 8 outputs. For any input combination decoder outputs are 1. 

 
 

DEMULTIPLEXER: Demultiplexer means generally one into many. A demultiplexer is a logic circuit 

with one input and many outputs. By applying control signals, we can steer the input signal to one of the 

output lines. The ckt.   has one input signal, m control signal and n output signals. Where 2n = m. It 

functions as an electronic switch to route an incoming data signal to one of several outputs. 

 

LOGIC DIAGRAM: 
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3:8 Decoder Octal to Binary Encoder 
 

1:4 Demux 
 

 
PROCEDURE: 

1) Connect the circuit as shown in figure. 

2) Apply Vcc & ground signal to every IC. 

3) Observe the input & output according to the truth table. 

OBSERVATION TABLE: 

 

 

Truth table for Decoder 
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Truth table for Encoder Truth table for Demux 
 

 
RESULT: Encoder/ decoder and demultiplexer have been studied and verified. 

 
PRECAUTIONS: 

 
1) Make the connections according to the IC pin diagram. 

2) The connections should be tight. 

3) The Vcc and ground should be applied carefully at the specified pin only. 

 
 

Quiz Questions with answer. 

 

Q. 1 What do you understand by decoder? 

Ans. A decoder is a combinational circuit that converts binary information from n input lines to a 

maximum of 2n unique output lines. Most IC decoders include one or more enable inputs to control the 

circuit operation. 

Q. 2 What is demultiplexer? 

 



DSD LAB (EC392) 
 

DEPARTMENT OF ELECTRONICS & COMMUNICATION ENGINEERING  

SILIGURI INSTITUTE OF TECHNOLOGY  

 

15 

 

 

 

 

Ans. The demultiplexer is the inverse of the multiplexer, in that it takes a single data input and n address 

inputs. It has 2n outputs. The address input determine which data output is going to have the same value 

as the data input. The other data outputs will have the value 0. 

Q. 3 What do you understand by encoder? 

Ans. An encoder or multiplexer is therefore a digital IC that outputs a digital code based on which of 

its several digital inputs is enabled. 
Q. 4 What is the main difference between decoder and demultiplexer? 

Ans. In decoder we have n input lines as in demultiplexer we have n select lines. 

Q. 5 Why Binary is different from Gray code? 

Ans. Gray code has a unique property that any two adjacent gray codes differ by only a single bit. 

Q. 6 Write down the method of Binary to Gray conversion. 

Ans. Using the Ex-Or gates. 

Q. 7 Convert 0101 to Decimal. 

Ans. 5 

Q. 8 Write the full form of ASCII Codes? 

Ans. American Standard Code for Information Interchange. 

Q.9. If a register containing 0.110011 is logically added to register containing 0.101010 what would be 

the result? 

Ans.111011 

Q10.Binary code is a weighted code or not? 

Ans. Yes 
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EXPERIMENT NO : 5 
 

Aim: Implementation of 4x1 Multiplexer using Logic Gates. 

 

APPARATUS REQUIRED: Power Supply, Digital Trainer, Connecting Leads, IC’s 74153(4x1 

multiplexer). 

 

BRIEF THEORY: 

 

MULTIPLEXER: Multiplexer generally means many into one. A multiplexer is a circuit with many 

Inputs but only one output. By applying control signals we can steer any input to the output .The fig. (1) 

Shows the general idea. The ckt. has n-input signal,    control signal & one output signal. Where 2n = m. 

One of the popular multiplexer is the 16 to 1 multiplexer, which has 16 input bits, 4 control bits & 1 output 

bit. 
 

PIN CONFIGURATION;–  
IC 74153 (4x1 multiplexer) 

 

 
 

LOGIC DIAGRAM:  
 

Multiplexer (4x1) IC 74153 
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PROCEDURE: 
 

1. Fix the IC's on the bread board &give the input supply. 

2. Make connection according to the circuit. 

3. Give select signal and strobe signal at respective pins. 

4. Connect +5 v Vcc supply at pin no 24 & GND at pin no 12. 

5. Verify the truth table for various inputs. 
 

OBSERVATION TABLE: 

 

Truth Table of multiplexer (4x1) IC 74153 
 

 

RESULT: Verify the truth table of multiplexer for various inputs. 

PRECAUTIONS: 
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1) Make the connections according to the IC pin diagram. 

2) The connections should be tight. 

3) The Vcc and ground should be applied carefully at the specified pin only. 

 

Quiz Questions with answer. 

 

Why is MUX called as “Data Selector”? 

Ans. This selects one out of many inputs. 

 What do you mean by Multiplexing? 

Ans. Multiplexing means selecting only a single input out of many inputs. 

 What is Digital Multiplexer? 

Ans. The multiplexer which acts on digital data. 

What is the function of Enable input to any IC? 

Ans. When this enable signal is activated. 

 What is demultiplexer? 

Ans. A demultiplexer transmits the data from a single source to various sources. 

Can a decoder function as a D’MUX? 

Ans. Yes 

What is the role of select lines in a Demultiplexer? 

Ans. Select line selects the output line. 

 Differentiate between functions of MUX & D’MUX? 

Ans. Multiplexer has only single output but demultiplexer has many outputs. 

The number of control lines required for a 1:8 demultiplexer will be 

Ans. 3 

How many 4:1 multiplexers will be required to design 8:1 multiplexer? Ans. 

2 
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EXPERIMENT NO - 6 
 

 

Aim – Implementation of 4-Bit Parallel Adder Using 7483 Ic. 

 

APPRATUS REQUIRED – Digital trainer kit, IC 7483 (4-bit parallel adder). 

 

BRIEF THEOR - A 4-bit adder is a circuit which adds two 4-bits numbers, say, A and B. In addition, a 
4-bit adder will have another single-bit input which is added to the two numbers called the carry-in (C

in
). 

The output of the 4-bit adder is a 4-bit sum (S) and a carry-out (C
out

) bit. 
 

PIN CONFIGURATION–  
Pin Diagram of IC 7483 

 
 

 

 

LOGIC DIAGRAM:- 
 

 

7483 4-bit Parallel Adder 
 
 

 
 

IC 7483 
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OBSERVATION TABLE –  
Truth table of 4-bit parallel adder 

 

 
 

PROCEDURE – 

a) Make the connections as per the logic diagram. 

b) Connect +5v and ground according to pin configuration. 

c) Apply diff combinations of inputs to the i/p terminals. 

d) Note o/p for summation. 

e) Verify the truth table. 

 

RESULT- Binary 4-bit full adder is studied and verified. 

 

PRECAUTIONS: 

1. Make the connections according to the IC pin diagram. 

2. The connections should be tight. 

3. The Vcc and ground should be applied carefully at the specified pin only. 

 

Quiz Questions with answer. 

 

Q 1 What do you understand by parallel adder? 

Ans. If we place full adders in parallel, we can add two- or four-digit numbers or any other size desired 

i.e. known as parallel adder. 

Q2 What happens when an N-bit adder adds two numbers whose sum is greater than or equal to 2N 

Ans. Overflow. 

Q3 Is Excess-3 code is weighted code or not? 

Ans. Excess-3 is not a weighted code. 

Q4 What is IC no. of parallel adder? 

Ans. IC 7483. 

Q5 What is the difference between Excess-3 & Natural BCD code? 

Ans. Natural BCD code is weighted code but Excess-3 code is not weighted code. 

Q6. What is the Excess-3 code for (396)10 

Ans. (396)10 = (011011001001)EX-3 

Q7 Can we obtain 1’s complement using parallel adder? 

Ans. Yes 

Q8 Can we obtain 2’s complement using parallel adder? 

Ans. yes 

Q9 How many bits can be added using IC7483 parallel adder? 
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Ans. 4 bits. 

Q10 Can you obtain subtractor using parallel adder? 

Ans. Yes 

EXPERIMENT NO :7 
 

Aim: – Design, and Verify the 4-Bit Synchronous Counter 
 

APPARATUS REQUIRED: Digital trainer kit and 4 JK flip flop each IC 7476 (i.e dual JK flip flop) and 

two AND gates IC 7408. 

 

BRIEF THEORY: Counter is a circuit which cycle through state sequence. Two types of counter, 

Synchronous counter (e.g. parallel) and Asynchronous counter (e.g. ripple). In Ripple counter same flip-flop 

output to be used as clock signal source for other flip-flop. Synchronous counter use the same clock signal 

for all flip-flop. 

 

PIN CONFIGURATION: 

Dual JK Master Slave Flip Flop with clear & preset 
 

 

 

LOGIC DIAGRAM:  
4- Bit Synchronous counter 
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DRONACHARA 

 

 

 

 

 

Pin Number Description 

1 Clock 1 Input 

2 Preset 1 Input 

3 Clear 1 Input 

4 J1 Input 

5 Vcc 

6 Clock 2 Input 

7 Preset 2 Input 

8 Clear 2 Input 

9 J2 Input 

10 Complement Q2 Output 

11 Q2 Output 

12 K2 Input 

13 Ground 

14 Complement Q1 Output 

15 Q1 Output 

16 K1 Input 
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DRONACHARA 

 

 

 

OBSERVATION TABLE:  
Truth Table 

 

 
States 

 

Count 

04 03 02 01 

0 0 0 0 0 

0 0 0 1 1 

0 0 1 0 2 

0 0 1 1 3 

0 1 0 0 4 

0 1 0 1 5 

0 1 1 0 6 

0 1 1 1 7 

1 0 0 0 8 

1 0 0 1 9 

1 0 1 0 10 

1 0 1 1 11 

1 1 0 0 12 

1 1 0 1 13 

1 1 1 0 14 

1 1 1 1 15 

 

PROCEDURE: 

a) Make the connections as per the logic diagram. 

b) Connect +5v and ground according to pin configuration. 

c) Apply diff combinations of inputs to the i/p terminals. 

d) Note o/p for summation. 

e) Verify the truth table. 

 

RESULT: 4-bit synchronous counter studied and verified. 
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PRECAUTIONS: 

1. Make the connections according to the IC pin diagram. 

2. The connections should be tight. 

3. The Vcc and ground should be applied carefully at the specified pin only. 

 

Quiz Questions with answer. 

 

Q.1 What do you understand by counter? 

Ans. Counter is a register which counts the sequence in binary form. 

Q.2What is asynchronous counter? 

Ans. Clock input is applied to LSB FF. The output of first FF is connected as clock to next FF. 

Q.3What is synchronous counter? 

Ans. Where Clock input is common to all FF. 

Q.4Which flip flop is used in asynchronous counter? 

Ans. All Flip-Flops are toggling FF. 

Q.5Which flip flop is used in synchronous counter? 

Ans. Any FF can be used. 

 What do you understand by modulus? 

Ans. The total no. of states in counter is called as modulus. If counter is modulus-n, then it has n 

different states. 

 What do you understand by state diagram? 

Ans. State diagram of counter is a pictorial representation of counter states directed by arrows in graph. 

 What do you understand by up/down counter? 

Ans. Up/Down Synchronous Counter: two way counter which able to count up or down. 

 Why Asynchronous counter is known as ripple counter? 

Ans. Asynchronous Counter: flip-flop doesn’t change condition simultaneously because it doesn’t use 

single clock signal Also known as ripple counter because clock signal input as ripple through counter. 

which type of counter is used in traffic signal? Ans. 

Down counters. 
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EXPERIMENT NO: 8 

Aim: – Design, and Verify the 4-Bit Asynchronous Counter. 
 

APPARATUS REQUIRED: Digital trainer kit and 4 JK flip flop each IC 7476 (i.e dual JK flip flop) and 

two AND gates IC 7408. 

 

BRIEF THEORY: Counter is a circuit which cycle through state sequence. Two types of counter, 

Synchronous counter (e.g. parallel) and Asynchronous counter (e.g. ripple). In Ripple counter same flip-flop 

output to be used as clock signal source for other flip-flop. Synchronous counter use the same clock signal 

for all flip-flop. 
 

PIN CONFIGURATION:  
 

Pin diagram of JK M/S Flip Flop 
 

 
 
 

LOGIC DIAGRAM:  
4-Bit Asynchronous counter 
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Pin Number Description 

1 Clock 1 Input 

2 Preset 1 Input 

3 Clear 1 Input 

4 J1 Input 

5 Vcc 

6 Clock 2 Input 

7 Preset 2 Input 

8 Clear 2 Input 

9 J2 Input 

10 Complement Q2 Output 

11 Q2 Output 

12 K2 Input 

13 Ground 

14 Complement Q1 Output 

15 Q1 Output 

16 K1 Input 
 

PROCEDURE: 

a) Make the connections as per the logic diagram. 

b) Connect +5v and ground according to pin configuration. 

c) Apply diff combinations of inputs to the i/p terminals. 

d) Note o/p for summation. 

e) Verify the truth table. 

 

RESULT: 4-bit asynchronous counter studied and verified. 

 

PRECAUTIONS: 

1. Make the connections according to the IC pin diagram. 

2. The connections should be tight. 

3. The Vcc and ground should be applied carefully at the specified pin only. 

 

Quiz Questions with answer. 

 

How many flip-flops are required to make a MOD-32 binary 

counter? Ans. 5. 

 The terminal count of a modulus-11 binary counter is . 
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Ans.1010. 

Synchronous counters eliminate the delay problems encountered with asynchronous counters 

because the: 

Ans. Input clock pulses are applied simultaneously to each stage. 

 

 
Q4. Synchronous construction reduces the delay time of a counter to the delay of: 

Ans. a single flip-flop and a gate. 

Q5. What is the difference between a 7490 and a 7492? 

Ans.7490 is a MOD-10, 7492 is a MOD-12. 

Q6. When two counters are cascaded, the overall MOD number is equal to the 

    of their individual MOD numbers. 

Ans. Product. 

Q7. A BCD counter is a . 

Ans. decade counter. 

Q8. What decimal value is required to produce an output at "X" ? 

 

 
Ans.5. 

 

Q9. How many AND gates would be required to completely decode ALL the states of 

a MOD-64 counter, and how many inputs must each AND gate have? 

 

Ans. 64 gates, 6 inputs to each gate. 

Q.10 A ring counter consisting of five Flip-Flops will have 

Ans. 5 states. 
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EXPERIMENT NO: 9 
SILIGURI INSTITUTE OF TECHNOLGY 

ELECTRONICS &COMMUNICATION ENGINEERING DEPARTMENT 

DIGITAL SYSTEM DESIGN LAB. 
        PAPER CODE:EC392 

 
 

       AIM:        Design and implementation of INVERTER Circuit using T-SPICE. 
 
         

        OBJECTIVE : 
 

                     Design & Implementation of an INVERTER Circuit using T-SPICE. 

 

THEORY: 

Inverter is a circuit that inverts the input. When the input is high then the 
output will be low that means when input is 1 output is 0 and when the input 
is low the output will be high that means if input is 0, output will be 1. 

 
 

TRUTH TABLE  :- 
                                                            

           

   

 

 

 

BOOLEAN EXPRESSION :  
                                           Y = X’ 

 

 

 

 

 

 

 

 

 

INPUT OUTPUT 

0 1 

1 0 
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CIRCUIT DIAGRAM:    

                       

 

  

• ANALYSIS/CIRCUIT DESCRIPTION:  
 

In this experiment, we have used CMOS logic design technique.  

Here f = Vin’ 

So, f’ = Vin 

 Now use f for pMOS circuit design & use f’ for nMOS circuit design. Where boolean (.) 
indicate series operation and Boolean (+) signifies parallel operation. Based on this, we 
built the given circuit and simulate using TSPICE to observe the output waveform. 

As per the above methodology one pMOS connected in series with an nMOS. Collecting 
output from their common node mentioned as Vout. 

 

We gave two common inputs (Vin) to both the circuit parts. 
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• NETLIST :  
 

* Waveform probing commands 

.probe 

.options probefilename=" inverter.dat" 

+ probesdbfile="D:\inverter.sdb" 

+ probetopmodule ="inverter" 

 

* Main circuit: inverter 

M1 Vb Va Gnd Gnd NMOS L=2u W=22u AD=66p PD=24u AS=66p PS=24u  

M2 Vb Va Vdd Vdd PMOS L=2u W=22u AD=66p PD=24u AS=66p PS=24u 

v3 Va Gnd bit({0101} pw=100n on=5.0 off=0.0 rt=1n ft=1n delay=0 lt=100n ht=100n) 

.include "C:\Program Files\Tanner EDA\Demo\T-Spice\models\ml2_20.md" 

Vdd Vdd Gnd 5v 

.Tran 1n 800n 

.print V(Vin),V(Vout) 

• End of main circuit: inverter 
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OUTPUT WAVEFORM: 

 

 

 

 

CONCLUSION: 

 

After performing the above experiment we come to know about the operation of a NOT 
gate using T-SPICE .here we have performed the operation of a  1 input NOT gate which 
is basically a inverting  operation of input. We have done dc & transient operation of the 
NOT gate. In the dc operation there is lots of noise interference in the output waveform 
which are eliminated in the transient operation by using source voltage bit instead of a dc 
input. As a result we got a output waveform as shown above. 
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EXPERIMENT NO :10 
 

SILIGURI INSTITUTE OF TECHNOLGY 

ELECTRONICS &COMMUNICATION ENGINEERING DEPARTMENT 

DIGITAL SYSTEM DESIGN LAB. 
PAPER CODE: EC392 

 

AIM:- Design & Implementation of 8:1 Multiplexer circuit using VHDL 

OBJECTIVE:- To design and implement a 8:1 Multiplexer using VHDL with the help of Xilinx ISE. 

THEORY:- 

Multiplexing is the process of transmitting a large number of information over a single line. A digital MUX is a 
combinational circuit that selects one 

digital information from several sources and transmits the selected information on a single output line. A MUX is 
also called adata selector. The selection of of a particular input line is controlled by a set of select lines. 

Truth table :- 

INPUTS OUTPUTS 

E’ S2 S1 S0 Y Y’ 

1 X X X 1 0 

0 0 0 0 D0 D0’ 

0 0 0 1 D1 D1’ 

0 0 1 0 D2 D2’ 

0 0 1 1 D3 D3’ 

0 1 0 0 D4 D4’ 

0 1 0 1 D5 D5’ 

0 1 1 0 D6 D6’ 

0 1 1 1 D7 D7’ 
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Boolean Expression:-  

 
              Y=ABCD+AB’CD+A’B’CD+A’BC’D+A’B’C’D+ABCD’+A’BCD’+ AB’CD’+A’BC’D’+AB’C’D’ 

 
SCHEMATIC DIAGRAM OF THE CIRCUIT:- 

 

 

 

       VHDL PROGRAM:- 

  

    Port ( Sl,A,B : in std_logic; 

               Y : out std_logic); 

 end Component; 

 

           Component mux4_1 is 

           Port ( I : in std_logic_vector(3 downto 0); 

           S : in std_logic_vector(1 downto 0); 

           YOUT : out std_logic); 

 end Component; 

 

     begin 

   L1:mux4_1 port map(A(7 downto 4),Sel(1 downto 0),Sig0); 

   L2:mux4_1 port map(A(3 downto 0),Sel(1 downto 0),Sig1); 

   L3:mux2_1 port map(Sel(2),Sig1,Sig0,Y0); 
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            end Structure; 

 

         OUTPUT WAVEFORM:- 

 

 

 

CONCLUSION:- 

A Multiplexer is a combinational circuit thar selects one digital information from several sources and transmits 
the selected information on a single output line with the help of a set of selection lines. Any Boolean or Logical 
expression can be easily implemented using a multiplexer. If a Boolean Expression has (n+1) variables then n of 
these variables can be connected to the select lines of a multiplexer. Here we have used the Structural process 
to build the program for 8:1 Multiplexer in Xilinx ISE. 
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EXPERIMENT NO: 11 
 

 

SILIGURI INSTITUTE OF TECHNOLGY 

ELECTRONICS &COMMUNICATION ENGINEERING DEPARTMENT 

DIGITAL SYSTEM DESIGN LAB. 
PAPER CODE:EC 392 

 

AIM: 
 Design and implementation of CMOS T-SPICE 
 

OBJECTIVE:-  

To design and implementation of a two input NAND gate using TSPICE and analyze the Transient 
characteristics of output waveform. 

 

THEORY: 

 

If we take Va as 1st input of the NAND gate, & Vb as 2nd input of the NAND gate then output can 
be expressed as- 

                  Vout = (Va.Vb)’. 

Which may also be expressed as- Vout = (Va.Vb)’ = Va’+Vb’. 

It must be noted as the output of this circuit is just the opposite of AND gate (initially observed).  

 

 

TRUTH TABLE: 

      Va       Vb      Va.Vb    (Va.Vb)’ 

        0         0        0          1 

        0         1        0          1 
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BOOLEAN EXPRESSION:  

 

                           Vout = (Va.Vb)’ = Va’ + Vb’. 

 

 

SCHEMATIC  DIAGRAM  OF THE CIRCUIT: 

 

 

        1         0        0          1 

        1         1        1          0 
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CIRCUIT DESCRIPTION:  

 

In this experiment, we have used CMOS logic design technique.  

Here f = (Va.Vb)’=Va’ +Vb’ 

So, f’ = ((Va.Vb)’)’=Va.Vb 

 Now use f for  pMOS circuit design & use f’ for nMOS circuit design. Where boolean (.) indicate 
series operation and Boolean (+) signifies parallel operation.Based on this, we built the given 
circuit and simulate using TSPICE to observe the output waveform. 

As per the above methodology two pMOS connected in parallel and two nMOS connected in 
series. Collecting output from their common node mentioned as Vout. 

 

We gave two common inputs (Va and Vb) to both the circuit parts. 

 

NETLIST: 

 

* SPICE netlist written by S-Edit Win32 Demo 9.12 

* Written on Apr 2, 2009 at 10:45:05 

 

* Waveform probing commands 

 

.probe 

.options probefilename="NAND_GATE.dat" 

+ probesdbfile="G:\ NAND_GATE.sdb" 

+ probetopmodule=" NAND_GATE” 

 

* Main circuit: NAND_GATE 
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M1 vout vin1 N2 N2 NMOS L=2u W=44u AD=66p PD=24u AS=66p PS=24u 

 M2 N2 vin2 Gnd Gnd NMOS L=2u W=44u AD=66p PD=24u AS=66p PS=24u 

 M3 vout vin1 Vdd Vdd PMOS L=2u W=22u AD=66p PD=24u AS=66p PS=24u 

M4 Vdd vin2 vout Vdd PMOS L=2u W=22u AD=66p PD=24u AS=66p PS=24u 

v5 vin1 Gnd bit ({0100} pw=100n on=5.0 off=0.0 rt=1n ft=1n delay=0 lt=100n ht=100n) 

v6 vin2 Gnd bit ({1111} pw=100n on=5.0 off=0.0 rt=1n ft=1n delay=0 lt=100n ht=100n) 

 

.include "C:\Program Files\Tanner EDA\Demo\T-Spice\models\ml2_125.md" 

vdd vdd gnd 5 

 

.tran 1n 400n 

  

.print tran v(vin1) v(vin2) v(vout) 
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OUTPUT WAVEFORM: 

 

 

 

 

CONCLUSION: 

After performing the above experiment we come to know about the operation of a NAND gate 
using T-SPICE .here we have performed the operation of a 2 input NAND gate which is basically a 
multiplication operation between two inputs. We have done dc & transient operation of the 
NAND gate. In the dc operation there is lots of noise interference in the output waveform which 
are eliminated in the transient operation by using source voltage bit instead of a dc input. As a 
result we got an output waveform as shown above. 
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Detailed contents: 
1. Conduct experiment to test diode clipping (single/double ended) and clamping circuits 
(positive/negative). 
2. Design and set up the following rectifiers with and without filters and to determine 
ripple factor and rectifier efficiency:  
(a). Full Wave Rectifier (b). Bridge Rectifier 
3.Design and set up the BJT common emitter amplifier using voltage divider bias 
with and without feedback and determine the gain- bandwidth product from its 
frequency response. 
4. Set-up and study the working of complementary symmetry class B push pull 
power amplifier and calculate the efficiency 
5. Realize BJT Darlington Emitter follower with and without bootstrapping and 
determine the gain, input and output impedances 
6. Conduct an experiment on Series Voltage Regulator using Zener diode and power 
transistor to determine line and load regulation characteristics. 
7. Design and set-up the following tuned oscillator circuits using BJT, and determine 
the frequency of oscillation. 
(a) Hartley Oscillator (b) Colpitts Oscillator 
8. Plot the transfer and drain characteristics of n-channel MOSFET and calculate its 
parameters, namely; drain resistance, mutual conductance and amplification 
factor. 
9. Design, setup and plot the frequency response of Common Source JFET/MOSFET 
amplifier and obtain the bandwidth. 
Course Outcome: 
Students will be able to: 
CO1: Design and test rectifiers, clipping circuits, clamping circuits and 
voltage regulators. 
CO2: Compute the parameters from the characteristics of JFET and MOSFET devices. 
CO3: Design, test and evaluate BJT amplifiers in CE configuration. 
CO4: Design and test JFET/MOSFET amplifiers. 
CO5: Design and test a power amplifier. 
CO6: Design and test various types of oscillators. 
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AIM 
To design and implement diode clipping circuits.  
 
OBJECTIVE 

The purpose of this lab is to introduce students to design and implement following diode 

clipping circuits.  

i) Negative series clipper 

ii)  Positive series clipper 

iii)  Negative shunt clipper 

iv) Positive shunt clipper 

v) Biased negative shunt clipper 

vi) Biased positive shunt clipper 

vii)  Biased negative and positive shunt clipper 

 

THEORY 

Diode clipping circuits 

The function of a clipper (or limiter) is to limit an ac voltage to predetermined level. This is 

sometimes necessary to protect a device or circuit that might be destroyed by large amplitude 

(negative or positive) signal. Limiters can transform a sine wave into a square wave; and can 

perform other useful wave shaping functions. 

 



 

(a) Negative series clipper: Figure 1(a) shows a negative series clipper circuit with ac input 

signal. It is called series limiter because the output is taken from the load resister R1 is in 

series with the diode. While the input is positive D1 is forward biased and the positive half 

cycle is passed to the output. The peak output voltage 

   VPO = VPI - VF 

Where VPI is the peak input voltage and VF is the diode forward voltage drop. During 

negative half cycle of input, the diode is reversed biased. Consequently the output remains 

zero and the negative half-cycle is effectively clipped off.  

The output terminals of series clippers are usually connected to circuits that have high input 

resistance, so resistor R1 (current limiting resistor) is selected to pass an acceptable minimum 

current through the diode. Typically a current of 1 mA is appropriate to be sufficient to 

operate the diode beyond the knee of its forward characteristics. 

 

Design problem 

Design a negative series clipper (Fig. 1(a)) sinusoidal input voltage ±9 V (p-p) and zero load 

current. Determine a suitable resistor R1 and specify the diode forward current and reverse 

voltage. (Use silicon diode). 

Solution:   VPO = VPI - VF 

VO = ( VM - VF) 

+VM 

V 

   t   

   t   

0 

0 

-VM 

+VM 

-VM 

R1 

1.0 kΩ 

D1 

±VM 

   V

+ 

_ 

Fig. 1(a): Negative series clipper, (b): input and output waveforms. 

(a) (b) 

VF 
+ 

_ 



           = 9 – 0.7 V  

           = 8.3 V 

 Select        IF = 1 mA 

 This implies       R1 = VPO / IF  

           = 8.3 V/ 1mA 

           = 8.3 kΩ  (use 8.2 kΩ standard value) 

(b) Positive series clipper 

 

 If the diode in Fig.1 (a) is reconnected with reversed polarity, as shown in Fig 2(a), 

the positive series half-cycles are clipped off, and the circuit becomes a positive series 

clipper. The input waveforms to a clipper may be a square, or sinusoidal, or any other 

shape. 

 The design process to find the value of resistor R1 and diode specification is same as 

given in the negative series clipper. 

Shunt clipper circuits 

(a) Positive shunt clipper: A positive shunt (parallel) clipper is shown in Figure 3(a). 

Here the diode is connected in parallel with the output terminals. During negative 

half-cycles of the input signal the diode is reversed biased and only a small voltage 

drop occurs across R1 due to load current IL. Hence the circuit output voltage (VO) is 

VO = - ( VP - VF) 

+VM 

V 

   t   

   t   

0 

0 

-VM 

+VM 

-VM 

R1 

1.0 kΩ 

D1 

±VP 

   V

+ 

_ 

Fig. 2(a): Positive series clipper, (b): input and output waveforms. 

(a) (b) 

VF 
+ 

_ 



approximately equal to the negative input peak (-Vin). When the input is +VM, D1 is 

forward biased, and the output voltage equals the diode voltage drop (VF). Thus 

positive half-cycles of the waveform are clipped off. As illustrated, upper and lower 

levels of the output of a positive shunt clipper are approximately +VF and –VM. 

 

(b) Negative shunt clipper: A negative shunt clipper circuit is exactly the same as a 

positive shunt clipper with the diode polarity reversed, [Fig 4(a) and (b)]. The 

negative half-cycles of the waveform are clipped off. 

 The load current on a shunt clipper produces a voltage drop (ILR1) across the resistor, 

 which might be insignificant where the load current is very low. 

   VO = VM - (ILR1) 

As in the series clipping circuits, shunt clippers may be used with square,  sinusoidal, or any 

other waveforms. 

VO = ( VM - ILR1) 
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   V
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Fig. 4(a): Negative shunt clipper, (b): input and output waveforms. 
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Fig. 3(a): Positive shunt clipper, (b): input and output waveforms. 

(a) (b) 

D1 
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Design problem 

The negative shunt clipper in figure 4(a) has a ± 9 V input, and is to produce a +5 V 

minimum output when the load current is 2 mA. Determine a suitable resistance for R1, and 

specify the diode forward current and reverse voltage. 

 

Solution 

When the Diode D1 in figure 4(a)  is reversed biased,  

              ( )1RIVV LMO −=   

 or,    Ω=Ω
×

−=−= − k
I

VV
R

L

OM 2
102

59
31  (2.2kΩ may be used) 

 Diode reverse voltage,  

   VVV MR 9==  

 When the diode is forward biased, 

   mAA
R

VV
I FM

F 8.3
102.2

7.09
3

1

=
×

−=−=  

 

 

(c) Biased negative shunt clipper: Figure 5(a) shows a negative shunt clipping circuit 

that uses a DC supply VB in series with the diode D1. The circuit accomplishes partial 

clipping of the negative half-cycles of an input sine wave.  

  Diode D1 in figure 5(a) is reverse-biased by DC supply VB which maintains the anode 

VB volts negative relative to its cathode. During the positive half-cycles of the input 

voltage Vin, the cathode of D1 is held positive .The diode acts as an open switch, and the 

positive half-cycles passes in the output [figure 5(b)]. During the negative half-cycles the 

cathode is driven negative, but the diode will not conduct until Vin is more negative than 

the bias voltage VB which maintains the anode VB volts negative. Hence, that part of the 

negative alteration which is less negative than VB appears in the output. When the 



negative half cycle of Vin reaches the level where it is more negative than VB, the cathode 

is driven more negative than the anode and the diode conducts, limit5ing that portion 

between –VB [precisely –(VB + VF)] and –VM peak. The input and output waveform is 

shown in figure 5(b). 

 

 

(d) Biased Positive shunt clipper: Figure 6(a) and (b) shows the circuit and input-output 

waveforms of a biased positive shunt clipper. It is exactly the same as a biased 

negative shunt clipper with the diode and DC supply polarity reversed as shown in the 

figure. 

 

(e) Biased double diode shunt clipper: figure 7(a) and (b) shows the circuit and input-

output waveforms of a biased double diode shunt clipper. The circuit uses two diodes 

VO  
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_ 

Fig. 6(a): Biased positive shunt clipper, (b): input and output waveforms. 
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Fig. 5(a): Biased negative shunt clipper, (b): input and output waveforms. 
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VB 

   - (VF + VB) 



which have different bias voltages as shown in the figure. While the input waveform 

amplitude is less than ± ( VB +VF), neither diode is forward biased, and the input is 

simply passed to the output. When the positive input is greater than (VB1 + VF ), diode 

D1 is forward biased, and the output can not exceed this voltage. Similarly, when the 

negative input goes below (- VB2 - VF), D2 is forward biased, and the output is limited 

to – (VB2 + VF).  

    VO = ± (VB + VF) 

Biased shunt clippers are used to protect circuits or devices from (positive/negative) input 

voltages that must not exceed specified levels. The voltage across resistor R1 is (VM – 

VO), and the resistor current is the sum of the load current and the diode forward current 

(IL + IF). As in the diode circuits, a minimum level of IF is selected, and resistor value is 

calculated as, 

   
FL

OM

II

VV
R

+
−

=1  

 

 

Design problem: 

 The biased shunt clipper in figure 7(a) has a ± 9 V input, and its output is to be limited to ±

5 V. Determine a suitable  resistance for R1 if the clipper output current is to be ± 1 mA. 

Solution: 

+VM 
V 

   t   

   t   

0 

0 

-VM 

+VM 

-VM 

±VM 

   Vin 

Fig. 7(a): Biased double diode shunt clipper, (b): input and output waveforms. 
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    VO = ± (VB + VF) 

Giving,    VB = ± (VO - VF) 

          = ± (5 V – 0.7 V) 

          = ± 4.3 V 

Select the diode forward current as,  

    IF = 1 mA 

Then             
FL

OM

II

VV
R

+
−

=1  = 
mAmA

VV

11

59

+
−

 

         = 2 kΩ (2.2 kΩ can be used) 

 

 APPARATUS REQUIRED 

 

 

 

 

 

  

   

 

 

PROCEDURE 

1. According to the design problem, find the values of components. Rig the circuit 

on a breadboard.  

2. Connect the DC voltage source, signal generator and CRO according to the circuit 

diagram.  

Sr. No. Components Quantity 

1. 

2. 

3. 

4. 

5. 

6. 

7. 

8. 

9. 

Variable regulated DC power source 

Signal generator 

Diode 1N4007 

Resistor 470 kΩ 

Resistor 2 kΩ or 2.2 kΩ 

Breadboard 

Dual trace CRO 

Digital Multimeter 

Connecting wires and patch cords 

2 

1 

2 

1 

1 

1 

1 

1 

1 m 



3. Switch on the circuit and observe the input and output waveforms on the CRO 

screen and plot it on a graph sheet. 

 

 

CIRCUIT DIAGRAM AND OBSERVATIONS 
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Fig. 9(a) Positive series clipper;   9(b): input and output waveforms. 
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Fig.:8.(a) Negative series clipper;   (b): input and output waveforms. 



 

Negative shunt clipper 

 

Biased negative shunt clipper 

 

Biased positive shunt clipper 
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Fig. 5(a): Biased negative shunt clipper, (b): input and output waveforms. 
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Fig. 3(a): Negative shunt clipper, (b): input and output waveforms. 

(a) 

D1 

VF 
+ 
_ RL

 IL +9V 

V 

   t   

   t   

0 

0 

-9V 

+9V 

-9V 

(b) 

-VF 

VO  

R1 

 

±9V 

   V

+ 

_ 

Fig. 3(a): Positive shunt clipper, (b): input and output waveforms. 

(a) 

D1 

VF 
+ 
_ RL

 IL +9V 

V 

   t   

   t   

0 

0 

-9V 

+9V 

-9V 

(b) 

+VF 



 

Biased double diode shunt clipper 

 

 

 

CONCLUSION 
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Fig. 7(a): Biased double diode shunt clipper, (b): input and output waveforms. 
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Fig. 6(a): Biased positive shunt clipper, (b): input and output waveforms. 
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AIM 
To design and implement Negative and Positive Diode Clamping Circuits 
 
OBJECTIVE 

The purpose of this experiment is to introduce students to design and implement following 

diode clamping circuits.  

a) Negative voltage clamper 

b) Positive voltage clamper 

 

THEORY 

 A clamping circuit changes the dc voltage level of a waveform, but does not affect its shape. 

In other words, in steady state, the output waveform is an exact replica of the input 

waveform, but the output signal is shifted by a dc value that depends on the circuit.  

Negative Voltage Clamping Circuit 

A negative voltage clamping circuit is shown in Fig.1 (a).  



 

During the positive half cycle of the square wave input, diode D1 is forward biased, and the 

output voltage equals the diode forward voltage drop (VF). 

   VO = VF 

Also, during positive half cycle of the input, the capacitor C1 is charged with the polarity 

shown to a voltage, 

   VC = (VM - VF) 

During the negative half cycle of the input the diode D1 is reversed biased and has no further 

effect on the capacitor voltage. Also, the R1 has very high resistance, so it cannot discharge 

C1 significantly during negative portion of the input waveform. During this half cycle polarity 

of the capacitor voltage is same as the (negative) input, the output is, 

   VO = - (VM + VC) 

         = - [(VM + (VM - VF       )] 

or,   VO = - (2VM - VF ) 

Also we can find,  VO(P-P) = 2 VM  

The output waveform of the negative voltage clamping circuit is (almost) completely 

negative and the output positive peak clamped at a level of +VF. 

Positive Voltage Clamping Circuit 

±VM  Vin 

V 

0 
+VF 

- (2VM - VF) 

(b) 

Output 

+VM 

0 

-VM 

Input 

2VM 

2VM 

t 

t 

V 

Fig. 1(a): A Negative voltage clamping circuit, (b): Input and Output waveforms. 
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We can design a positive voltage clamping circuit shown in fig. 2(a) by reversing the polarity 

of the diode and capacitor of a negative voltage clamping circuit. 

 

As illustrated, the output waveform of a positive clamping circuit is clamped to keep it 

(almost) completely positive. In other words a positive clamping circuit passes the complete 

input waveform to the output, but clamps the negative peak of the output close the ground 

level. 

Output Slope 

Resistor R1 in figure 1(a) and 2(a) is sometimes termed as bleeder resistor. It is used to 

gradually discharge the capacitor C1 over several cycles of input waveform, so that it can be 

charged to new level when the input changes. However, R1 partially discharges the capacitor 

during the time when D1 is reversed biased. This produces a slope or tilt (∆VC) on the output 

waveform, as shown in Fig.3.  

 

Fig. 2(a): A Positive voltage clamping circuit, (b): Input and Output waveforms. 
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Design Problem 

Design a negative voltage clamping circuit as shown in Fig.1 (a). It has a ±10 V, 1 KHz 

square wave input with a 50 Ω signal source resistance. The output waveform should have 

maximum slope (∆VC) of 5%. Determine suitable values of R1 and C1. 

Solution 

  t = T/2 = 1/2fo    ( T = 1/fo) 

     = 1/(2 x 1000 Hz) = 0.5 ms 

 Hence,  Pulse width, PW = t = 0.5 ms 

Since,   PW or t  =  C1 x RS   ( A capacitor is completely charged in approximately 
     five time constants of the circuit. In the case of a R-C 
     circuit, the time constant is RC. So, 5 RC = 5 PW or 
     PW = RC) 

 

  C1 = PW/RS = 0.5 ms /50Ω               [ (0.5 x 10-3)/ 50 = 10 x 10-6] 

       = 10 µF 

 VO(pp)    =  2VM = 2 x 10 V       ( since,   VM  = 10 V) 

   =  20 V 

    ∆VC   =  5% of  VO(pp) = 5% of  20 V 

Fig. 3: The output voltage from a clamping circuit has a slope (∆VC)         
produced by capacitor discharge. 
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- (2VM - VF) 

Output 

2VM 
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∆VC 

tilt t 

T 



   = 1V 

We know,  ∆VC = (IC x t)/C1          {∆V = ∆Q/C} 

Hence,      IC = (∆VC x C1)/ t = (1 V x 10µF)/0.5 ms 

         = 20mA 

Since,      IC = VO /R1  and  VO = 2VM 

  R1 = 20 V/20 mA 

       = 1KΩ  

  Use 1N4007 as diode D1. The designed circuit is shown in Fig.4. 

 

 

 

Apparatus and Components Required 

Sr. No. Components Quantity 

1. Signal generator 01 

2. 20 MHz Dual trace CRO/DSO 01 

3. DMM 01 

4. Breadboard 01 

5. Diode 1N4007 01 

Fig. 4: A Negative voltage clamping circuit (designed) 

VO = - (VM - VF) 
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R1 

1 KΩ 
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±10 V  
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_ 
VF 
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_ 
D1 

(VM - VF) 

CRO 



6. Resistor 1 kΩ  0.25 W 01 

7. Capacitor 10 μF , 50V 01 

8. Hook up Wire 24 or 25 SWG 1 m 

 

Observation table 1: Positive Diode Clamper circuit 

VIN(P-P) 

(V) 

∆VC 

(calculated) 

(V) 

∆VC 

(observed) 

(V) 

VO 

(calculated) 

(V) 

VO 

(Observed) 

(V) 

     

 

Observation table 2: Negative Diode Clamper circuit 

VIN(P-P) 

(V) 

∆VC 

(calculated) 

(V) 

∆VC 

(observed) 

(V) 

VO 

(calculated) 

(V) 

VO 

(Observed) 

(V) 

     

 

 

 

PROCEDURE 

4. According to the design problem, find the values of components. Rig the circuit 

on a breadboard.  

5. Connect the Signal generator and CRO according to the circuit diagram.  

6. Apply 20 V peak to peak square wave as input from the signal generator. 

7. Observe the input and output waveforms on the CRO screen. Record the different 

voltages of the waveforms in the observation table and plot it on a graph sheet.  



 

Calculations: 

Conclusion: 
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AIM:  To design and implement of a full wave bridge rectifier circuit with and without filter. 

OBJECTIVE: 

1. To design and implement afull wave rectifier circuit. 
2. To study the ripple factor, percentage of regulation, input and output waveform of a 

full wave rectifier without filter and with capacitive input filter. 

 

APPARATUS REQUIRED: 

Sl. No. Name Of The Apparatus Specification/Range Quantity 
1. Bread Board  01 

2. Step down transformer  220V AC  to 0 – 6V, 300 mA 01 

3. Diode 1N4007  01 

4. Resistor 200 Ω, ¼ W 01 

5. Capacitor 470µF, 50 V 01 

6. DMM  01 

7. Single Strand Wire 25 or 26 SWG 1 m 

8. CRO or DSO DC to 20 MHz 01 

 

Theory:  

A device is capable of converting a sinusoidal input waveform into a unidirectional 

waveform with non zero average component is called a rectifier. The Bridge rectifier is a 

circuit, which converts an ac voltage to dc voltage using both half cycles of the input ac 

voltage. The Bridge rectifier has four diodes connected to form a Bridge. The load resistance 

is connected between the other two ends of the bridge.  

For the positive half cycle of the input ac voltage, diode D1 and D3 conducts whereas 

diodes D2 and D4 remain in the OFF state. The conducting diodes will be in series with the 



load resistance RL and hence the load current flows through RL. For the negative half cycle of 

the input ac voltage, diode D2 and D4 conducts whereas diodes D1 and D3 remain in the OFF 

state.  

The conducting diodes will be in series with the load resistance RL and hence the load 

current flows through RL in the same direction as in the previous half cycle. Thus a 

bidirectional wave is converted into a unidirectional wave. Ripple factor is a measure of 

effectiveness of a rectifier circuit and defined as a ratio of RMS value of ac component to the 

dc component in the rectifier output.  
 

CIRCUIT DIAGRAM: 

Full wave bridge rectifier circuit without filter capacitor 

 



Full wave bridge rectifier circuit with filter capacitor

 

Full wave bridge rectifier circuit with filter capacitor 

 



 

 

DESIGN PROBLEM:  Design a full wave bridge rectifier with capacitive input filter to 
produce an output dc voltage 5.5 V when load current is 30 mA and ripple factor is 0.03. Find 
out the value of load resistor RL and filter C. 

 

SOLUTION:  

                                 Given, Vdc = 5.5 V,  IL = 30 mA, Ӷ = 0.03 

As we know,          Vdc = 2Vm/π 

                                Vm =  �Vdc/2 =5.5π/2 

       = 8.64 V 

         Vdc = IL.RL 

                                   RL = 5.5 V/30 mA = 183 Ω.   Choose RL = 200 Ω 

                                    Vrms = Vm/√2 = 8.64/√2  

           = 6.11 V       Use step down transformer with secondary voltage 6 
V. 



                                    Ӷ = 1/(4√3fo CRL) 

                                    C = 1/(4√3foӶRL)  fo = 50 Hz , the line frequency 

                                   C = 481 µF .            Choose 470µF as the nearest standard value  

OBSERVATION TABLE:  

1) Observation Of Rectified Output using DMM : 

Type Of Rectifier 
Circuit 

Vdc 

(V) 
Vac 

(V) 
Ӷ(cal) Ӷ (obs)=Vac/Vdc % of error 

Bridge rectifier without 
filter 

     

Bridge rectifier with 
filter 

     

 

 

2) Observation On CRO/DSO For Rectified Output : 

TYPE OF 
RECTIFIERCIRCUIT 

AMPLITUDE TIME PERIOD FREQUENCY 

Bridge rectifier without 
filter 

   

Bridge rectifier with 
filter 

   

 

VOLTAGE REGULATION: 

% of voltage regulation= [(VNL-VFL)/VFL]X100 

OBSERVATION TABLE: 

VNL   (V) VFL  (V) % OF REGULATION 
   
 

CONCLUSION: 
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AIM: Design and setup the BJT common emitter amplifier using voltage divider bias and 
determine the gain-bandwidth product from its frequency response. 

OBJECTIVES: 

1. To design and setup a capacitor-coupled Common Emitter Amplifier with voltage 

divider bias according to a given specification. 

2. To study the frequency response curve and determine the gain-bandwidth product. 

THEORY: 

 Specification: Supply voltage (VCC), minimum Voltage gain (AV), Frequency 
response (lower cutoff (fL) and upper cutoff frequency (fH)), Signal source impedance (ZS) 
and Load impedance (ZL). Fig. 1 shows the circuit for a single-stage CE amplifier with 
voltage divider bias. 

 

 

Step 1: Selection of VCC, IC, RC and RE 

Figure 1(b): Voltage waveforms 

for a CE amplifier circuit. 

ac output 

ac input 

vo 

vs 
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Figure 1(a): Single-stage CE 

amplifier circuit. 



Voltage gain,  AV = 
�ℎ��(	
(�	׀׀ 

ℎ
�
 

 

Therefore, AV is proportional to RCIIRL. But large value of RC will make the collector current 
IC too small. A good minimum IC will be 1 mA for small signal amplifier. 

To ensure that the transistor operates linearly and to allow the collector voltage swing of 
±1V, which actually adequate for a small signal amplifier, the collector-emitter voltage VCE 
should be around 3V. 

For good bias stability, emitter resistor voltage drop VE should be much larger than base-
emitter voltage VBE. This is because, 

VE = VB─ VBE, and when VE>> VBE, VE will only be slightly affected by any variation in VBE 

(due to temperature change or other effects). Consequently, IE and IC remain fairly stable at IC 
≈ IE = VE/RE.  

With VCC= 15V, we can choose VE = 5V for a reasonable level of VCE and VRC. 

Let us choose VCC = 15V, VCE= 3V, VE= 5V, IC = 1mA.  

Then VRC= VCC ─ VCE─VE= 15 ─ 3─ 5 = 7V 

RC = 
��


��
 = 

��
���

 = 7KΩ. We choose RC = 6.8 KΩ as the standard value nearest to 7KΩ. 

RE = 
��

��
 = 

��
���

 = 5KΩ. We choose RE = 4.7 KΩ as the standard value nearest to 5KΩ. 

Step 2: Selection of Bias Resistors R1 and R2 

The voltage divider current (I2) may be selected as IC/10 to achieve a good bias stability and 
reasonably high input resistance.  

R2 = 
��

��
 = 

��� � ��

�� ��⁄
 = 

(�.� � �)�
��� ��⁄

 = 57 KΩ. We choose R2= 56 KΩ as the standard value nearest 

to 57KΩ. 

R1 = 
�

─  ��

�� ��⁄
 = 

(�� ─ �.�)�
��� ��⁄

 = 92KΩ. We choose R1= 100 KΩ as the standard value nearest to 

92 KΩ. 

Step 2: Selection of Coupling Capacitors C1 and C3 



To minimize the effects of C1 and C3, the reactance of each coupling capacitor is selected to 
be approximately equal to one-tenth of the impedance in series with it at the lowest operating 
frequency of the circuit (fL). 

XC1 = 
�
� ��

��
at fL 

XC3 = 
� � !�

��
at fL 

Let the transistor 2N3904 is selected for this design. 

From the datasheet of 2N3904 we have, hfe = 70 (min) at IC = 1 mA, VCE = 1.0 V 

  ŕ e = 
"# ��

��
 = 

"# ��
� ��

 = 26Ω 

  hie = (1 + hfe)rʹe = (1+70) x 26 Ω ≈ 1.8 kΩ 

Input impedance, Z i = R1׀׀R2׀׀hie= 100kΩ56׀׀kΩ1.8׀׀ kΩ = 1.72 kΩ 

C1 = 
�

"$%�(�
���)/��
 Signal source impedance, rs = 50Ω = 0.05 KΩ 

Let,  fL = 1000 HZ 

Therefore, C1 = 
�

"π ' ���� () ' (�.�" *Ω��.��+Ω)/�� 
≈0.899 μF. We choose C1 = 1 μF as the 

standard value nearest to 0.899 μF. 

As a rule of thumb, the value of RL is selected as 10RCwhich is sufficient to keep the effect of 
RL insignificant on the circuit voltage gain. 

Hence, RL = 68 KΩ is selected. 

C3 = 
�

"π,�(	
�	�)/��
 = 

�
"π'����() '(#.- *Ω�#- +Ω)/��

= 0.021 μF. We choose C3 = 22 nFas the 

standard value nearest to 0.021 μF. 

 

Step 2: Selection of Bypass Capacitor C2 

XC2 = 
ℎ
�

��ℎ��
at fL =

�.- .Ω
����

= 25.35Ω 

C2 = 
�

"$%/01�
 = 

�
"π'���� () ' "�.2� Ω

 = 6.28μF. We choose C2 = 10 μF as the standard 

value nearest to 6.28 μF. 



The upper cut-off frequency (fH) of circuit is set by simply connecting a capacitor (CL) from 
the collector terminal to ground. Let us select fH= 100 KHz. 

CL = 
�

"$%3!1
 = 

�
"π'���*()'#.-+Ω

= 234 pF. We choose CL = 220 pF as the standard value nearest  

to 234 pF. 

 

 

Circuit Analysis 

The h-parameter equivalent circuit is produced by replacing the supply voltage and all 
capacitors with short circuits and substituting device h-parameter model for the transistor as 
shown in figure 3.  

 

Input impedance, Zi = R1׀׀R2׀׀hie= 100kΩ56׀׀kΩ1.8׀׀ kΩ = 1.72 kΩ 

Figure 3: h-parameter equivalent circuit for a CE amplifier 
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Figure 2: A designed capacitor-coupled CE amplifier. 
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Output impedance, Zo = Rc׀׀(1/hoe) 

Since, Rc<< 1/hoe Zo ≈ Rc= 6.8 kΩ 

Voltage gain,  Av1 =
�ℎ��(	8׀׀	/)

ℎ
�
 

= 
���×(#.-.Ω �� #- .Ω)

�.- .Ω
≈ 240  

Design problem 

Design a capacitor coupled CE amplifier with the following specification. Setup the circuit on 
a breadboard. Experimentally determine lower cut-off and higher cut-off frequency and 
bandwidth of circuit. Calculate the input and output impedance. 

(a) VCC= 15 V, (b) IC = 1mA, (c) VCE = 3V and (d) fL= 1000Hz and fH=100 kHz 

Design Solution 

The design of the capacitor coupled CE amplifier with the given specification is done in the 
theory part of this laboratory manual.  

Procedure 

a) Apply a fixed peak-to-peak amplitude sinusoidal signal within the range of 1 mV 

through 5mV to the input coupling capacitor C1 from a signal generator’s 50 Ω output 

terminal.  

b) Vary the input signal frequency from 100 Hz to 900 Hz at the step of 100 Hz, from 1 

kHz to 10 kHz at the step of 1 kHz, and from 20 kHz to 100 kHz at the step of 10 

kHz, 200 kHz to 1MHz at the step of 100 kHz. 

c) For each input signal frequency measure the peak-to-peak amplified output across the 

load resistor RL with the help of a CRO and record in the observation table. 

d) Draw the frequency response curve on a semi-log graph sheet and find out lower cut-

off and upper cut-off frequencies and bandwidth.  

e) Calculate the input and output impedance of the circuit. 

Apparatus Required 

Sl. 
No. 

Devices/ Test equipment/ Power 
source  

Value/ Make and model  Quantity 



1. NPN Transistor 2N3904  VCE MAX = 40V, IC MAX = 
200mA, hFE(min) = 70 

01 

2. Resistor (carbon film or metal 
film) 

100 KΩ 
68 KΩ 
56 KΩ 
6.8 KΩ 
4.7 KΩ 

01 
01 
01 
01 
01 

3. Capacitor  10 μF(Electrolytic) 
1 μF (Electrolytic) 
22 nF (Polypropylene) 
220 pF (Ceramic Disc) 

01 
01 
01 
01 

4. Single Stand Wire (hook up wire) 24SWG as required 
5. Bread Board Wish 01 
6.  Regulated DC Power  ELNOVA E-61 (+15V) 01 
7. Dual Channel Oscilloscope Scientech/ GW Instek 

dc to 20 MHz 
01 

8. Function Generator GW Instek SFG-1013 01 
9. DMM CIE-122 01 

Observation Table 

Vin = 5 mV (peak-to-peak) 

Sl. 
No. 
of 

Obs. 

Frequency 
of input 
signal                       

(Hz/ kHz) 

VO(p-p)             
(V) 

AV  = 
;<

;=>
 

?@ = 
ABCDEFB(;<

;=>
) 

(dB) 

fL 

(Hz) 

fH 

(kHz) 

3-dB 
Bandwidth 

(kHz) 

1. 100 Hz       
2. 200 Hz       
… …       
… …       
10 1 kHz       
11. 2 kHz       
… …       
… …       
20. 20 kHz       
21 30 kHz       
… …       
… …       
28. 100 kHz       
29. 200 kHz       
… …       
… …       
37 1000 kHz       

Calculation: 

Discussion: 



Conclusion: 
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AIM  

Design a Class-AB Complementary Symmetry Power Amplifier with the given 
specifications. Find the  

(1) Power output, 
(2) Efficiency  
(3) THD (total harmonic distortion) 

 

THEORY 

 

 

DESIGN PROBLEM 

 We have to design a Class AB complementary symmetry emitter follower power amplifier as 
shown in Figure 1(a) to deliver1 watt power to an 8 Ω load. The lower cut-off frequency (fL) 
of the capacitor coupled amplifier to be chosen 1 KHz. We have to determine the required 
supply voltage (VCC), and calculate resistor values for RC, RB, RE2, and RE3. Here we assume 
hFE(min) = 50 for Q2 and Q3. 

 

 



 

 

Solution 

We know, peak voltage of the output waveform, 

GH = J(2KLMN) = J(2 × 8Ω × 1P) = 4V 

QH = 
RS

!/
 = 

TR
-Ω

 = 500 mA 

The voltage drops across RE2 and RE3 when the peak output current is flowing are typically 
selected as 5% to 10% of the peak output voltage. RE2 and RE3 are included to help stabilize 
the transistor quiescent current at a level that eliminates cross-over distortion in output 
waveform.  

Hence,  

  KU" = KU2 = 0.1 KL = 0.1 × 8 Ω = 0.8 Ω  (use 1 Ω standard value) 

 

Select ,  QWX" = 0.1QH = 0.1 × 500 Z[ = 50 mA 

 

+VCC 

RE1 

R1 

CE 

Vout 

Fig 1(a): Class-AB Complementary Symmetry Power Amplifier  
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  G\ = G\U" + QWX"(KU" + KU2) + G\U2 

       = 0.7 V + 50 mA (1 Ω + 1 Ω) + 0.7 V 

       = 1.5 V 

 

When the output voltage is at its negative-going peak , the VCE1 should be 1 V minimum to 
ensure that Q1 does not go into saturation. Also, VE1 should be typically 3 V. So, the 
minimum level of VC1 is typically 4 V. Similarly, when the output is at its positive-going 
peak, there must be an appropriate minimum voltage across resistor RC. It is not acceptable to 
set a 1 V minimum for VRC, because the current through RC would be too small for the 
required peak base current to Q2. It is best to select, 

  VRC(min) = VC1(min) = 4 V 

 

The minimum current through RC (IRC(min)) should be typically be selected 1 mA larger than 
the peak base current for the output transistors Q2 and Q3.  

 

  Q\"(^_`) = 
aS

ℎbc�(d
e)
= 

��� fg
��

 

     = 10 mA 

Select,   Q!W(fhi) = Q\"(f_`) + 1 mA = 10 mA + 1 mA 

     = 11 mA 

  KW  =
Rj1(d
e)

aj1(d
e)
= 

T �
�� ��

 

   = 360 Ω 

We can find the VCC, from the relation, 

  GWW = 2 (GH + G!U" + G\U" + G!W(fhi)) 

    = 2(4 + 1 Ω × 0.5 [ + 0.7 G + 4 G)  

    = 18.4 V   (use 18 V) 

The voltage drop across the diodes and RB should just bias Q2 and Q3 on for Class-AB 
operation. The current through RB is the Q1 quiescent current ICQ1.  

G!W(mn) + GW�(mn) = GWW − G\   

Since, The dc voltage drop across RC , VRC(dc) equals VC1(dc) , we can write  



  G!W(mn) = GW�(mn) = 0.5(GWW − G\) = 0.5(18.4 G − 1.5 G) 

 Hence,  G!W(mn)= 8.45 V 

  QW�(mn) =  
Rj1(pq)

!1r
 = 

-.T� R
2#� Ω

 

   = 23 mA 

  K\ =  Rs t Rur t Ru�

a1r(pq)
 = 

�.� R� �.� R� �.� R
"2 fg

 

         = 4.35 Ω  (use 20 Ω standard value variable resistor to allow for ±      
adjustment) 

Resistors R1, R2 and RE1 are determined in the usual manner. 

Since, GU� = 3 G, KU� =  Rcr

a1r(pq)
=  2 R

"2 fg
 

     = 130 Ω  (use 120 Ω standard value resistor) 

  K" =  Rsr 

�.�a1r(pq)
 = 

Rscr � Rcr

�.�a1r(pq)
 = 

�.� R �2 R
".2 fg

 

         = 1.6 KΩ 

  K� =  R11 t Rsr

�.�a1r(pq)
 = 

�- R � 2.� R
".2 fg

 

        = 6.2 KΩ 

Design of coupling and Bypass capacitors, CC, CO and CE 

To minimize the effects of CC and CO, the reactance of each coupling capacitor is selected to 
be approximately one-tenth of the impedance in series with it at the lowest operating 
frequency for the circuit (fL).  

XCc = 
�
� ��

��
at fL 

XCo = 
� � !�

��
at fL 

Let the transistor SL100 for Q1 is selected for this design. 

From the datasheet of SL100 we have, hfe = 25 (min) at IC = 10 mA, VCE = 10 V 

  ŕ e= 
"# ��

��
 = 

"# ��
"2 ��

 = 1.13 Ω 

  hie= (1 + hfe)rʹe = (1+25) x 1.13 Ω ≈ 30 Ω 



Input impedance, Z i = R1׀׀R2׀׀hie = 6.2 kΩ1.6׀׀ kΩ30׀׀ Ω   

       = 29Ω 

CC = 
�

"$%�(�
���)/��
 Signal source impedance, rs = 50Ω  

Let,  Lower cut-off frequency, fL = 1000 HZ 

Then,  after solving we get  CC = 20 µF select 47 µF for CC as nearest standard value. 

   CO≈ �
"$%��.�!/

 = 
�

"$×����×�.�×- Ω
  = 199 µF 

   Select 220 µF for CO as the nearest standard value. 

We can write,  CE≈ �
"$%�ℎ
wr

 = 
�

"$×����×�.�2Ω
F 

       = 141 µF  Select 220 µF for CE as nearest standard value. 

Completely designed Class AB Complementary Symmetry Power Amplifier is shown in Fig. 
1(a). 
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Fig 1(b): Class-AB Complementary Symmetry Power Amplifier  
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APPARATUS AND COMPONENTS REQUIRED:  

Sl. 
No. 

Devices/ Test equipment/ Power 
source  

Value/ Make and model  Quantity 

1. Transistor SL100  01 
2. Transistor 2N3055  01 
3. Transistor 2N2955  01 
4. Diode 1N4007  02 
5. Resistor (carbon film or metal 

film) 
1 Ω, 4 W 
120 Ω,2W 
1.6 kΩ 
6.2 kΩ 

02 
01 
01 
01 

6. Capacitor  47 μF, 50 V(Electrolytic) 
220 μF, 50 V (Electrolytic) 

01 
02 

7. Potentiometer 100 Ω 01 
8. Single Stand Wire (hook up wire) 24 SWG 1 m 
9. Bread Board Wish 01 
10.  Regulated DC Power  ELNOVA E-61 (0 to +30 V) 01 
11. Dual Channel Oscilloscope Scientech/ GW Instek 

dc to 20 MHz 
01 

12. Function Generator GW Instek SFG-1013 01 
13. DMM CIE-122 01 
 

OBSERVATION TABLE: 

Sl. No.  

of Obs. 

Description of 
measurement 

Calculated 

value 

Observed 

value 

% of error  

1. Vcc    

2. VRE    

3. VRC    

4. VCEQ    

5. ICQ    

6. vin(p-p)    

7. Po (max)    

8. η    

9. THD (total 
harmonic 
distortion) 

   

 



 

CONCLUSION:  
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AIM  
 To design and implement a transistor series voltage regulator with error amplifier and 
to determine line and load regulation characteristics.  
THEORY  
 The function of an ideal voltage regulator is to maintain a constant voltage at its 
output terminals, no matter what current is drawn from it. The output voltage of a practical 
power supply changes with load current, generally dropping as load current increases. The 
power supply specifications include a full load current rating, which is the maximum current 
that can be drawn from the supply. The terminal voltage when full load current is drawn is 
called the full load voltage (VFL). The no load voltage (VNL) is the terminal voltage when 
zero current is drawn from the supply, that is, the open circuit terminal voltage.  

One measure of power supply performance, in terms of how well the power supply is 
able to maintain a constant voltage between no load and full load conditions, is called its 
percentage voltage regulation.  

An unregulated power supply has poor regulation, i.e., output voltage changes with 
load variations. If a power supply has poor regulation it possesses high internal impedance. A 
simple emitter follower regulator is shown in Fig.1. It is also called a series regulator since 
the control element (transistor) is in series with the load. It is also called as the series-pass 
transistor because it conducts or passes all the load current through the regulator. It is usually 
a power transistor. The zener diode provides the voltage reference, and the base to emitter 
voltage of the transistor is the control voltage.  

The value of RS must be sufficiently small, to keep the zener in its reverse 
breakdown region. Writing Kirchhoff’s voltage law to the output circuit,  

  VO + V
BE 

- V
Z 

= 0 

i.e.,   V
BE 

= V
Z 

- VO 

           also,    VO = VZ - VBE  
If V Z is perfectly constant, the above equation is valid at all times, and any change in 

VO must cause change in VBE, in order to maintain equality.  



 
When load current demand is increased by decreasing RL, VO tends to decrease. 

From the above equation, it is seen that as VZ is fixed, decrease in VO increases in VBE. This 
will increase the forward bias of the transistor, thereby increasing level of conduction. Thus, 
the output current is increased to keep ILRL a constant. The reverse process occurs when RL is 
increased. Thus, the above circuit keeps the output voltage constant, even if the load varies 
widely. 

Series regulator using an error amplifier  
 A series regulator using an error amplifier as shown in fig.2 improves the line and 
load regulation of the circuit. In comparison to the simple regulator circuit in fig.1, where the 
zener voltage is greater than the output voltage, this amplifier makes it possible to have an 
output voltage greater than the zener voltage.   
 

 
The Zener diode D1 with resistor R2 plays the role of a reference source. Transistor Q2 along 
with its associated components resistor R1, R3 and R4 constitute the error amplifier which 
controls emitter current IE1 of the series pass transistor Q1. The output is divided by resistors 
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 Fig. 2: Series voltage regulator circuit with an error amplifier 
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 Fig. 1 Circuit diagram of a simple series voltage regulator 
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R3 and R4 and compared to Zener diode voltage level VZ.  
  
 When the output voltage VO changes, the change is amplified by transistor Q2 and fed 
back to the base of Q1 to correct the output voltage level. Suppose the regulator is designed 
for VO 12 V and the DC supply VS = 18 V. In this case the suitable Zener diode should be 
selected for VZ = 6 V. For this level of VZ the base voltage of Q2 can be found as 
    VB2 = VZ + VBE2 = 6.7 V. 
 So resistors R3 and R4 are selected to give VB2 = 6.7 V and VO = 12 V. The voltage at 
the base of Q1 is 
   VB1 = VO + VBE1 = 12.7 V. 
 Also,   VR1 = VS – VB1 = 18 – 12.7 = 5.3 V. 
The current through R1 is mostly the collector current of Q2. 
 
  Let us see how this regulator works. Assume that the output voltage drops slightly for 
some reason. When VO decreases, VB2 decreases. Since the emitter voltage of Q2 is tied at VZ, 
any decrease in VB2 appears across at the base-emitter of Q2. A reduction in VBE2 causes IC2 
to be reduced. When IC2 falls, VR1 is reduced and the voltage at the base of Q1 rises (since, 
VB1 = VS – VR1) causing the output voltage to increase. Thus, a decrease in the output voltage 
produces a feedback effect which causes the output voltage to increase back toward its 
normal level. Similarly, a rise in VO above its normal level produces a feedback effect that 
pushes VO down again toward its normal level. C1 is a large value capacitor, usually 50 
μF to 100 μF, which is connected at the output to suppress any tendency of the regulator to 
oscillate.    
 The error amplifier in the regulator improves all aspects of the circuit performance by 
an amount directly related to the amplifier voltage gain (AV). When VS changes by ∆VS, the 
output voltage is  

  ∆Vo =  
∆Ry

gz
  

 
REGULATOR DESIGN  
Design problem:  
 Design a voltage regulator circuit as shown in fig. 2 to produce regulated VO

 = 9V and 
IL(max) = 40 mA. The supply voltage range is 12 to 15 V DC. 
 
 Solution:  

Specifications:  

 Output Voltage,  VO = 9 V  

 Output Current,  IL(MAX)  = 40 mA  

 Input Voltage,  Vi = 12 to 15 V DC 

Select  VZ ≈ 0.75 VO = 0.75 X 9 V 

          = 6.75 V 

For Zener diode D1 we can use 1N754, with VZ = 6.8 V (IZT = 20 mA, IZM = 60 mA, PD = 400 



mW) 

For minimum D1 current, choose  

  IR2 = 20 mA 

   

                      K" =  R{  t R|

aj�
 = 

} R �#.- R
"� fg

 

  = 110 Ω (wattage of R2 is (20 mA)2 × 110 Ω = 0.044 W, choose 1/2W) 

  IE1(max) ≈ IL(max) + IR2 = 40 mA + 20 mA  

   = 60 mA 

  KL =  R{  

a/
 = 

} R
T� fg

  

      = 225 Ω   We choose 220 Ω, nearest standard value.  

Specifications of Q1:  

  VCE1(max) ≈ VS = 15 V 

   IC1(max)  ≈ IE1(max) = 60 mA 

   PD(max)  = (VS ─ VO) × IE1(max) = (15 V ─ 9 V) × 60 mA 

     = 360 mW 

 Assuming hFE1(min)  = 100  We choose 2N2222A for Q1 

  IB1(max)  = 
acr(d~�)

�bcr(���)
 = 

#� fg
���

 

     = 0.6 mA 

  IC2 > IB1(max)   

Select   IC2 = 2.5 mA 

  R1 = 
Ry�Rsr

a1��asr
 = 

�� R –(} R��.�)  
".� fg ��.# fg

  

     = 1.71 KΩ (use 1.8 KΩ standard value) 

  IZ = IE2 + IR2 = 2.5mA + 20 mA  

    = 22.5 mA 

  I4 >> IB1 

Select  I4 = 1 mA 

  R4 = 
R| �  Rsc�

a�
 = 

#.-  R��.� R
� fg

 

     = 7.5 KΩ  

  R3 = 
R{ �  Rj�

a�
 = 

}  R��.� R
� fg

  

     = 1.5 KΩ 

Select Q2 a NPN transistor of small signal amplifier viz. BC548B 



 

 

 
PROCEDURE 
 Load regulation 
  

1. The circuit is wired as per the circuit diagram shown in fig. 2.  
2. Keep the input voltage constant at Vi(min) , i.e. 12 V.  
3. Vary the load resistance. Note IL and VO for each setting of RL. Ensure that Vi 

remains same throughout.  
4. Draw a plot between IL and VO.  

 
 Line Regulation  
 Percentage of line regulation is another measure of the ability of a power supply to 
maintain a constant output voltage. In this case, it is a measure of how sensitive the output is 
to the changes in input or line voltage rather than to the changes in load. The specification is 
usually expressed as the percentage of change in output voltage that occurs per volt change in 
input voltage, with the load RL assumed constant.  

1. The circuit diagram is wired as per the circuit diagram shown in fig. 1.  
2. Keep the load resistance RL a constant.  
3. Vary the input voltage between the limits for which the regulator is designed (12 to 

15V).  
4. Note the load voltage VO for each setting of Vin.  
5. Draw a graph between Vin (X axis ) and VL (Y axis).  

 
OBSERVATIONS  

(a) Load Regulation 
Load Resistance Output Load Current 

─ 

─ 

+ 

 Fig. 3: Series voltage regulator circuit with an error amplifier (designed) 

VO VS 

D1 
1N754 
 

R1 

1.8 KΩ 
 

Q2 

R2 
110 Ω 

R3  
1.5KΩ 

R4 

7.5 KΩ 

C1 

100 μF 
 

Q1 

12 V to 15 V 

+ 

2N2222

BC54
8B 

RL 
220 Ω 



(RL) 
 

Voltage 
VO 

(V) 

IL 
(mA) 

   
   
   
   
   
   
 
(b) Line Regulation 
Line input Voltage 

V i 
(V) 

Output Voltage 
VO 

(V) 
  
  
  
  
  
  
 
Expected Output Plots  

 

Line Regulation     Load Regulation 

Result  
Line regulation and load regulation curves are plotted.  

Conclusion 
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AIM 

 Design and set-up the following tuned oscillator circuits using BJT, and determine 
the frequency of oscillation. 

(a) Hartley Oscillator and (b) Colpitts Oscillator 
 

THEORY 
LC oscillators are generally used as RF oscillators since they are generally used to 
create high frequency oscillations. In Hartley and Colpitts oscillator an LC tank 
circuit is used for selection of frequency of oscillation. A voltage divider biased 
common emitter amplifier is used as amplifier. The amplifier and tank circuit 
together provides a phase shift of 360 degrees to satisfy Barkhausen criterion. 

 
HARTLEY OSCILLATOR  

 
COMPONENTS REQUIRED: 
 

Sr. No. Components Range/Rating Quantity 

1. Transistor  SL-100 1 

2. Resistance 270 Ω, 1/4 W 1 

3. Resistance 1 KΩ, 1/4 W 1 

4. Resistance 15 KΩ, 1/4 W 1 

5. Resistance 2.7 KΩ, 1/4 W 1 

6. Capacitor 0.47 µF 2 

 Capacitor 47 µF 1 

7. Capacitor 470 pF 1 

8. Inductor  100 µH 2 

9. Potentiometer 1 KΩ 1 

10. Bread Board  1 

11. Hookup wire 25 SWG  

 
 
 



 
APPARATUS REQUIRED: 
 

Sr. 
No. 

Name of the Apparatus Quantity Range/Rating Make 

1. Variable DC Regulated Power 
Supply  

1 0 – 15 V ELNOVA 

2. Digital Multimeter 1   

3. CRO or DSO  1 20 MHz  

4. Single Strand Connecting Wire 50 cm 24 SWG or 25 SWG  

 

Design: 

BJT-Amplifier design is same as given in Common Emitter 

Amplifier.  

Tank Circuit Design:  

Oscillator Frequency f = fo  

                           Leq = L1 +L2 

Assume   fo = 500 KHz, with  L1 = L2 =100μH,  

We get,    Leq = L1 + L2 = 200μH 

We know,   �6  =  �
"$ √(LW) 

Hence,  Leq x C = 1/(2πfo)2  

This gives C = {1/(2πfo)2}/{ Leq}  

    = {1/(2π x 500 KHz)2}/200 μH 

    = 507 pF  Choose 470 pF as standard value 

For this capacitance value we get    fo = 519 KHz 

 

CIRCUIT DIAGRAM: 



 

Procedure: 
1. Switch on the Power Supply and check the DC conditions by 

removing the coupling capacitor CC1 or CC2. 
2. Connect the coupling capacitors and obtain an output wave form on the 

CRO .If the o/p is distorted vary 1 KΩ Potentiometer (R3) to get perfect 
SINE wave. 

3. Measure the period of oscillation and calculate the frequency of oscillation. 
4. Compare the measured frequency with re-computed theoretical value 

for the component values connected. 

 
Observation: 
 

Parameter VRC VCE VE ICQ = VRC / RC VBE VB 

Assumed 4.8V 6 V 1.2V 4.5 mA 0.6 V 4.8V 

Practical       

 
Result: The frequency of oscillation is ……. 

Fig1: Hartley Oscillator (designed) 



COLPITTS OSCILLATOR
 

Components and equipments
 

Sr. No. Components

1. Transistor 

2. Resistance

3. Resistance

4. Resistance

5. Resistance

6. Capacitor

7. Capacitor

8. Capacitor

9. Inductor 

10. Potentiometer

11. Bread Board

12. Hookup wire

 
 

Design: 

In the Colpitts Oscillator shown in Fig. 2 
the LC tuned circuit. A voltage divider biased common emitter amplifier
amplifier. The amplifier and
degree to satisfy Barkhausen

 
 
 
 
 
 
 
 
 
 
 
 
 
 
Fig. 2 Colpitts Oscillator 

COLPITTS OSCILLATOR  

equipments required: 

Components Range/Rating 

Transistor  BC107B 

Resistance 270 Ω, 1/4 W 

Resistance 1 KΩ, 1/4 W 

Resistance 15 KΩ, 1/4 W 

Resistance 2.7 KΩ, 1/4 W 

Capacitor 0.47 µF 

Capacitor 0.2 µF 

Capacitor 0.02 pF 

Inductor  15 µH 

Potentiometer 1 KΩ 

Bread Board  

wire 25 SWG 

In the Colpitts Oscillator shown in Fig. 2 capacitor C3 and C4 along with L
A voltage divider biased common emitter amplifier

and tank circuit together provides a phase shift
Barkhausen criterion. 

Quantity 

1 

1 

1 

1 

1 

2 

1 

2 

2 

1 

1 

1m 

along with L1 makes 
A voltage divider biased common emitter amplifier is used as 

e shift of 360 



 

Design: 

BJT-Amplifier design is same as given in Common Emitter amplifier.  

Tank Circuit Design:  

Assume   fo = 10 KHz, with C3 = 200 nF, C4 = 20 nF and frequency of oscillation 

10KHz we have to find value of inductor L1. 

We know,   �6  =  �
"$ 

(√(W� � W�

LrW�W�
) 

Hence,   L1 = Wr� W�

T$� % 
�WrW�

 

After solving, inductor value we get    L1 = 13.932 mH 

Voltage gain to produce oscillation is           AV > C3/ C4 

Procedure: 

1. Switch on the Power Supply and check the DC conditions by 
removing the coupling capacitor CC1 orCC2. 

2. Connect the coupling capacitors and obtain an output waveform on the 
CRO. If the o/p is distorted adjust 1-KΩ Potentiometer (R5) to get 
perfect SINE wave. 

3. Measure the period of oscillation and calculate the frequency of oscillation. 
4. Compare the measured frequency with re-computed theoretical value 

for the component values connected. 
 

Observation: 

Parameter VRC VCE VE ICQ = VRC / RC VBE VB 

Assumed 4.8V 6 V 1.2V 4.5 mA 0.6 V 1.8 V 

Practical       

 
 

Result: The frequency of oscillation is ….. 
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AIM: Plot the transfer and drain characteristics of n-channel MOSFET and calculate the 
following parameters. 

1. Drain resistance (rD), 
2. Transconductance  (gm) and  
3. Amplification factor (µ) 

 
Theory: 

In a MOSFET, current flows from the drain terminal to the source terminal through 

a semiconductor channel. The resistance of the channel, and therefore its ability to conduct 

current, is controlled by a voltage applied to a third terminal denoted as the gate. MOSFETs 

can be either an n-channel type or a p-channel type. In an n-channel MOSFET a positive 

voltage is applied to the drain terminal for operation while in a p-channel MOSFET a 

negative voltage is applied to the drain terminal for operation. An n-channel and p-channel 

type MOSFET may be one of two modes; enhancement mode or depletion mode. The 

enhancement mode MOSFET is normally “OFF” (in cutoff and conducting no current) 

when no voltage is applied to the gate and is “ON” (in saturation and conducting current) 

when a voltage greater than the gate-to-source threshold is applied to the gate. The 

depletion mode MOSFET is normally “ON” (in saturation and conducting current) when no 

voltage is applied to the gate and is “OFF” (in cutoff and not conducting current) when a 

voltage more negative than the gate-to-source threshold is applied to the gate.  

Components and equipment required:  
 

Sl. No. Components/Test Equipment Quantity 

1. MOSFET IRF840 01 

2. Resistor-100 Ω 01 



 

3. Bread board  01 

4. 1/24 SWG single strand wire 1m 

5. Regulated Power supply 0 to +30 V 02 

6. Digital Multimeter 03 

 
Circuit setup diagram: 

Procedure: 

Follow the below mentioned steps to obtain the Drain Characteristics 

1. Set up the connections as indicated in the figure. 

2. Keep both VGG and VDD at zero position. 

3. By varying VGG set VGS to some value (slightly greater than the Threshold 

voltage determined from the transfer characteristics) Say +3.0V 

4. Increase VDS by varying VDD gradually and note down the corresponding 

meter readings as shown in the table. 

5. Repeat the steps 3 and 4 for VGS =+3.2V and VGS = +3.4V 

6. Plot the graph of ID vs. VDS 

 
Observation Table:  Drain Characteristics  
 

VGS = 3.0 V VGS = 3.2 V VGS = 3.4 V 
VDS 

(V) 
ID 

(mA) 
VDS 

(V) 
ID 

(mA) 
VDS 

(V) 
ID 

(mA) 
0.0  0.0  0.0  



 

0.2  0.2  0.2  
0.4  0.4  0.4  
0.6  0.6  0.6  
0.8  0.8  0.8  
1.0  1.0  1.0  
1.5  1.5  1.5  
2.0  2.0  2.0  
3.0  3.0  3.0  
4.0  4.0  4.0  
5.0  5.0  5.0  
10.0  10.0  10.0  
12.0  12.0  12.0  
15.0  15.0  15.0  
18.0  18.0  18.0  
20.0  20.0  20.0  

 
Procedure: 

Follow the below mentioned steps to obtain the Transfer Characteristics 

1. Set up the connections as indicated in the figure. 

2. Keep both VGG and VDD at zero position. 

3. Vary the VDD and set VDS = 1V. 

4. Increase VGS by varying VGG gradually and note down the 
corresponding meter readings as shown in the table. 

5. Note down the minimum value of  VGS for which drain current starts 

flowing and record VTH  = 

6. Repeat for VDS = 5 V, 10 V, and 15 V. 

7. Plot the graph of ID vs. VGS 

Observation Table: Transfer Characteristics 
 

VDS = 1.0 V VDS = 5.0 V VDS = 10.0 V VDS = 15.0 V 
VGS 

(V) 
ID 

(mA) 
VGS 

(V) 
ID 

(mA) 
VGS 

(V) 
ID 

(mA) 
VGS 

(V) 
ID 

(mA) 
1.0  1.0  1.0  1.0  
2.0  2.0  2.0  2.0  
2.9  2.9  2.9  2.9  
3.0  3.0  3.0  3.0  
3.1  3.1  3.1  3.1  
3.2  3.2  3.2  3.2  



 

3.3  3.3  3.3  3.3  
3.4  3.4  3.4  3.4  
3.5  3.5  3.5  3.5  
3.8  3.8  3.8  3.8  
4.0  4.0  4.0  4.0  
4.2  4.2  4.2  4.2  
4.5  4.5  4.5  4.5  

 
 

Expected graphs: 

 
 

(a) Drain Characteristics (b) Transfer Characteristics 

 

From the curves determine:  

Transconductance        gm    = ∆ID / ∆VGS mho  

Drain Resistance          rD  = ∆VDS / ∆ID ∆ 

Amplification factor       µ  = gm x rD 

 

Conclusion: 
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AIM  
This experiment will investigate the characteristics of the common-source and common- 
drain amplifier. 
 

Material and Equipment 
NTE 312 N Channel JFET. 
Resistors: 2 k (2), 3.9 KΩ, 10 KΩ (2), 100 KΩ, 200 
KΩ, 1 MΩ. Capacitors: 100 µF, 47µF, 1µF. 
 

Theory 
In this lab, two JFET amplifier configurations will be investigated; the common-source, 
and the common-drain amplifier. 

 
The basic common-source circuit is shown in Fig. 1. In comparison to the BJT 
common-emitter amplifier, the FET amplifier has much higher input impedance, but a 
lower voltage gain. 

 
The voltage gain of the circuit can be expressed as 

 
Av = -gmRD 

 

 
 

Figure 1: Common-Source Amplifier 



 

 

 
 

Figure 2: The Junction Field Effect Transistor(NTE 312) 

 
Figure 2 shows the transistor terminals for your reference.. 

 
The common-drain (CD) amplifier is shown in figure 3. The common-drain 
configuration is often called a source follower as the voltage gain is nearly unity. The 
common drain FET amplifier is similar to the common collector configuration of the 
bipolar junction transistor. 

Figure 3: Common-Drain Amplifier 

Procedure 
 

1) Common-Source Amplifier 
a) Connect the circuit as shown in figure9-1. 
b) Use Cc1 = 1µF, Cc2 = 47µF, Cs=100 µF, RL =3.9 k, RS=RD=2 k, R1 = 200 KΩ , 

R2=100 KΩ, VDD = 12 V. 
c) Apply a sinusoidal signal with frequency 1 KHz, amplitude 1Vp-p, and 

supply voltages at10 V. 
d) Observe the output. 
e) Capture both input and output waveforms. 
f) Calculate the voltage gain. 
g)  Measure the operating point.  



 

1) Common-Drain Amplifier 
a) Connect the circuit as shown in figure9-2. 
b) Use RG = 1 M Ω, RS = RL = 10 K Ω, supply VDD = 10 V and VSS= - 10 V. 
c) Apply a sinusoidal signal with frequency 1 KHz, amplitude 2Vp-p. 
d) Observe the output. 
e) Capture both input and output waveforms. 
f) Calculate the voltage gain. 
g) Measure the operating point. 

 

Questions for the Lab Report 
 

Compare BJT and JFET (in terms of characteristics, applications, merits and 
demerits but not constructional details) 
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S.No Experiment 

1 Study of different types of Network cables and Practically implement the 

cross-wired cable and straight through cable using clamping tool. 

2 Study of Network Devices in Detail. 

3 Study of network IP. 

4 Connect the computers in Local Area Network. 

5 Study of basic network command and Network configuration commands. 

6 Configure a Network topology using packet tracer software. 

7 Configure a Network topology using packet tracer software. 

8 Configure a Network using Distance Vector Routing protocol. 

9 Configure Network using Link State Vector Routing protocol. 
  



 

 

 

 

Hardware and Software Requirement 

 
Hardware Requirement 

RJ-45 connector, 

Climping Tool, 

Twisted pair Cable 

 

Software Requirement 
Command Prompt And Packet Tracer. 



EXPERIMENT-1 

 
Aim: Study of different types of Network cables and Practically implement the cross-wired 

cable and straight through cable using clamping tool. 

 

Apparatus (Components): RJ-45 connector, Climping Tool, Twisted pair Cable 

Procedure: To do these practical following steps should be done: 

 
1. Start by stripping off about 2 inches of the plastic jacket off the end of the cable. Be very 

careful at this point, as to not nick or cut into the wires, which are inside. Doing so could alter 

the characteristics of your cable, or even worse render is useless. Check the wires, one more 

time for nicks or cuts. If there are any, just whack the whole end off, and start over. 

 

2. Spread the wires apart, but be sure to hold onto the base of the jacket with your other hand. 

You do not want the wires to become untwisted down inside the jacket. Category 5 cable 

must only have 1/2 of an inch of 'untwisted' wire at the end; otherwise it will be 'out of spec'. 

At this point, you obviously have ALOT more than 1/2 of an inch of un-twisted wire. 

 

3. You have 2 end jacks, which must be installed on your cable. If you are using a pre-made 

cable, with one of the ends whacked off, you only have one end to install - the crossed over 

end. Below are two diagrams, which show how you need to arrange the cables for each type 

of cable end. Decide at this point which end you are making and examine the associated 

picture below. 

Diagram shows you how to prepare Cross wired connection 
 



Diagram shows you how to prepare straight through wired connection 
 



 

EXPERIMENT-2 

 
Aim: Study of following Network Devices in Detail 

 Repeater 

 Hub 

 Switch 

 Bridge 

 Router 

 Gate Way 

 
Apparatus (Software): No software or hardware needed. 

 
Procedure: Following should be done to understand this practical. 

 
1. Repeater:Functioning at Physical Layer.A repeater is an electronic device that receives a 

signal and retransmits it at a higher level and/or higher power, or onto the other side of an 

obstruction, so that the signal can cover longer distances. Repeater have two ports ,so cannot 

be use to connect for more than two devices 

 

2. Hub: An Ethernet hub, active hub, network hub, repeater hub, hub or concentrator 

is a device for connecting multiple twisted pair or fiber optic Ethernet devices together and 

making them act as a single network segment. Hubs work at the physical layer (layer 1) of the 

OSI model. The device is a form of multiport repeater. Repeater hubs also participate in 

collision detection, forwarding a jam signal to all ports if it detects a collision. 

 

3. Switch:A network switch or switching hub is a computer networking device that 

connects network segments.The term commonly refers to a network bridge that processes and 

routes data at the data link layer (layer 2) of the OSI model. Switches that additionally 

process data at the network layer (layer 3 and above) are often referred to as Layer 3 switches 

or multilayer switches. 

 

4. Bridge: A network bridge connects multiple network segments at the data link layer 

(Layer 2) of the OSI model. In Ethernet networks, the term bridge formally means a device 

that behaves according to the IEEE 802.1D standard. A bridge and switch are very much 

alike; a switch being a bridge with numerous ports. Switch or Layer 2 switch is often used 

interchangeably with bridge.Bridges can analyze incoming data packets to determine if the 

bridge is able to send the given packet to another segment of the network. 

 

5. Router: A router is an electronic device that interconnects two or more computer 

networks, and selectively interchanges packets of data between them. Each data packet 

contains address information that a router can use to determine if the source and destination 

are on the same network, or if the data packet must be transferred from one network to 

another. Where multiple routers are used in a large collection of interconnected networks, the 

routers exchange information about target system addresses, so that each router can build up 

a table showing the preferred paths between any two systems on the interconnected networks. 

 

6. Gate Way: In a communications network, a network node equipped for interfacing with 



another network that uses different protocols. 

 A gateway may contain devices such as protocol translators, impedance matching 

devices, rate converters, fault isolators, or signal translators as necessary to provide 

system interoperability. It also requires the establishment of mutually acceptable 

administrative procedures between both networks. 

 A protocol translation/mapping gateway interconnects networks with different 

network protocol technologies by performing the required protocol conversions. 



 

 

EXPERIMENT- 3 

Aim: Study of network IP 

 

 Classification of IP address 

 Sub netting 

 Super netting 

 

Apparatus (Software): NA 
 

Procedure: Following is required to be study under this practical. 

 Classification of IP address 

 
As show in figure we teach how the ip addresses are classified and when they are used. 

 

Class Address Range Supports 

Class A 1.0.0.1 to 126.255.255.254 Supports 16 million hosts on each of 127 networks. 

Class B 128.1.0.1 to 191.255.255.254 Supports 65,000 hosts on each of 16,000 networks. 

Class C 192.0.1.1 to 223.255.254.254 Supports 254 hosts on each of 2 million networks. 

Class D 224.0.0.0 to 239.255.255.255 Reserved for multicast groups. 

Class E 240.0.0.0 to 254.255.255.254 Reserved. 

 
 

 Sub netting 

Why we Develop sub netting and How to calculate subnet mask and how to identify subnet 

address. 

 

 Super netting 

Why we develop super netting and How to calculate supernet mask and how to identify 

supernet address. 



 

 

EXPERIMENT-4 

 
Aim: Connect the computers in Local Area Network. 

 
Procedure: On the host computer 

 
On the host computer, follow these steps to share the Internet connection: 

 
1. Log on to the host computer as Administrator or as Owner. 

2. Click Start, and then click Control Panel. 

3. Click Network and Internet Connections. 

4. Click Network Connections. 

5. Right-click the connection that you use to connect to the Internet. For example, if you 

connect to the Internet by using a modem, right-click the connection that you want under 

Dial-up / other network available. 

6. Click Properties. 

7. Click the Advanced tab. 

 
8. Under Internet Connection Sharing, select the Allow other network users to connect 

through this computer's Internet connection check box. 

 

9. If you are sharing a dial-up Internet connection, select the Establish a dial-up connection 

whenever a computer on my network attempts to access the Internet check box if you 

want to permit your computer to automatically connect to the Internet. 

 

10. Click OK. You receive the following message: 

 
When Internet Connection Sharing is enabled, your LAN adapter will be set to use IP address 

192.168.0.1. Your computer may lose connectivity with other computers on your network. If 

these other computers have static IP addresses, it is a good idea to set them to obtain their IP 

addresses automatically. Are you sure you want to enable Internet Connection Sharing? 

 

11. Click Yes. 

The connection to the Internet is shared to other computers on the local area network (LAN). 

 
The network adapter that is connected to the LAN is configured with a static IP address of 

192.168.0.1 and a subnet mask of 255.255.255.0 

 
 

On the client computer 

 
To connect to the Internet by using the shared connection, you must confirm the LAN adapter 

IP configuration, and then configure the client computer. To confirm the LAN adapter IP 

configuration, follow these steps: 

 

1. Log on to the client computer as Administrator or as Owner. 

2. Click Start, and then click Control Panel. 



3. Click Network and Internet Connections. 

4. Click Network Connections. 

5. Right-click Local Area Connection and then click Properties. 

6. Click the General tab, click Internet Protocol (TCP/IP) in the connection uses the 

following items list, and then click Properties. 

 

7. In the Internet Protocol (TCP/IP) Properties dialog box, click Obtain an IP address 

automatically (if it is not already selected), and then click OK. 

 

Note: You can also assign a unique static IP address in the range of 192.168.0.2 to 

192.168.0.254. For example, you can assign the following static IP address, subnet mask, and 

default gateway: 

 
8. IP Address 192.168.31.202 

9. Subnet mask 255.255.255.0 

10. Default gateway 192.168.31.1 

 

11. In the Local Area Connection Properties dialog box, click OK. 

 
12. Quit Control Panel. 



 

 

EXPERIMENT- 5 

 
Aim: Study of basic network command and Network configuration commands. 

 
Apparatus (Software): Command Prompt And Packet Tracer. 

 
Procedure: To do this EXPERIMENT- follows these steps: 

 
In this EXPERIMENT- students have to understand basic networking commands e.g ping, 

tracert etc. 

 

All commands related to Network configuration which includes how to switch to privilege 

mode and normal mode and how to configure router interface and how to save this 

configuration to flash memory or permanent memory. 

 
This commands includes 

 

 Configuring the Router commands 

 General Commands to configure network 

 Privileged Mode commands of a router 

 Router Processes & Statistics 

 IP Commands 

 Other IP Commands e.g. show ip route etc. 

ping: 

ping(8) sends an ICMP ECHO_REQUEST packet to the specified host. If the host responds, 

you get an ICMP packet back. Sound strange? Well, you can “ping” an IP address to see if a 

machine is alive. If there is no response, you know something is wrong. 



 
 

Traceroute: 
 

Tracert is a command which can show you the path a packet of information takes from your 

computer to one you specify. It will list all the routers it passes through until it reaches its 

destination, or fails to and is discarded. In addition to this, it will tell you how long each 'hop' 

from router to router takes. 



 
 

 

 

 

 

nslookup: 

 
Displays information from Domain Name System (DNS) name servers. 

NOTE :If you write the command as above it shows as default your pc's server name firstly.  

 

 

 

 

 

 
pathping: 

 
A better version of tracert that gives you statics about packet lost and latency. 



 
 

 

Getting Help 

 
In any command mode, you can get a list of available commands by entering a question mark (?). 

Router>? 

To obtain a list of commands that begin with a particular character sequence, type in those 

haracters followed immediately by the question mark (?). 

 

Router#co? 

 
configure connect copy 

To list keywords or arguments, enter a question mark in place of a keyword or argument. Include 

a space before the question mark. 

 

Router#configure ? 

 
memory Configure from NV memory 

network Configure from a TFTP network host 

terminal Configure from the terminal 

You can also abbreviate commands and keywords by entering just enough characters to make the 

command unique from other commands. For example, you can abbreviate the show command to 

sh. 

 

Configuration Files 

 
Any time you make changes to the router configuration, you must save the changes to memory 

because if you do not they will be lost if there is a system reload or power outage. There are two 

types of configuration files: the running (current operating) configuration and the startup 

configuration. 

Use the following privileged mode commands to work with configuration files. 



• configure terminal – modify the running configuration manually from the terminal. 

 
• show running-config – display the running configuration. 

 
• show startup-config – display the startup configuration. 

 
• copy running-config startup-config – copy the running configuration to the startup 

configuration. 

 

• copy startup-config running-config – copy the startup configuration to the running 

configuration. 

 

• erase startup-config – erase the startup-configuration in NVRAM. 

 
• copy tftp running-config – load a configuration file stored on a Trivial File 

Transfer Protocol (TFTP) server into the running configuration. 

 

• copy running-config tftp – store the running configuration on a TFTP server. 

 

IP Address Configuration 

 
Take the following steps to configure the IP address of an interface. 

Step 1: Enter privileged EXEC mode: 

 

Router>enable password 

 
Step 2: Enter the configure terminal command to enter global configuration mode. 

Router#config terminal 

Step 3: Enter the interface type slot/port (for Cisco 7000 series) or interface type port (for Cisco 

2500 series) to enter the interface configuration mode. 

 

Example: 

Router (config)#interface ethernet 0/1 

Step 4: Enter the IP address and subnet mask of the interface using the ip address ipaddress 

subnetmask command. 

 

Example, 

Router (config-if)#ip address 192.168.10.1 255.255.255.0 

 
Step 5: Exit the configuration mode by pressing Ctrl-Z 

Router(config-if)#[Ctrl-Z] 



EXPERIMENT-6 

 
Aim: Configure a Network topology using packet tracer software. 

 
Apparatus (Software): Packet tracer Software 

 
Procedure: To implement this practical following network topology is required to be 

configured using the commands learned in previous practical. 

 

After configuring the given network a packet should be ping from any one machine to 

another. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
Router0 Configuration Command :......... 

Continue with configuration dialog? [yes/no]: no 



 

Press RETURN to get started! 

Router> 

Router>Enable 

Router#config t 

Enter configuration commands, one per line. End with CNTL/Z. 
 

Router(config)#hostname router0 

router0(config)#interface fastethernet 0/0 

router0(config-if)#ip address 192.168.1.1 255.255.255.0 

router0(config-if)#description router0 fastethernet 0/0 

router0(config-if)#no shutdown 

 

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up 

router0(config-if)#exit 

router0(config)#interface fastethernet 0/1 

router0(config-if)#description router0 fastethernet 0/1 

router0(config-if)#no shutdown 

 

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up 

router0(config-if)#exit 

 

router0(config)#exit 
 

%SYS-5-CONFIG_I: Configured from console by console 

router0#show running-config 

Building configuration... 

 

 

Current configuration : 437 bytes 



! 
 

version 12.4 
 

no service password-encryption 
 

! 
 

hostname router0 
 

! 
 

! 
 

! 
 

! 
 

! 
 

ip ssh version 1 
 

! 
 

! 
 

interface FastEthernet0/0 

description router0 fastethernet 0/0 

ip address 192.168.1.1 255.255.255.0 
 

duplex auto 

speed auto 

! 
 

interface FastEthernet0/1 

description router0 fastethernet 0/1 

no ip address 

duplex auto 

speed auto 

! 
 

interface Vlan1 

no ip address 



shutdown 
 

! 
 

ip classless 
 

! 
 

! 
 

! 
 

! 
 

! 
 

line con 0 
 

line vty 0 4 

login 

! 
 

! 
 

end 

 

 

 

 
router0# 

router0# 

router0#copy running-config startup-config 

Destination filename [startup-config]? 

Building configuration... 

[OK] 

router0# 



EXPERIMENT-7 

 

Aim: Configure a Network topology using packet tracer software. 

 
Apparatus (Software): Packet tracer Software 

 
Procedure: To implement this practical following network topology is required to be 

configured using the commands learned in previous practical. 

 

After configuring the given network a packet should be ping from any one machine to 

another. 
 

 
 

 

 

 

Router0 Configuration Command......... 
 

Router>enable 

Router#configure terminal 

Enter configuration commands, one per line. End with CNTL/Z. 

Router(config)#interface FastEthernet0/0 

Router(config-if)#ip address 192.168.0.254 255.255.255.0 

Router(config-if)#no shutdown 

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up 

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to 

up 

Router(config-if)#exit 



Router(config)#exit 

%SYS-5-CONFIG_I: Configured from console by console 

Router# 

Router#configure terminal 

Enter configuration commands, one per line. End with CNTL/Z. 

Router(config)#interface FastEthernet0/0 

Router(config-if)# 

Router(config-if)#exit 

Router(config)#interface Serial2/0 

Router(config-if)#ip address 192.168.1.1 255.255.255.0 

Router(config-if)#no shutdown 

 

%LINK-5-CHANGED: Interface Serial2/0, changed state to down 

Router(config-if)#exit 

Router(config)#exit 

%SYS-5-CONFIG_I: Configured from console by console 

Router#wr 

Building configuration... 

[OK] 

Router#show running-config 

Building configuration... 

 

Current configuration : 542 bytes 

! 

version 12.2 

no service password-encryption 

! 

hostname Router 

! 

! 

! 

! 

! 

ip ssh version 1 

! 

! 

interface FastEthernet0/0 

ip address 192.168.0.254 255.255.255.0 

duplex auto 

speed auto 

! 

interface FastEthernet1/0 

no ip address 

duplex auto 

speed auto 

shutdown 

! 

interface Serial2/0 

ip address 192.168.1.1 255.255.255.0 

! 



interface Serial3/0 

no ip address 

shutdown 

! 

interface FastEthernet4/0 

no ip address 

shutdown 

! 

interface FastEthernet5/0 

no ip address 

shutdown 

! 

ip classless 

! 

! 

! 

! 

! 

line con 0 

line vty 0 4 

login 

! 

! 

end 

 
 

Router# 

 
Router1 Configuration Command....... 

 

Continue with configuration dialog? [yes/no]: no 

 
 

Press RETURN to get started! 

 

 
 

Router>enable 

Router# 

Router#configure terminal 

Enter configuration commands, one per line. End with CNTL/Z. 

Router(config)#interface Serial2/0 

Router(config-if)#ip address 192.168.1.2 255.255.255.0 

Router(config-if)#no shutdown 

 

%LINK-5-CHANGED: Interface Serial2/0, changed state to up 

Router(config-if)#exit 

Router(config)#exit 

%SYS-5-CONFIG_I: Configured from console by console 

Router#config t 



Enter configuration commands, one per line. End with CNTL/Z. 

Router(config)# 

Router(config)#interface Serial2/0 

Router(config-if)# 

Router(config-if)#exit 

Router(config)#interface FastEthernet0/0 

Router(config-if)#ip address 192.168.2.254 255.255.255.0 

Router(config-if)#no shutdown 

 

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up 

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to 

up 

Router(config-if)#exit 

Router(config)#exit 

%SYS-5-CONFIG_I: Configured from console by console 

Router#wr 

Building configuration... 

[OK] 

Router# 

Router#show running-config 

Building configuration... 

 

Current configuration : 542 bytes 

! 

version 12.2 

no service password-encryption 

! 

hostname Router 

! 

! 

! 

! 

! 

ip ssh version 1 

! 

! 

interface FastEthernet0/0 

ip address 192.168.2.254 255.255.255.0 

duplex auto 

speed auto 

! 

interface FastEthernet1/0 

no ip address 

duplex auto 

speed auto 

shutdown 

! 

interface Serial2/0 

ip address 192.168.1.2 255.255.255.0 

! 



interface Serial3/0 

no ip address 

shutdown 

! 

interface FastEthernet4/0 

no ip address 

shutdown 

! 

interface FastEthernet5/0 

no ip address 

shutdown 

! 

ip classless 

! 

! 

! 

! 

! 

line con 0 

line vty 0 4 

login 

! 

! 

end 

 
 

Router# 

 
IP ROUTE Command..... 

Router#config t 

Enter configuration commands, one per line. End with CNTL/Z. 

Router(config)#ip route 192.168.2.0 255.255.255.0 192.168.2.2 

Router(config)#exit 

Router#show ip route 

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area 

* - candidate default, U - per-user static route, o - ODR 

P - periodic downloaded static route 

 

Gateway of last resort is not set 

 
C 192.168.2.0/24 is directly connected, FastEthernet0/0 

C 192.168.1.2/24 is directly connected, Serial2/0 

S 192.168.2.0/24 [1/0] via 192.168.1.2 

Router# 



IP ROUTE Command..... 

 
Router>enable 

Router#show ip route 

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area 

* - candidate default, U - per-user static route, o - ODR 

P - periodic downloaded static route 

 

Gateway of last resort is not set 

 
S 192.168.0.0/24 [1/0] via 192.168.1.1 

C 192.168.0.0/24 is directly connected, FastEthernet0/0 

C 192.168.1.1/24 is directly connected, Serial2/0 

Router# 



EXPERIMENT- 8 

 
Aim: Configure a Network using Distance Vector Routing protocol. 

 

 RIP 

 
Apparatus (Software): packet tracer software 

 
Procedure: 

1. Develop a Topology shown in figure given below. 

3. Configure all Routers 

4. Implement RIP protocols in Router to configure Network. 
 

 

 

 

 

 

 

 
Router0 configuration..... 

 
Continue with configuration dialog? [yes/no]: no 

 

Press RETURN to get started! 

Router> 

Router>en 

Router#config t 

Enter configuration commands, one per line. End with CNTL/Z. 



Router(config)#hostname router0 

router0(config)#int lo0 

%LINK‐5‐CHANGED: Interface Loopback0, changed state to up 

%LINEPROTO‐5‐UPDOWN: Line protocol on Interface Loopback0, changed state to up 

router0(config‐if)#ip address 10.1.1.1 255.255.255.0 

router0(config‐if)#int f0/0 

router0(config‐if)#ip address 10.1.12.1 255.255.255.0 

router0(config‐if)#no shut 

 
%LINK‐5‐CHANGED: Interface FastEthernet0/0, changed state to up 

router0(config‐if)#int f0/1 

router0(config‐if)#ip address 10.1.14.1 255.255.255.0 

router0(config‐if)#no shut 

 
%LINK‐5‐CHANGED: Interface FastEthernet0/1, changed state to up 

router0(config‐if)#end 

%SYS‐5‐CONFIG_I: Configured from console by console 

router0#wr 

Building configuration... 

[OK] 

router0# 

router0# 

%LINEPROTO‐5‐UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up 

%LINEPROTO‐5‐UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up 

router0 con0 is now available 

Press RETURN to get started. 

 
router0> 

router0>en 

router0#config t 

Enter configuration commands, one per line. End with CNTL/Z. 

router0(config)#router rip 

router0(config‐router)#net 10.0.0.0 

router0(config‐router)# 

router0(config‐router)#end 

%SYS‐5‐CONFIG_I: Configured from console by console 

router0#show ip route 

Codes: C ‐ connected, S ‐ static, I ‐ IGRP, R ‐ RIP, M ‐ mobile, B ‐ BGP 

D ‐ EIGRP, EX ‐ EIGRP external, O ‐ OSPF, IA ‐ OSPF inter area 

N1 ‐ OSPF NSSA external type 1, N2 ‐ OSPF NSSA external type 2 

E1 ‐ OSPF external type 1, E2 ‐ OSPF external type 2, E ‐ EGP 

i ‐ IS‐IS, L1 ‐ IS‐IS level‐1, L2 ‐ IS‐IS level‐2, ia ‐ IS‐IS inter area 

* ‐ candidate default, U ‐ per‐user static route, o ‐ ODR 

P ‐ periodic downloaded static route 

 
Gateway of last resort is not set 



10.0.0.0/24 is subnetted, 3 subnets 

C 10.1.1.0 is directly connected, Loopback0 

C 10.1.12.0 is directly connected, FastEthernet0/0 

C 10.1.14.0 is directly connected, FastEthernet0/1 

router0# 

router0# 

 
Router1 Configuration..... 

 
Continue with configuration dialog? [yes/no]: no 

 

 
Press RETURN to get started! 

 
Router>enable 

Router#config t 

Enter configuration commands, one per line. End with CNTL/Z. 

Router(config)#int lo0 

 
%LINK‐5‐CHANGED: Interface Loopback0, changed state to up 

%LINEPROTO‐5‐UPDOWN: Line protocol on Interface Loopback0, changed state to up 

Router(config‐if)#ip address 10.1.2.1 255.255.255.0 

Router(config‐if)#no shut 

Router(config‐if)#int f0/1 

Router(config‐if)#ip address 10.1.23.1 255.255.255.0 

Router(config‐if)#no shut 

 
%LINK‐5‐CHANGED: Interface FastEthernet0/1, changed state to up 

Router(config‐if)#int f0/0 

Router(config‐if)#ip address 10.1.12.2 255.255.255.0 

Router(config‐if)#no shut 

 
%LINK‐5‐CHANGED: Interface FastEthernet0/0, changed state to up 

%LINEPROTO‐5‐UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up 

Router(config‐if)#end 

%SYS‐5‐CONFIG_I: Configured from console by console 

Router#wr 

Building configuration... 

[OK] 

Router# 

Router# 

Router# 

%LINEPROTO‐5‐UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up 

Router con0 is now available 

Press RETURN to get started. 

 
Router> 

Router>en 

Router#con t 



% Ambiguous command: "con t" 

Router#co t 

% Ambiguous command: "co t" 

Router#conf t 

Enter configuration commands, one per line. End with CNTL/Z. 

Router(config)#router rip 

Router(config‐router)#net 10.0.0.0 

Router(config‐router)# 

Router(config‐router)# 

Router(config‐router)#end 

%SYS‐5‐CONFIG_I: Configured from console by console 

Router# 

 
Router2 Configuration..... 

 

 
Continue with configuration dialog? [yes/no]: no 

 

Press RETURN to get started! 

Router>en 

Router#config t 

Enter configuration commands, one per line. End with CNTL/Z. 

Router(config)#int lo0 

 
%LINK‐5‐CHANGED: Interface Loopback0, changed state to up 

%LINEPROTO‐5‐UPDOWN: Line protocol on Interface Loopback0, changed state to up 

Router(config‐if)#ip address 10.1.3.1 255.255.255.0 

Router(config‐if)#no shut 

Router(config‐if)#int f0/0 

Router(config‐if)#ip address 10.1.23.2 255.255.255.0 

Router(config‐if)#no shut 

 
%LINK‐5‐CHANGED: Interface FastEthernet0/0, changed state to up 

%LINEPROTO‐5‐UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up 

Router(config‐if)#int f0/1 

Router(config‐if)#ip address 10.1.34.1 255.255.255.0 

Router(config‐if)#no shut 

 
%LINK‐5‐CHANGED: Interface FastEthernet0/1, changed state to up 

Router(config‐if)#End 

%SYS‐5‐CONFIG_I: Configured from console by console 

 
Router#wr 

Building configuration... 

[OK] 

Router# 

Router# 

Router# 

%LINEPROTO‐5‐UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up 



Router con0 is now available 
 

 
Press RETURN to get started. 

 

 
Router> 

Router> 

Router>en 

Router#show ip route 

Codes: C ‐ connected, S ‐ static, I ‐ IGRP, R ‐ RIP, M ‐ mobile, B ‐ BGP 

D ‐ EIGRP, EX ‐ EIGRP external, O ‐ OSPF, IA ‐ OSPF inter area 

N1 ‐ OSPF NSSA external type 1, N2 ‐ OSPF NSSA external type 2 

E1 ‐ OSPF external type 1, E2 ‐ OSPF external type 2, E ‐ EGP 

i ‐ IS‐IS, L1 ‐ IS‐IS level‐1, L2 ‐ IS‐IS level‐2, ia ‐ IS‐IS inter area 

* ‐ candidate default, U ‐ per‐user static route, o ‐ ODR 

P ‐ periodic downloaded static route 

Gateway of last resort is not set 

10.0.0.0/24 is subnetted, 3 subnets 

C 10.1.3.0 is directly connected, Loopback0 

C 10.1.23.0 is directly connected, FastEthernet0/0 

C 10.1.34.0 is directly connected, FastEthernet0/1 

Router#config t 

Enter configuration commands, one per line. End with CNTL/Z. 

Router(config)#router rip 

Router(config‐router)#net 10.0.0.0 

Router(config‐router)#end 

%SYS‐5‐CONFIG_I: Configured from console by console 

Router# 

Router# 

Router#show ip route 

Codes: C ‐ connected, S ‐ static, I ‐ IGRP, R ‐ RIP, M ‐ mobile, B ‐ BGP 

D ‐ EIGRP, EX ‐ EIGRP external, O ‐ OSPF, IA ‐ OSPF inter area 

N1 ‐ OSPF NSSA external type 1, N2 ‐ OSPF NSSA external type 2 

E1 ‐ OSPF external type 1, E2 ‐ OSPF external type 2, E ‐ EGP 

i ‐ IS‐IS, L1 ‐ IS‐IS level‐1, L2 ‐ IS‐IS level‐2, ia ‐ IS‐IS inter area 

* ‐ candidate default, U ‐ per‐user static route, o ‐ ODR 

P ‐ periodic downloaded static route 

Gateway of last resort is not set 

10.0.0.0/24 is subnetted, 7 subnets 

R 10.1.1.0 [120/2] via 10.1.23.1, 00:00:19, FastEthernet0/0 

R 10.1.2.0 [120/1] via 10.1.23.1, 00:00:19, FastEthernet0/0 

C 10.1.3.0 is directly connected, Loopback0 

R 10.1.12.0 [120/1] via 10.1.23.1, 00:00:19, FastEthernet0/0 

R 10.1.14.0 [120/2] via 10.1.23.1, 00:00:19, FastEthernet0/0 

C 10.1.23.0 is directly connected, FastEthernet0/0 



C 10.1.34.0 is directly connected, FastEthernet0/1 

Router# 

Router# 

Router# 

 
Router3 Configuration....... 

 
Continue with configuration dialog? [yes/no]: no 

 

Press RETURN to get started! 

Router> 

Router>en 

Router#config t 

Enter configuration commands, one per line. End with CNTL/Z. 

Router(config)#int lo0 

 
%LINK‐5‐CHANGED: Interface Loopback0, changed state to up 

%LINEPROTO‐5‐UPDOWN: Line protocol on Interface Loopback0, changed state to up 

Router(config‐if)#int f0/0 

Router(config‐if)#ip address 10.1.34.2 255.255.255.0 

Router(config‐if)#no shut 

 
%LINK‐5‐CHANGED: Interface FastEthernet0/0, changed state to up 

%LINEPROTO‐5‐UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up 

Router(config‐if)# 

Router(config‐if)#int f0/1 

Router(config‐if)#ip address 10.1.14.2 255.255.255.0 

Router(config‐if)#no shut 

 
%LINK‐5‐CHANGED: Interface FastEthernet0/1, changed state to up 

%LINEPROTO‐5‐UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up 

Router(config‐if)#end 

%SYS‐5‐CONFIG_I: Configured from console by console 

Router#wr 

Building configuration... 

[OK] 

Router# 

Router# 

Router#show ip route 

Codes: C ‐ connected, S ‐ static, I ‐ IGRP, R ‐ RIP, M ‐ mobile, B ‐ BGP 

D ‐ EIGRP, EX ‐ EIGRP external, O ‐ OSPF, IA ‐ OSPF inter area 

N1 ‐ OSPF NSSA external type 1, N2 ‐ OSPF NSSA external type 2 

E1 ‐ OSPF external type 1, E2 ‐ OSPF external type 2, E ‐ EGP 

i ‐ IS‐IS, L1 ‐ IS‐IS level‐1, L2 ‐ IS‐IS level‐2, ia ‐ IS‐IS inter area 

* ‐ candidate default, U ‐ per‐user static route, o ‐ ODR 

P ‐ periodic downloaded static route 

 
Gateway of last resort is not set 



10.0.0.0/24 is subnetted, 2 subnets 

C 10.1.14.0 is directly connected, FastEthernet0/1 

C 10.1.34.0 is directly connected, FastEthernet0/0 

Router#conf t 

Enter configuration commands, one per line. End with CNTL/Z. 

Router(config)#router rip 

Router(config‐router)#net 10.0.0.0 

Router(config‐router)# 

 
Router(config‐router)#end 

%SYS‐5‐CONFIG_I: Configured from console by console 

Router#show ip route 

Codes: C ‐ connected, S ‐ static, I ‐ IGRP, R ‐ RIP, M ‐ mobile, B ‐ BGP 

D ‐ EIGRP, EX ‐ EIGRP external, O ‐ OSPF, IA ‐ OSPF inter area 

N1 ‐ OSPF NSSA external type 1, N2 ‐ OSPF NSSA external type 2 

E1 ‐ OSPF external type 1, E2 ‐ OSPF external type 2, E ‐ EGP 

i ‐ IS‐IS, L1 ‐ IS‐IS level‐1, L2 ‐ IS‐IS level‐2, ia ‐ IS‐IS inter area 

* ‐ candidate default, U ‐ per‐user static route, o ‐ ODR 

P ‐ periodic downloaded static route 

Gateway of last resort is not set 

10.0.0.0/24 is subnetted, 7 subnets 

R 10.1.1.0 [120/1] via 10.1.14.1, 00:00:09, FastEthernet0/1 

R 10.1.2.0 [120/2] via 10.1.34.1, 00:00:14, FastEthernet0/0 

[120/2] via 10.1.14.1, 00:00:09, FastEthernet0/1 

R 10.1.3.0 [120/1] via 10.1.34.1, 00:00:14, FastEthernet0/0 

R 10.1.12.0 [120/1] via 10.1.14.1, 00:00:09, FastEthernet0/1 

C 10.1.14.0 is directly connected, FastEthernet0/1 

R 10.1.23.0 [120/1] via 10.1.34.1, 00:00:14, FastEthernet0/0 

C 10.1.34.0 is directly connected, FastEthernet0/0 

Router# 



EXPERIMENT- 9 

 
Aim: Configure Network using Link State Vector Routing protocol. 

 OSPF 

 
Apparatus (Software): Packet Tracer Software 

 
Procedure: 

 
1. Develop a Topology shown in figure given below. 

2. Configure all the workstations 

3. Configure all switches 

4. Configure all Routers 

5. Implement OSPF protocols in Router to configure Network. 
 

 



 
Laboratory Manual 

 

VLSI Design Lab                 

(EC 792) 

PART - 1 
FAMILIARITY WITH SPICE 

SIMULATION TOOL 

 

 



VLSI Design Laboratory (EC-792) 

 

Index 

 

Part 1. 
 Name of the Experiments Page 

No. 

 Chapter 1. Familiarity with Spice simulation tool. 1-6 

 Chapter 2. DC Operating Point Analysis  7-12 

 Chapter 3. DC Transfer Analysis. 13-16 

 Chapter 4. Transient Analysis—Inverter   17-19 

 Chapter 5. AC Analysis  20-23 

 Chapter 6. Using Sub-circuits  24-27 

 Chapter 7. Transient Analysis—CMOS D-Latch  28-30 

 Chapter 8. Command Reference 31-36 

 Chapter 9. Experiments Using T-Spice 37-45 

Part 2.    

 Chapter 10. Software Familiarization 46-53 

 Chapter 11. Experiments Using Xilinx Software 54-69 

 Chapter 12. Implementation of 2:4 Decoder using Xilinx 

ISE Tool 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

70-75 



 
 



CHAPTER 1: SOFTWARE FAMILIARIZATION 

T-Spice User Guide 

S-EDIT 
Simulating Schematics in S-EDIT 

 

 

 

 

 

 

Creating a new Schematic Cell 

1. Run Tanner Tools S-Edit, Tanner’s schematic entry program. Invoke File -> new design 

2. Type the design name and locate it in a specified folder and click OK. 
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3. Add libraries from libraries toolbar-Add (all.tanner), it includes complete library components. This 

all folder is located at: Specific Folder\Tanner EDA\Tanner Tools v14.1\Libraries\All 

4. Now create a cell. Invoke Cell > New View : Give a name to cell0: (Inverter) 

 

 
 

After pressing OK, you will get an empty drawing area for a new schematic view.  

Placing Instances 

5. Click on devices for CMOS Inverter design-Select PMOS and click on Instance. 

6. Instance Cell dialog will appear, you can change the instance name or properties of the cell you are 

about to instance. 

7. With mouse device will attached, place it by single click, right click on workspace or press “Esc” 

key or “done” button on the instance cell dialog to go back.  

8. To move a component anywhere at workspace, click on component, then by pressing mouse scroll 

button or by pressing left mouse key, or select and press “Alt+M”  key it can be moved anywhere. 

9. Additional instances of PMOS can be placed by continuing to click the mouse to place instances.  

10. When opening a view, you can force the new view to open in a new window by holding the Ctrl key 

down when opening the new view.  

11. Let’s pan and zoom around the design.  

 Use the  +/-  keys to zoom in and out of the design.  

 Scroll the mouse wheel to zoom in and out of the design, centered at the cursor.  

 Use the arrow keys to pan up/down/left/right.  

 Press and release the Z key, then click and drag the left mouse button over a region to zoom 

into that region (“create a zoom box”).  

 Use the Home key to fit the entire contents to the window.  

12. Shortcut for Draw menu 

 Draw > Force Move   ----------------- select and press  Alt + M 

 Draw > Rotate -------------------------- select and press  R 

 Draw > Flip > Flip Horizontal ------  select and press H 

 Draw > Flip > Flip Vertical ---------- select and press V 

Edit > Undo (Ctrl + Z)  

13. Similarly paste NMOS -> 

14. Properties of devices can be changed from properties toolbar, it is customizable. But don’t change 

the instance name or properties of the cell you are about to instance. 

15. Select misc from library toolbar, and paste Vdd and Gnd 

16. Select SPICE_Elements then voltage source, Type of voltage can be changed by instance cell, Paste 

one DC and one Pulse voltage source at workspace 

 

Making Connections and placing Input, output ports 

 

17. Now connections can be made from wire selection from Electrical Toolbar 

18. Just click on open node of device and wire the nodes accordingly 

19. Now  add Input port and Output port 
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20. Now connect input, output port accordingly 

 

Checking the Schematic 

21. Invoke Tools > Design Checks and press the Check view and hierarchy button (  ), to perform a 

schematic check. The design checker will report warnings for the unconnected wire end, the 

unconnected symbol port, Instances with no name or non-unique name, Ports with the same name 

have the same type and the unconnected net label. You can jump to step 28 if you do not want to 

follow the steps to create symbol or step 31 to avoid writing Spice commands in netlist also. 

 

Moving Instances with Rubberbanding 

22. Select the PMOS and Vdd instances at the top of the schematic, as well as the attached wires, by 

drawing a selection box. First enter selection mode by pressing the Select toolbar button ( ), then 

press and hold down the left mouse button, drag a rectangle, then release the mouse button. Now 

press and hold the middle mouse button while dragging the mouse up or down to move the two 

instances without breaking any connections.  

 

Creating a new Symbol 

23. Invoke Cell > New View, and select the name (Eg. Ringvco) for design, Inverter for the cell, and 

symbol for view type. Enter view_1 for View name and Interface name. After pressing OK, you will 

get an empty drawing area for a new symbol view  

 

Automatic Symbol Generation and Update 

24. Invoke Cell > Update Symbol, and S-Edit will create a symbol  

25. Modify this symbol to make a symbol more suitable for an inverter. Draw a triangle for symbol using 

the path drawing tool. To draw a path, select the Path drawing button on the toolbar, (), then select 

the All Angle button on the segment toolbar, (), then click the left mouse button to place the first 

vertex, subsequent clicks with the left mouse button will place additional vertices. Clicking the right 

mouse button ends the wire without placing a vertex, and double clicking the left mouse button will 

end the path with placing a vertex at the double click location.  

26. Delete the box that was placed by Update Symbol. Press the Select button on the toolbar (), click on 

the box to select it (it will highlight when selected) and press the delete key to delete the box.  Move 

the ports and labels onto the new graphics you have drawn 

27. Use View Symbol (   ) and View Schematic (   ) toolbar buttons to open the Symbol or Schematic 

view that corresponds to the currently active window. Pressing the “?” key will toggle between 

symbol and schematic views of a cell.    

 

Including Spice Commands and Checking Waveform 

28. Now include SPICE_commands (print voltage) from library & Connect this to input and output port 

to check waveform 

29. Include model file (hp05.md) with SPICE_commands -> include Hp05.md file location is inserted as 

shown below: 

“Specific folder where Examples and tutorial was installed during set up\Tanner EDA\Tanner Tools 

v13.0\L-Edit and LVS\LVS\SPR_Core\hp05.md” 

Note: Tutorial and example files may be installed at any time by invoking Help > Setup 

Examples and Tutorial from S-Edit, or by invoking Setup Examples and Tutorial from the 

Windows start menu for S-Edit. Modified tutorial files Can be replaced  with a fresh copy of 

the tutorial files by invoking Help > Setup Examples and Tutorial, and choosing Repair, when 

asked to select from the options Modify, Repair, and Remove. 

30. Paste this include command anywhere at workspace. 
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31. Now circuit is complete. Just save it. You can follow different saving options given below. 

There are four ways of saving a file:  

 File > Save > Save Design. Design Name saves modifications to the design, but does not 

save modifications to any libraries.  

 File > Save > Save Design.  Design Name and Its Libraries saves modifications to the 

design and all libraries.  

 File > Save > Save # Selected Design/Libraries saves those Design/Libraries that are 

selected in the list of libraries in the Library browser.  

 The Save Copy of … command saves a copy of the selected Design and Libraries in the 

Library Browser to a new location on disk. The Save Copy of … command is not the same as 

a Save As command in that after the command is issued, the application is still editing the 

original design, not the newly saved design.  

 

 

Simulating the Design 

SPICE simulation using the T-Spice engine 

 

32. For simulation of design go to Setup-> Spice Simulation 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

33. Select Spice options (Eg. DC Operating Point Analysis and/or Transient Analysis) then define time 

and other parameters. Press OK in the Simulation Setup dialog. 

34. Select Tools-> start simulation or press the Simulate button, ( ), to run the simulation. It will follow 

Procedure 1 given in T-Spice demonstration. Go to the next page. 

 

 



VLSI Design Lab                   (EC 792) 

 

Siliguri Institute of Technology | Department: Electronics and Communication Engineering 5 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

T-SPICE 

 

Procedure 1: 
 

Running simulation in S-Edit will automatically invoke T-Spice software. Waveform appears in W-

Edit window directly. 

 

Procedure 2: 

 

1. If Steps 28-30 are not followed earlier then click on T-Spice icon [T] in S-Edit window. A Netlist 

file will be open with extension .sp. Place the cursor at the beginning of the next blank line. 

Invoke Edit > Insert Command (shortcut Ctrl+M or use the toolbar icon) to open the 

Command Tool. Insert desired Spice commands. To include model file specify the path “Specific 

folder where Examples and tutorial was installed during set up\Tanner EDA\Tanner Tools 

v14.1\L-Edit and LVS\LVS\SPR_Core\hp05.md”.  Insert also the output commands as per 

requirement. For an example a T-Spice netlist file is given below. 

2. Then simulation -> run simulation or click on simulation icon. T-Spice will automatically invoke 

W-Edit. 
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W-EDIT 

 

Waveform can be checked using W-Edit. It will automatically invoke at the time of running T-spice. 

Results will appear in W-Edit, displaying the voltage waveforms for the nodes indicated with the 

Print Voltage commands or commands inserted in the netlist file.  



CHAPTER 2: DC OPERATING POINT ANALYSIS  

DC operating point analysis finds a circuit’s steady-state condition, obtained (in principle) after 

the input voltages have been applied for an infinite amount of time. 

 

Schematic    ...\Tanner EDA\Tanner Tools v12.6\T-Spice\Analysis Examples\ 

Inverter_TestBench Operating Point 

T-Spice Input    ...\Tanner EDA\Tanner Tools v12.6\T-Spice\Simulation Results\ 

Inverter OP.sp 

Output    ...\Tanner EDA\Tanner Tools v12.6\T-Spice\Simulation Results\ 

Inverter OP.out 

 

 

Schematic 
 

 
 

(This CMOS inverter is also used in Example 2: DC Transfer Analysis and Example 3: Transient 

Analysis—Inverter.) 

 

Each of the components visible in the schematic has properties associated with it. Properties are 

textual elements, created in DxDesigner, that are attached to an object and provide key 

information about its design and simulation commands in T-Spice. 

 

If you "push in" to open a specific instance, you can see that the physical dimensions of the 

component N1 in the inverter are defined by the properties: 

 

M = 1 

W = 2.5u 

L = 0.25u 
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N1 is an instance of the symbol NMOS, which represents an n-channel MOSFET transistor. 

Properties that describe the operation of a generic n-channel MOSFET are defined at the symbol 

level. Properties specific to component N1, such as length and width, are defined when N1 is 

created. Property values defined at the component level take precedence over default (symbol) 

values. 

 

SPICE Simulation Setup in S-Edit 

 

Prior to running the T-Spice simulation, the analysis commands and all processing options need 

to be established. This is accomplished using the Setup SPICE Simulation dialog in 

DxDesigner. 

 

􀀻 Ensure that you are viewing the top level schematic. For this example, the top level cell is 

named inverter_TestBench OperatingPoint. Right-click on inverter_TestBench in the 

Libraries window and use Open View to select the schematic OperatingPoint. 

 

􀀻 Use Setup > SPICE Simulation to launch the Setup SPICE Simulation dialog. The proper 

simulation settings for the Inverter_TestBench example have already been entered for you. 

Note that the DC Operating Point Analysis box is checked. Also note the settings in the 

General options for File Search Path and Include Files. 
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Export the Netlist to T-Spice 

􀀻 In the inverter_Testbench Operating Point schematic, use Tools > Design Checks to 

execute the Design Checker. 

􀀻 The Design Checker will display any violation or errors in the Command window. There 

should not be any errors in the file inverter_Testbench Operating Point. 

􀀻 Press the T-Spice icon ( ) to export a T-Spice netlist file named inverterOP.sp. DxDesigner 

will launch T-Spice with the inverterOP.sp netlist open. 

 

 

T-Spice Input 
 

********* Simulation Settings - General section ********* 

.option search="C:\src\TannerToolsShippingFiles\Libraries\Models" 

.lib "Generic_025.lib" TT 

*-------- Devices: SPICE.ORDER < 0 -------- 

* Design: AnalysisExamples / Cell: Inverter_TestBench / View: OperatingPoint 

/ Page: 

* Designed by: Tanner EDA Library Development Team 

* Organization: Tanner EDA - Tanner Research, Inc. 

* Info: Operating point analysis testbench of an inverter 

* Date: 06/15/2007 2:56:17 PM 

* Revision: 0 

 

*************** Subcircuits ***************** 

.subckt INV A Out Gnd Vdd 

*-------- Devices: SPICE.ORDER < 0 -------- 

* Design: LogicGates / Cell: INV / View: Main / Page: 

* Designed by: Tanner EDA Library Development Team 

* Organization: Tanner EDA - Tanner Research, Inc. 

* Info: Inverter 

* Date: 06/15/2007 2:56:17 PM 

* Revision: 0 

 

*-------- Devices: SPICE.ORDER == 0 -------- 

MP1 Out A Vdd Vdd PMOS W=2.5u L=250n M=2 AS=4.5p PS=13.6u AD=3.125p PD=7.5u 

MN1 Out A Gnd 0 NMOS W=2.5u L=250n AS=2.25p PS=6.8u AD=2.25p PD=6.8u 

.ends 

 

********* Simulation Settings - Parameters and SPICE Options ********* 

.param Vpwr = 3.3v 

*-------- Devices: SPICE.ORDER == 0 -------- 

VVin N_2 Gnd DC 1 

XX1 N_2 N_1 Gnd Vdd INV 

VVpower Vdd Gnd DC Vpwr 

CC1 N_1 Gnd 1p 
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********* Simulation Settings - Analysis section ********* 

.op 

 

********* Simulation Settings - Additional SPICE commands ********* 

 

.end 

 

Two transistors, MP1 and MN1, are defined in inverterOP.sp. These are MOSFETs, as 

indicated by the key letter M that begins their names. Following each transistor name are the 

names of its terminals in the required order: drain–gate–source–bulk. Then the model name 

(PMOS or NMOS in this example) and physical characteristics, such as length and width, are 

specified. 

 

A capacitor CC1 (signified by the key letter C) connects nodes N 1 and GND with a capacitance 

of 1p. (Strictly speaking, the capacitor could be omitted from the circuit for this example, since it 

does not affect the DC operation of the inverter.) 

 

Two DC voltage sources are defined: VVin, which sets node N2 to 1.0 volt relative to ground 

and VVpower, which sets node Vdd to 3.3 volts as defined by the variable Vpwr. 

 
􀀻 Notice that the simulation settings which were entered in the SPICE Simulation Setup dialog 

resulted in .option, .lib, and .op commands being written to the T-Spice input file. The .lib 

command causes T-Spice to read the contents of the Generic_025.lib library file for the 

evaluation of transistors MP1 and MN1, and the search option identifies the path to the library 

files. In this case, the library file contains two device .model commands, describing MOSFET 

models PMOS and NMOS, as shown below for 

PMOS: 

+VERSION = 3.1                TNOM = 27                                 TOX = 5.6E-9 

+XJ            = 1E-7              NCH = 4.1589E17                        VTH0 = -0.4935548 

+K1            = 0.6143278      K2 = 6.804492E-4                        K3 = 0 

+K3B          = 5.8844074     W0 = 1E-6                                   NLX = 6.938169E-9 

+DVT0W    = 0                   DVT1W = 0                                 DVT2W = 0 

+DVT0        = 2.3578746     DVT1 = 0.7014778                      DVT2 = -0.1881376 

+U0            = 100                UA = 9.119231E-10                    UB = 1E-21 

+UC            = -1E-10          VSAT = 1.782051E5                   A0 = 0.9704347 

+AGS         = 0.1073973      B0 = 2.773991E-7                       B1 = 8.423987E-7 

+KETA       = 0.0104811     A1 = 0.0193128                           A2 = 0.3 

+RDSW      = 694.5830247  PRWG = 0.3169639                     PRWB = -0.1958978 

+WR           = 1                  WINT = 0                                   LINT = 2.971337E-8 

+XL            = 0                  XW = -4E-8                                DWG = -2.967296E-8 

+DWB        = -2.31786E-10 VOFF = -0.1152095                    NFACTOR = 1.1064678 

+CIT          = 0                   CDSC = 2.4E-4                           CDSCD = 0 

+CDSCB    = 0                   ETA0 = 0.3676411                      ETAB = -0.0915241 

+DSUB       = 1.1089801     PCLM = 1.3226289                     PDIBLC1 = 9.913816E-3 

+PDIBLC2  = -1.499968E-6 PDIBLCB = -1E-3                     DROUT = 0.1276027 

+PSCBE1   = 8E10             PSCBE2 = 5.772776E-10             PVAG = 0.0135936 
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+DELTA = 0.01                        RSH = 3                             MOBMOD = 1 

+PRT = 0                                  UTE = -1.5                         KT1 = -0.11 

+KT1L = 0                                KT2 = 0.022                       UA1 = 4.31E-9 

+UB1 = -7.61E-18                     UC1 = -5.6E-11                  AT = 3.3E4 

+WL = 0                                   WLN = 1                            WW = 0 

+WWN = 1                               WWL = 0                            LL = 0 

+LLN = 1                                  LW = 0                               LWN = 1 

+LWL = 0                                CAPMOD = 2                       XPART = 0.5 

+CGDO = 5.59E-10                  CGSO = 5.59E-10                 CGBO = 5E-10 

+CJ = 1.857995E-3                   PB = 0.9771691                    MJ = 0.4686434 

+CJSW = 3.426642E-10            PBSW = 0.871788                MJSW = 0.3314778 

+CJSWG = 2.5E-10                  PBSWG = 0.871788              MJSWG = 0.3314778 

+CF = 0                                   PVTH0 = 4.137981E-3          PRDSW = 7.2931065 

+PK2 = 2.600307E-3                WKETA = 0.0192532            LKETA = -5.972879E-3 

) 

 

Generic_025.lib assigns values to various Level 49 MOSFET model parameters for both n- and 

pchannel devices. T-Spice uses these parameters to evaluate Level 49 MOSFET model 

equations.  

 

The .op command performs a DC operating point calculation and writes the results to the file 

specified in the Simulation > Run Simulation dialog. 

 

Run the Simulation In T-Spice 

 

􀀻 With inverterOP.sp open in T-Spice, use File > Save to save the file. 

􀀻 Click the Run Simulation button ( ) in the T-Spice simulation toolbar. 

􀀻 In the Run Simulation dialog, click Start Simulation. 

􀀻 T-Spice will open a new window displaying the simulation log. 

 

 

Output 
 

The output file lists the DC operating point information for the circuit. You can read this file in 

T-Spice 

or any text editor. 

Open the Output File 

 

􀀻 If not already displayed, select View > Simulation Manager from the T-Spice menu to open 

the 

Simulation Manager: 
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􀀻 Select the InverterOP.out display line in the window, then click the Show Output button to 

open the output file InverterOP.out in a new T-Spice window. 

 

􀀻 If you prefer to view the output in a text editor, simply open InverterOP.out as a text file. (It 

is located in the same directory as the input file.) 

 

􀀻 The output file contains the following DC operating point information (in addition to 

comments of various kinds, not shown here. (You can also view DC operating voltages, currents 

and small-signal parameters in S-Edit.) 

 

DC ANALYSIS - temperature=25.0 

v(N_1) = 3.0633e+000 

v(N_2) = 1.0000e+000 

v(Vdd) = 3.3000e+000 

i1(VVin) = 0.0000e+000 

i2(VVin) = 0.0000e+000 

i1(VVpower) = -3.1508e-004 

i2(VVpower) = 3.1508e-004 



CHAPTER 3: DC TRANSFER ANALYSIS  

DC transfer analysis is used to study the voltage or current at one set of points in a circuit as a 

function of the voltage or current at another set of points. This is done by sweeping the source 

variables over specified ranges and recording the output. 

 

Schematic 
 

 
This schematic includes a .print command, which measures and records voltages at the input and 

output nodes of the circuit. The command is contained within the DC analysis output cell. 

 

 

T-Spice Input 
 

If T-Spice is open when you run the simulation in S-Edit, the SPICE file inverterDC.sp will 

open and run automatically. 

********* Simulation Settings - General section ********* 

.option search="...\Tanner EDA\Tanner Tools v12.6\Libraries\Models" 

.probe 

.option probev 

.lib "Generic_025.lib" TT 

*-------- Devices: SPICE.ORDER < 0 -------- 

* Design: AnalysisExamples / Cell: Inverter_TestBench / View: DCAnalysis / 

Page: 

* Designed by: Tanner EDA Library Development Team 

* Organization: Tanner EDA - Tanner Research, Inc. 

* Info: DC analysis testbench of an inverter 

* Date: 06/15/2007 2:56:17 PM 

* Revision: 0 

*************** Subcircuits ***************** 
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.subckt INV A Out Gnd Vdd 

 

*-------- Devices: SPICE.ORDER < 0 -------- 

 

* Design: LogicGates / Cell: INV / View: Main / Page: 

* Designed by: Tanner EDA Library Development Team 

* Organization: Tanner EDA - Tanner Research, Inc. 

* Info: Inverter 

* Date: 06/15/2007 2:56:17 PM 

* Revision: 0 

 

*-------- Devices: SPICE.ORDER == 0 -------- 

 

MP1 Out A Vdd Vdd PMOS W=2.5u L=250n M=2 AS=4.5p PS=13.6u AD=3.125p PD=7.5u 

MN1 Out A Gnd 0 NMOS W=2.5u L=250n AS=2.25p PS=6.8u AD=2.25p PD=6.8u 

.ends 

‘ 

********* Simulation Settings - Parameters and SPICE Options ********* 

 

.param Vpwr = 3.3v 

 

*-------- Devices: SPICE.ORDER == 0 -------- 

 

VVin In Gnd DC 1 

XX1 In Out Gnd Vdd INV 

VVpower Vdd Gnd DC Vpwr 

CC1 Out Gnd 1p 

 

*-------- Devices: SPICE.ORDER > 0 -------- 

. 

PRINT DC V(Out) 

.PRINT DC V(In) 

 

********* Simulation Settings - Analysis section ********* 

 

.dc lin VVin 0.0 3.3 0.02 lin VVpower 2.3 4.3 0.5 

 

********* Simulation Settings - Additional SPICE commands ********* 

 

.end 

 

The .DC command, indicating transfer analysis, is followed by the parameter lin, which specifies 

a linear sweep. Next is a list of sources to be swept, and the voltage ranges across which the 

sweeps are to take place. 
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In this example, VVin will be swept from 0 to 3.3 volts in 0.02 volt increments, and VVpower 

will be swept from 2.3 to 4.3 volts in 0.5 volt increments. 

 

The transfer analysis will be performed as follows: VVpower will be set at 2.3 volts and V1 will 

be swept over its specified range; VVpower will then be incremented to 2.5 volts and V1 will be 

reswept over its range; and so on, until VVpower reaches the upper limit of its range. 

 

The .DC command ignores the values assigned to the voltage sources VVpower and VVin in the 

voltage source statements; however, they must be declared in those statements. 

 

The resulting voltages for nodes IN and OUT are reported by the .PRINT DC command to the 

specified destination. 

 

Output 
 

When W-Edit launches, simulation results of the same data type, which in this case is voltage, 

are automatically plotted on a single chart. In this example, traces were separated into different 

charts and reorganized (according to data type) using the commands in Chart > Expand Chart 

of the W-Edit menu. 

The charts below show input and output voltages to the circuit, with separate traces for each 

sweep of v(Out). To view detailed information about a trace, double-click on the trace or on the 

trace label located in the upper right corner of the chart. 
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The Trace Properties dialog displays the value of parameter v(Out) corresponding to each 

trace, as well as labels and line properties.  

 

 



 

 

CHAPTER 4: TRANSIENT ANALYSIS—INVERTER   

Transient analysis provides information on how circuit elements vary with time. 

The basic T-Spice command for transient analysis has three modes. In the op mode (default), the 

DC operating point is computed, and T-Spice uses this as the starting point for the transient 

simulation. 

 

Schematic 
 

 
 

T-Spice Input 
 

********* Simulation Settings - General section ********* 

.option search="...\Tanner EDA\Tanner Tools v12.6\Libraries\Models" 

.probe 

.option probev 

.option probei 

.lib "Generic_025.lib" TT 

 

*-------- Devices: SPICE.ORDER < 0 -------- 

* Design: AnalysisExamples / Cell: Inverter_TestBench / View: 

TransientAnalysis / Page: 

* Designed by: Tanner EDA Library Development Team 

* Organization: Tanner EDA - Tanner Research, Inc. 
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* Info: Transient analysis testbench of an inverter 

* Date: 12/18/2005 7:28:14 PM 

* Revision: 5 

 

*************** Subcircuits ***************** 

 

.subckt INV A Out Gnd Vdd 

*-------- Devices: SPICE.ORDER < 0 -------- 

* Design: LogicGates / Cell: INV / View: Main / Page: 

* Designed by: Tanner EDA Library Development Team 

* Organization: Tanner EDA - Tanner Research, Inc. 

* Info: Inverter 

* Date: 12/18/2005 7:28:14 PM 

* Revision: 5 

 

*-------- Devices: SPICE.ORDER == 0 -------- 

 

MP1 Out A Vdd Vdd PMOS W=2.5u L=250n M=2 AS=4.5p PS=13.6u AD=3.125p PD=7.5u 

MN1 Out A Gnd 0 NMOS W=2.5u L=250n AS=2.25p PS=6.8u AD=2.25p PD=6.8u 

.ends 

 

********* Simulation Settings - Parameters and SPICE Options ********* 

 

.param Vpwr = 3.3v 

 

*-------- Devices: SPICE.ORDER == 0 -------- 

 

VVin In Gnd PULSE(0 Vpwr 0 1n 1n 49n 100n) 

XX1 In Out Gnd Vdd INV 

VVpower Vdd Gnd DC Vpwr 

CC1 Out Gnd 1p 

 

*-------- Devices: SPICE.ORDER > 0 -------- 

 

.PRINT TRAN V(Out) 

.PRINT TRAN V(In) 

.MEASURE TRAN RiseDelay_MeasureDelay_1 TRIG v(In) VAL='(Vpwr-0)*50/100+0' 

TD='0' RISE=1 TARG v(Out) VAL='(Vpwr-0)*50/100+0' TD='0' FALL=1 OFF 

.MEASURE TRAN FallDelay_MeasureDelay_1 TRIG v(In) VAL='(Vpwr-0)*50/100+0' 

TD='0' FALL=1 TARG v(Out) VAL='(Vpwr-0)*50/100+0' TD='0' RISE=1 OFF 

.MEASURE TRAN AvgDelay 

PARAM='(RiseDelay_MeasureDelay_1+FallDelay_MeasureDelay_1)/2.0' ON 

.MEASURE TRAN FallTime TRIG v(Out) VAL='(Vpwr-0)*90/100+0' TD=0 Fall=1 TARG 

v(Out) VAL='(Vpwr-0)*10/100+0' TD=0 FALL=1 ON 

.MEASURE TRAN RiseTime TRIG v(Out) VAL='(Vpwr-0)*10/100+0' TD=0 RISE=1 TARG 

v(Out) VAL='(Vpwr-0)*90/100+0' TD=0 RISE=1 ON 
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********* Simulation Settings - Analysis section ********* 

 

.tran 250p 300n 

 

********* Simulation Settings - Additional SPICE commands ********* 

 

.end 

 

This circuit is similar to that of chapter 1, except that voltage source VVin here generates a pulse 

(indicated by the keyword pulse) to In, rather than setting a constant value. 

 

The times and voltages that define the “legs” of the waveform are specified in the arguments to 

pulse.The initial current is zero amperes and the peak current is Vpwr, with an initial delay of 

zero seconds.The rise and fall times are one nanosecond, with a pulse width of 49 nanoseconds 

and a pulse period of100 nanoseconds. 

 

The .tran command specifies the characteristices of the transient analysis to be performed; in 

this example the maximum time step allowed is 250 pico with a total duration of 300 

nanoseconds. 

 

Output 

 



 

 

CHAPTER 5: AC ANALYSIS  

AC analysis characterizes the circuit’s behavior dependence on small-signal input frequency. It 

involves three steps: 

 (1) Calculating the DC operating point; 

 (2) Linearizing the circuit; and  

(3) solving the linearized circuit for each frequency. 

This example involves a standard operational amplifier, consisting of one PMOS, one NMOS, a 

transconductance amplifier and one capacitor. 

 

 

Schematic 
 

 
 

T-Spice Input 
 

********* Simulation Settings - General section ********* 

.option Accurate 

.option search="...\Tanner EDA\Tanner Tools v12.6\Libraries\Models" 

.probe 

.option probev 

.option probei 

.lib "Generic_025.lib" TT 

 

*************** Subcircuits ***************** 

 

.subckt TransAmp in1 in2 out vbias Gnd Vdd 
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*-------- Devices: SPICE.ORDER < 0 -------- 

 

* Design: AnalysisExamples / Cell: TransAmp / View: Main / Page: 

* Designed by: Tanner EDA Library Development Team 

* Organization: Tanner EDA - Tanner Research, Inc. 

* Info: Transconductance Amplifier 

* Date: 06/15/2007 2:56:17 PM 

* Revision: 0 

 

*-------- Devices: SPICE.ORDER == 0 -------- 

 

MMP1 vm1 vm1 Vdd Vdd PMOS W=2u L=2u AS=1.8p PS=5.8u AD=1.8p PD=5.8u 

MMP2 out vm1 Vdd Vdd PMOS W=2u L=2u AS=1.8p PS=5.8u AD=1.8p PD=5.8u 

MMN1 vm1 in1 vn1 0 NMOS W=2u L=2u AS=1.8p PS=5.8u AD=1.8p PD=5.8u 

MMN2 out in2 vn1 0 NMOS W=2u L=2u AS=1.8p PS=5.8u AD=1.8p PD=5.8u 

MMN3 vn1 vbias Gnd 0 NMOS W=2u L=3u AS=1.8p PS=5.8u AD=1.8p PD=5.8u 

.ends 

... 

*-------- Devices: SPICE.ORDER == 0 -------- 

XX1 in1 in2 vf1 vbias Gnd Vdd TransAmp 

MMP1 Out vf1 Vdd Vdd PMOS W=6u L=2u AS=5.4p PS=13.8u AD=5.4p PD=13.8u 

CComp vf1 Out 200f 

MMN1 Out vbias Gnd 0 NMOS W=3u L=2u AS=2.7p PS=7.8u AD=2.7p PD=7.8u 

.ends 

 

********* Simulation Settings - Parameters and SPICE Options ********* 

 

.param Vpwr = 3.3v 

*-------- Devices: SPICE.ORDER == 0 -------- 

VVdd Vdd Gnd DC Vpwr 

VVdiff in2 in1 DC 0 AC 1 90 

VVcm in1 Gnd DC Vpwr/2 

VVbias vbias Gnd DC 700m 

CCout Out Gnd 200f 

XX1 Out in1 in2 vbias Gnd Vdd OpAmp 

 

*-------- Devices: SPICE.ORDER > 0 -------- 

 

.PRINT AC Vdb(Out) 

.PRINT AC Vp(Out) 

.PRINT NOISE INOISE 

.PRINT NOISE ONOISE 

.PRINT NOISE TRANSFER dn(XX1.XX1.MMN3) 

.MEASURE NOISE InputNoise<nv/Hz^0.5> FIND 'inoise/1E-9' WHEN Vdb(Out)=0 ON 

.MEASURE AC UnityGainBandwidth<Hz> WHEN Vdb(Out)=0 ON 

.MEASURE AC MeasureGainBandwidthProduct_1_Gain MAX vdb(Out) OFF 
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.MEASURE AC MeasureGainBandwidthProduct_1_UGFreq WHEN Vdb(Out)=0 OFF 

.MEASURE AC GainBandwidth<Hz> 

PARAM='MeasureGainBandwidthProduct_1_Gain*MeasureGainBandwidthProduct_1_U 

GFreq' ON 

.MEASURE AC Gain<db> MAX vdb(Out) ON 

.MEASURE AC PhaseMargin<deg> FIND '90+vp(Out)' WHEN vdb(Out)=0 ON 

 

********* Simulation Settings - Analysis section ********* 

.op 

.ac dec 10 1 100Meg 

.noise v(Out) VVdiff 5 

 

Three voltage sources (in addition to Vdd) are defined. 

 
􀂃 Vdiff sets the DC voltage difference between nodes IN2 and IN1 to 0 volts; the AC magnitude 

is 1 volt and its AC phase is 90 degrees. 

 
􀂃 Vcm sets node IN1 to 2 volts, relative to GND. 

 
􀂃 Vbias sets node vbias to 700 mille volts, relative to GND. 

 

The .ac command performs an AC analysis. Following the .ac keyword is information 

concerning the frequencies to be swept during the analysis. In this case, the frequency is swept 

logarithmically, by decades (DEC); 10 data points are to be included per decade; the starting 

frequency is 1 Hz and the ending frequency is 100 MHz. 

 

The .PRINT command writes the voltage magnitude (in decibels) and phase (in degrees), 

respectively, for the node OUT to the specified file.  

 

 

Output 
 

The AC simulation will result in AC small-signal model parameters being written to the output 

file, in addition to all output generated from the .print statements. 
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CHAPTER 6: USING SUB-CIRCUITS  

Subcircuit definitions allow arbitrarily complex arrangements of nodes and devices to be easily 

reused multiple times in a circuit. A subcircuit definition in DxDesigner is contained within a 

cell definition, and is comprised of both a schematic view and a symbol view. Each instance of 

the symbol encapsulates the subcircuit schematic, allowing a simple but complete representation 

of subcircuit dynamics. 

This example  uses a NAND gate to illustrate the use of subcircuit definitions and subcircuit 

parameters. 

 

 

Schematic 

 

 
 

An instance of the subcircuit NAND is created in the schematic and labeled X1. (To access 

NAND from the main schematic, double-click on the NAND item in the Libraries list. ) 

 

As discussed in chapter 2, symbol properties are used to define component properties such as 

length and width. This example introduces a new symbol property, SPICE.PARAMETER, which 

allows parameters to be passed through a hierarchical netlist. 

 

The symbol that represents NAND has the SPICE parameter property L=NW=PW= which 

specifies that the cell properties L, NW, and PW are subcircuit parameters of NAND. The cell 

also contains the three property definitions L = 0.5u, NW = 4.0u, and PW = 8.0u. 

These parameters define properties of all n-channel and p-channel MOSFETS within the 

subcircuit such that L represents the length property of both n- and p-channel MOSFETS, NW 

represents n-channel width and PW represents p-channel width. 

 

Attaching these parameters to NAND allows component properties within the subcircuit 

definition to be controlled in the subcircuit call. 
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T-Spice Input 
 

********* Simulation Settings - General section ********* 

.option search="...\Tanner EDA\Tanner Tools v12.6\Libraries\Models" 

.probe 

.option probev 

.option probei 

.lib "Generic_025.lib" TT 

*-------- Devices: SPICE.ORDER < 0 -------- 

* Design: AnalysisExamples / Cell: Subcircuit_TestBench / View: Main / Page: 

* Designed by: Tanner EDA Library Development Team 

* Organization: Tanner EDA - Tanner Research, Inc. 

* Info: Testbench for subcircuit example 

* Date: 7/13/2007 7:59:21 AM 

* Revision: 19 

 

*************** Subcircuits ***************** 

 

.subckt NAND A B Out Gnd Vdd L=500n NW=4u PW=8u 

*-------- Devices: SPICE.ORDER < 0 -------- 

* Design: AnalysisExamples / Cell: NAND / View: Main / Page: 

* Designed by: Tanner EDA Library Development Team 

* Organization: Tanner EDA - Tanner Research, Inc. 

* Info: 2 input NAND gate 

* Date: 7/13/2007 7:59:21 AM 

* Revision: 95 

 

*-------- Devices: SPICE.ORDER == 0 -------- 

 

MP1 Out A Vdd Vdd PMOS W=PW L=L M=2 AS='if(0, 

(900n*PW+floor(2/2)*1.25u*PW), 

(2*900n*PW+(floor(2/2)-1)*1.25u*PW))' PS='if(0, (2*900n+PW+PW*1+floor(2/ 

2)*2*(1.25u+PW*1)), (2*2*900n+PW+PW*1+(floor(2/2)-1)*2*(1.25u+PW*1)))' 

AD='if(0, (900n*PW+floor(2/2)*1.25u*PW), floor(2/2)*1.25u*PW)' PD='if(0, 

(2*900n+PW+PW*1+floor(2/2)*2*(1.25u+PW*1)), floor(2/2)*2*(1.25u+PW*1))' 

MP2 Out B Vdd Vdd PMOS W=PW L=L M=2 AS='if(0, 

(900n*PW+floor(2/2)*1.25u*PW), 

(2*900n*PW+(floor(2/2)-1)*1.25u*PW))' PS='if(0, (2*900n+PW+PW*1+floor(2/ 

2)*2*(1.25u+PW*1)), (2*2*900n+PW+PW*1+(floor(2/2)-1)*2*(1.25u+PW*1)))' 

AD='if(0, (900n*PW+floor(2/2)*1.25u*PW), floor(2/2)*1.25u*PW)' PD='if(0, 

(2*900n+PW+PW*1+floor(2/2)*2*(1.25u+PW*1)), floor(2/2)*2*(1.25u+PW*1))' 

MN1 Out A 1 0 NMOS W=NW L=L AS='if(1, (900n*NW+floor(1/2)*1.25u*NW), 

(2*900n*NW+(floor(1/2)-1)*1.25u*NW))' PS='if(1, (2*900n+NW+NW*1+floor(1/ 

2)*2*(1.25u+NW*1)), (2*2*900n+NW+NW*1+(floor(1/2)-1)*2*(1.25u+NW*1)))' 

AD='if(1, (900n*NW+floor(1/2)*1.25u*NW), floor(1/2)*1.25u*NW)' PD='if(1, 

(2*900n+NW+NW*1+floor(1/2)*2*(1.25u+NW*1)), floor(1/2)*2*(1.25u+NW*1))' 
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MN2 1 B Gnd 0 NMOS W=NW L=L AS='if(1, (900n*NW+floor(1/2)*1.25u*NW), 

(2*900n*NW+(floor(1/2)-1)*1.25u*NW))' PS='if(1, (2*900n+NW+NW*1+floor(1/ 

2)*2*(1.25u+NW*1)), (2*2*900n+NW+NW*1+(floor(1/2)-1)*2*(1.25u+NW*1)))' 

AD='if(1, (900n*NW+floor(1/2)*1.25u*NW), floor(1/2)*1.25u*NW)' PD='if(1, 

(2*900n+NW+NW*1+floor(1/2)*2*(1.25u+NW*1)), floor(1/2)*2*(1.25u+NW*1))' 

.ends 

 

*-------- Devices: SPICE.ORDER == 0 -------- 

 

VVin Vin Gnd PULSE(0 Vpwr 0 1n 1n 49n 100n) 

XX1 Vin N_1 Out Gnd Vdd NAND L=500n NW=4u PW=8u 

VVb N_1 Gnd DC 5 

VVpower Vdd Gnd DC Vpwr 

 

*-------- Devices: SPICE.ORDER > 0 -------- 

 

.PRINT TRAN V(Out) 

.PRINT TRAN V(Vin) 

.PRINT TRAN V(X1/1) 

 

********* Simulation Settings - Analysis section ********* 

 

.tran 250p 300n 

 

********* Simulation Settings - Additional SPICE commands ********* 

 

.end 

 

Subcircuits are defined by blocks of device statements bracketed with the .SUBCKT and .ENDS 

commands, and instanced by statements beginning with the key letter X. 

 

The .SUBCKT command includes the name of the subcircuit being defined (NAND), a list of 

terminals, and three subcircuit parameters. The terminals do not have a predefined order, but 

whatever order is used in the definition must be used in instances. Parameters can be written in 

any order in both the definition and the instances. If a parameter value is not specified in the 

instance the value in the definition is used as the default. 

 

Within the subcircuit definition, four MOSFETs are defined in the usual manner—and in these 

statements the order of terminals is important: drain–gate–source–bulk. Node 1 is the source of 

transistor MN1 and the drain of transistor MN2. Subcircuit parameters, enclosed by single 

quotes, are used in place of numerical values. 

 

After the subcircuit is defined, you can create an instance of the subcircuit. The instance 

statement begins with the key letter X. The name of the instance, by which it is to be identified in 

the rest of the input file, is X1 (not "XX1.") 
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The list of terminals in the instance statement must have the same order as on the first line of the 

subcircuit definition so that A B Out Gnd in the definition corresponds to Vin N_1 OUT Gnd 

in the instance. The next argument of the instance statement is the original subcircuit name 

NAND. 

 

The default subcircuit parameter values, as specified by the definition, are overridden by 

instancespecific value assignments, which can appear in any order. Any parameters omitted from 

the instance statement retains its default value. 

 

A standard DC operating point calculation (.OP) analysis is carried out on this circuit, with a 

duration of 300 nanoseconds and a maximum timestep of 250 picoseconds. The .param 

command sets the initial node voltages to 3.3 volts. The .PRINT command reports simulation 

results for the voltages at nodes 

Vin, OUT, and X1/N_1. 

 

Output 

 



CHAPTER 7: TRANSIENT ANALYSIS—CMOS D-
LATCH 

Transient analysis on a CMOS static D-latch demonstrates the analog D-latch characteristics of a 

digital circuit. The circuit has four inverters and four transmission gates. 

 

 

Schematic 

 

 
 

 

T-Spice Input 
 

********* Simulation Settings - Parameters and SPICE Options ********* 

 

.param Vpwr = 3.3v 

.option NUMDGT = 2 

 

*-------- Devices: SPICE.ORDER == 0 -------- 

 

VVdd Vdd Gnd DC Vpwr 

VVData Data Gnd BIT({1000} PW=16n ON=Vpwr RT=500p FT=500p LT=15.5n 

HT=15.5n) 

VVPhi1 Phi1 Gnd BIT({0011} PW=8n ON=Vpwr RT=500p FT=500p LT=7.5n 

HT=7.5n) 

VVPhi2 Phi2 Gnd BIT({1100} PW=8n ON=Vpwr RT=500p FT=500p LT=7.5n 

HT=7.5n) 

XX1 Q Data Phi1 Phi2 Gnd Vdd DLatch 

 

*-------- Devices: SPICE.ORDER > 0 -------- 

 

.PRINT TRAN V(Q) 
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.PRINT TRAN V(X1/a1) 

.PRINT TRAN V(X1/a3) 

.PRINT TRAN V(X1/a5) 

.PRINT TRAN V(Data) 

.PRINT TRAN V(Phi1) 

.PRINT TRAN V(Phi2) 

 

********* Simulation Settings - Analysis section ********* 

.op 

.tran 75ps 300ns 

 

********* Simulation Settings - Additional SPICE commands ********* 

 

.end 

Voltage source VDD sets the voltage between power and ground to the Vpwr parameter value of 

3.3 volts. 

The next three statements beginning with V define voltage sources for custom input waveforms. 

Following each voltage source name are the names of the input nodes (Data, Phi1, Phi2) and the 

type of waveform. Here, however, not piecewise linear but rather bit waveforms are used.  

 

Following the keyword BIT in parentheses are parameters specifying the waveform 

characteristics. The four-digit sequence in braces { } specifies the sequence of the wave’s states 

(either 1, “on,” or 0, “off”). This sequence will be repeated until the simulation is complete. The 

pulse widths (PW) are 16, 8 and 8 nanoseconds, respectively. The OFF voltage is zero, the ON 

voltage is 3.3 volts, the rise (RT) and fall (FT) times are each 500 picoseconds, and the low time 

(LT) and high time (HT) are both 7.5 nanoseconds. 

 

The .TRAN command instructs T-Spice to perform a 300-nanosecond simulation while printing 

node voltages at least every 75 picoseconds. 

 

The .PRINT commands write simulation results for the voltages at each of seven nodes to the 

specified file. 

 

 

Output 

 
The following chart shows the seven output voltages measured during simulation, plotted across 

time. The chart is expanded and the traces are displayed in the same order in which they were 

loaded. Traces can be loaded or unloaded on a chart using Chart > Options—Format in W-Edit.  

 

Note that when a trace is added to an existing chart, scaling of the axes is not automatically 

updated. To rescale the axes for optimal display, you can use the HOME key. Select Chart > 

Options—Axes to choose appropriate spacing of the major and minor tick marks. 
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CHAPTER 8: COMMAND REFERENCE 

 File Menu 

 

Command      Shortcut 
File > New > Design 
 
File > New > File     Ctrl+N 
 
File > Open > Open Design     Ctrl+O 
 
File > Open > 
Add Library 
Open File 
Execute Script 
 
File > Save > Save Design    Ctrl+S 
 
File > Save > 
Save Design and Its Libraries 
Save Selected Design/Libraries 
Save copy of Selected 
Design/Libraries 
 
File > Close > 
{Design } 
Remove Library 
Close File 
 
File > Import > 
Import EDIF 
Import Spice 
 
File > Export > 
Export EDIF 
Export Spice 
Export Verilog 
Export VHDL 
Export TPR 
 
File > Page Setup 
 
File > Print Preview 
 
File > Print      Ctrl+P 
 
File > Recent Files 
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File > Recent Scripts 
 
File > Exit 

 Edit Menu 

Command      Shortcut 
Edit > Undo      Ctrl+Z, Alt+Back 
 
Edit > Redo      Ctrl+Y 
 
Edit > Cut      Ctrl+X 
 
Edit > Copy      Ctrl+C 
 
Edit > Paste      Ctrl+V 
 
Edit > Clear Del 
 
Edit > Duplicate     Ctrl+D 
 
Edit > Capture Window 
 
Edit > Select All     Ctrl+A 
 
Edit > Deselect All     Alt+A 
 
Edit > Find 
 
Edit > Edit-in-Place > Push Into Page Down 
 
Edit > Edit-in-Place > Pop Out Page Up 
 

 View Menu 

 

Command      Shortcut 
View > Fit Home 
 
View > Exchange     X 
 
View > Goto > Goto Previous 
 
View > Goto > Goto Next 
 
View > Goto > Goto Coordinates 
 
View > Zoom > Mouse Zoom   Z 
 
View > Zoom > Zoom In    + 
 
View > Zoom > Zoom Out    - 
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View > Zoom > Zoom to Selections  W 
 
View > Zoom > Pan to Selections 

Command      Shortcut 
 
View > Pan > Pan Left 
 
View > Pan > Pan Right 
 
View > Pan > Pan Up 
 
View > Pan > Pan Down 
 
View > Pan > Edge 
 
View > Library Navigator 
 
View > Properties 

View > View Navigator 
 
View > Status Bar 
 
View > Command Window 
 
View > Activate Command Window  ‘ 
 
View > Toolbars > 

Standard 
Draw 
Segment 
Electrical 
SPICE Simulation 
Locator 

Mouse Buttons 

 
View > Cell View > Cycle View   ? 
 
View > Objects > 

Visible 
Selectable 
 

View > Display > 
Display Major Grid 
Display Minor Grid 
Display Origin 
Display Evaluated Properties 
 

View > Redraw Space 
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 Draw Menu 

Command      Shortcut 
Draw > Move By 
 
Draw > Force Move     Alt + M 
 
Draw > Rotate     R 
 
Draw > Flip > Flip Horizontal   H 
 
Draw > Flip > Flip Vertical    V 
 
Draw > Select 
 
Draw > Box      B 
 
Draw > Polygon     P 
 
Draw > Path 
 
Draw > Circle 
 
Draw > Text Label 
 
Draw > Electrical > 

Wire 
Solder Point 
Connect/Disconnect 
Net Cap 
Net Label 
In Port 
Out Port 
In/Out Port 
Other Port 
Global Port 
Property 
 

 Cell Menu 

 

Command      Shortcut 
Cell > New View     N 
 
Cell > Open View     O 
 
Cell > Copy View 
 
Cell > Rename View 
 
Cell > Delete View 
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Cell > Page 
New Page 
Delete Page 

Command      Shortcut 
Rename Page 
Previous Page 
Next Page 
Open Page 
Cell > Copy Cell 
Cell > Rename Cell 
Cell > Redirect Instances 
Cell > Generate Symbol 
Cell > Instance I 

 

 

 Setup Menu 

 

Command      Shortcut 
Setup > Technology 
 
Page > Preferences 
 
Page > SPICE Simulation 

 

 Tools Menu 

 

Command      Shortcut 
Tools > Design Checks 
 
Tools > Highlight Net 
 
Tools > Start Simulation 
 
Tools > T-Spice 
 
Tools > Probe    V 
 
Tools > Probe    I 
 
Tools > Probe    Q 
 
Tools > User > (User 1...10) 

 

 Window Menu 

Command      Shortcut 
Window > Dockable 
 
Window > Auto Hide 
 
Window > Hide 
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Window > Floating 
Window > Close 
 
Window > Cascade 
 
Window > New Window 
 
Window > Tile 
 
Window > Arrange Icons 
 
Window > Close All Except Active 
 
Window > Theme 
 
Window > (recently opened files) 
 

 

 Help Menu 

 

Command       Shortcut 
Help > Schematic Editor Manual 
 
Help > Release Notes 
 
Help > Tutorial 
 
Help > S-Edit Examples Guide 
 
Help > Setup Examples and Tutorial 
 
Help > Commuter Licenses 
 
Help > Support 
 
Help > About S-Edit 



 

CHAPTER 9: EXPERIMENTS USING T-SPICE  

In this chapter some experiments related with university syllabus are described. These 

experiments will describe how to write a laboratory copy and how experiments will be 

performed. 

 

The three experiments are described as they belong to syllabus. These are 

1. Experiment No. 1: To design and implementation of a two input NAND gate     

using TSPICE. 

2. Experiment No. 2: To design and implementation of a two input NOR gate using 

TSPICE. 

3. Experiment No. 3: To design and implementation of a two input XOR gate using 

TSPICE. 
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EXPERIMENT NUMBER: -                                              Date:- 

 

Design & Implementation of CMOS NAND gate using 
T-SPICE 

 

 
OBJECTIVE:-  

 
To design and implementation of a two input NAND gate using TSPICE and analyze the 

Transient characteristics of output waveform. 

 

 
THEORY: 

 
If we take Va as 1st input of the NAND gate, & Vb as 2nd input of the NAND gate then output 

can be expressed as- 

                  Vout = (Va.Vb)’. 

Which may also be expressed as- Vout = (Va.Vb)’ = Va’+Vb’. 

It must be noted as the output of this circuit is just the opposite of AND gate (initially observed).  

 

 

Truth table: 

 

       Va       Vb      Va.Vb    (Va.Vb)’ 

        0         0        0          1 

        0         1        0          1 

        1         0        0          1 

        1         1        1          0 

 
 

Boolean Expression:  

 

                           Vout = (Va.Vb)’ = Va’ + Vb’. 
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SCHEMATIC DIAGRAM OF THE CIRCUIT: 
 

 
 
 
CIRCUIT DESCRIPTION:  

 
In this experiment, we have used CMOS logic design technique.  

Here f = (Va.Vb)’=Va’ +Vb’ 

So, f’ = ((Va.Vb)’)’=Va.Vb 

 Now use f for  pMOS circuit design & use f’ for nMOS circuit design. Where boolean (.) 

indicate series operation and Boolean (+) signifies parallel operation.Based on this, we built the 

given circuit and simulate using TSPICE to observe the output waveform. 

As per the above methodology two pMOS connected in parallel and two nMOS connected in 

series. Collecting output from their common node mentioned as Vout. 

 

We gave two common inputs (Va and Vb) to both the circuit parts. 



VLSI Design Lab                  (EC 792) 
 

Siliguri Institute of Technology | Department: Electronics and Communication Engineering 40 

 

NETLIST: 

 
* SPICE netlist written by S-Edit Win32 Demo 9.12 

* Written on Apr 2, 2009 at 10:45:05 

 

* Waveform probing commands 

 

.probe 

.options probefilename="NAND_GATE.dat" 

+ probesdbfile="G:\ NAND_GATE.sdb" 

+ probetopmodule=" NAND_GATE” 

 

* Main circuit: NAND_GATE 

 

M1 vout vin1 N2 N2 NMOS L=2u W=44u AD=66p PD=24u AS=66p PS=24u 

 M2 N2 vin2 Gnd Gnd NMOS L=2u W=44u AD=66p PD=24u AS=66p PS=24u 

 M3 vout vin1 Vdd Vdd PMOS L=2u W=22u AD=66p PD=24u AS=66p PS=24u 

M4 Vdd vin2 vout Vdd PMOS L=2u W=22u AD=66p PD=24u AS=66p PS=24u 

v5 vin1 Gnd bit ({0100} pw=100n on=5.0 off=0.0 rt=1n ft=1n delay=0 lt=100n ht=100n) 

v6 vin2 Gnd bit ({1111} pw=100n on=5.0 off=0.0 rt=1n ft=1n delay=0 lt=100n ht=100n) 

 

.include "C:\Program Files\Tanner EDA\Demo\T-Spice\models\ml2_125.md" 

vdd vdd gnd 5 

 

.tran 1n 400n 

.print tran v(vin1) v(vin2) v(vout) 
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OUTPUT WAVEFORM: 

 

 
 
 
 
CONCLUSION: 

 
After performing the above experiment we come to know about the operation of a NAND gate 

using T-SPICE .here we have performed the operation of a 2 input NAND gate which is 

basically a multiplication operation between two inputs. We have done dc & transient operation 

of the NAND gate. In the dc operation there is lots of noise interference in the output waveform 

which are eliminated in the transient operation by using source voltage bit instead of a dc input. 

As a result we got an output waveform as shown above. 
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 EXPERIMENT NUMBER: -                                          Date:- 

Design & Implementation of CMOS Nor gate using 

T-SPICE 

 

OBJECTIVE:-  

To design and implementation of a two input NOR gate using TSPICE and analyze the Transient 

characteristics of output waveform. 

 

THEORY: 

If we take Va as 1st input of the NOR gate, & Vb as 2nd input of the NOR gate then output can be 

expressed as- 

                  Vout = (Va+Vb)’. 

Which may also be expressed as- Vout = (Va+Vb)’ = Va’.Vb’. 

It must be noted as the output of this circuit is just the opposite of OR gate (initially observed).  

 

Truth table: 

Input = A Input = B Output = Y 

0 0 1 

0 1 0 

1 0 0 

1 1 0 

 

BOOLEAN EXPRESSION : 

The Boolean Expression of the circuit is : 

F = (A+B) ‘ = (A’.B’). 
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F’ = ( (A+B)’)’= A+B. 

 

CIRCUIT DIAGRAM: 

The circuit diagram for the same is shown as  

 

 

CIRCUIT ANALYSIS: 

The above circuit consists of two PMOS in series and two NMOS in parallel. When both the 

input is low we get the Vdd as the Vout. But when any of the or both the input is high then the 

route for the current is blocked by one or both of the PMOS. But at that time the current finds 
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alternate path from the ground as one or both of the NMOS is ON and they are in parallel. Hence 

we get output as low.  

 

NETLIST: 

* Written on Mar 26, 2009 at 09:58:50 

* Waveform probing commands 

.probe 

.options probefilename="NOR1.dat" 

+ probesdbfile="D:\NOR1.sdb" 

+ probetopmodule="NOR" 

 

* Main circuit: NOR 

M1 Vout vin2 Gnd Gnd NMOS L=2u W=22u AD=66p PD=24u AS=66p PS=24u  

M2 Vout vin1 Gnd Gnd NMOS L=2u W=22u AD=66p PD=24u AS=66p PS=24u  

M3 N3 vin1 Vdd Vdd PMOS L=2u W=22u AD=66p PD=24u AS=66p PS=24u 

M4 Vout vin2 N3 Vdd PMOS L=2u W=22u AD=66p PD=24u AS=66p PS=24u 

v5 vin2 Gnd bit({10011} pw=100n on=5.0 off=0.0 rt=10n ft=10n delay=0 lt=10n ht=10n) 

v6 vin1 Gnd bit({10011} pw=100n on=5.0 off=0.0 rt=10n ft=10n delay=0 lt=10n ht=10n) 

.include "C:\Program Files\Tanner EDA\Demo\T-Spice\models\ml2_20.md" 

vdd vdd gnd 5 

.tran 1n 400n 

.print v(vin1) v(vin2) v(vout) 
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OUTPUT WAVEFORM: 

 

 

   

 

CONCLUSION: 

The analysis of NOR gate using CMOS is done in T-SPICE. The circuit is combination of 

NMOS and PMOS.  Output was high when both the input is Low. The output came as Low when 

one or both of the input was high. The graph is obtained from the circuit gives the characteristics 

of the NOR gate. But there is some delay due to the presence of rise time and fall time.  
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EXPERIMENT NUMBER:-                                                 Date:- 

 

 
Design & Implementation of XOR  gate using  

T-SPICE 
 

 
OBJECTIVE:-  

 
To design and implementation of a two input XOR gate using TSPICE and analyze the Transient 

characteristics of output waveform. 

 

 

THEORY: 
 

If we take Va as 1st input of the NAND gate, & Vb as 2nd input of the XOR gate then output can 

be expressed as- 

                  Vout = (Va.Vb’+Vb.Va’); 

 

 

Truth table: 

 

Input = A Input = B Output = Y 

0 0 0 

0 1 1 

1 0 1 

1 1 0 

 

 

 

Boolean Expression:  

 

                           Vout = (Va.Vb’ + Vb.Va’) 
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SCHEMATIC DIAGRAM  OF THE CIRCUIT: 

 

 

 

CIRCUIT DESCRIPTION:  
 

In this experiment, we have used CMOS logic design technique.  

Here f = (Va.Vb’+ Vb.Va’) 

 So, f’ = (Va.Vb’+ Vb.Va’)’ = (Va+Vb’) * (Va’+Vb); 

 Now use f for pMOS circuit design & use f’ for nMOS circuit design. Where boolean (.) 

indicate series operation and Boolean (+) signifies parallel operation.Based on this, we built the 

given circuit and simulate using TSPICE to observe the output waveform. 

As per the above methodology two pMOS connected in parallel and two nMOS connected in 

series. Collecting output from their common node mentioned as Vout. 

 

 

NETLIST: 
 

* Waveform probing commands 

.probe 
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.options probefilename=" XOR.dat" 

+ probesdbfile="D:\XOR.sdb" 

+ probetopmodule="XOR" 

 

* Main circuit: Anirban_XOR 

.include "C:\Program Files\Tanner EDA\Demo\T-Spice\models\ml2_typ.md" 

M1 N4 Vb Vout N4 NMOS L=2u W=22u AD=66p PD=24u AS=66p PS=24u  

M2 Vout Vabar N4 N4 NMOS L=2u W=22u AD=66p PD=24u AS=66p PS=24u  

M3 N4 Va Gnd Gnd NMOS L=2u W=22u AD=66p PD=24u AS=66p PS=24u  

M4 Gnd Vbbar N4 Gnd NMOS L=2u W=22u AD=66p PD=24u AS=66p PS=24u  

M5 Vabar Va Gnd Gnd NMOS L=2u W=22u AD=66p PD=24u AS=66p PS=24u  

M6 Gnd Vb Vbbar Gnd NMOS L=2u W=22u AD=66p PD=24u AS=66p PS=24u  

M7 N3 Vabar Vdd Vdd PMOS L=2u W=22u AD=66p PD=24u AS=66p PS=24u 

M8 Vdd Va N1 Vdd PMOS L=2u W=22u AD=66p PD=24u AS=66p PS=24u 

M9 Vout Vb N3 Vdd PMOS L=2u W=22u AD=66p PD=24u AS=66p PS=24u 

M10 N1 Vbbar Vout Vdd PMOS L=2u W=22u AD=66p PD=24u AS=66p PS=24u 

M11 Vabar Va Vdd Vdd PMOS L=2u W=22u AD=66p PD=24u AS=66p PS=24u 

M12 Vdd Vb Vbbar Vdd PMOS L=2u W=22u AD=66p PD=24u AS=66p PS=24u 

v13 Va Gnd bit({0011} pw=100n on=5.0 off=0.0 rt=0n ft=0n delay=0 lt=100n ht=100n) 

v14 Vb Gnd bit({0101} pw=100n on=5.0 off=0.0 rt=0n ft=0n delay=0 lt=100n ht=100n) 

Vdd Vdd gnd 5v 

.tran 1n 400n 

.print tran V(Va) V(Vb) V(Vout) 

 

OUTPUT WAVEFORM: 
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CONCLUSION: 
 

After performing the above experiment we come to know about the operation of a XOR gate 

using T-SPICE. Here we have performed the operation of a 2 input XOR gate which is basically 

a multiplication operation between two inputs. We have done dc & transient operation of the 

XOR gate. In the dc operation there is lots of noise interference in the output waveform which 

are eliminated in the transient operation by using source voltage bit instead of a dc input. As a 

result we got a output waveform as shown above. 
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CHAPTER 10: SOFTWARE FAMILIARIZATION 

Study of Simulation Tools 

 
Simulation is functional emulation of the circuit design through software programs that uses 

models to replicate how a system will perform in terms of timings and results. 

 

Xilinx ISE tool supports the following simulation tools:  

•HDL Bencher is an automated test bench creation tool. It is fully integrated with Project 

Navigator.  

 
Simulation using Xilinx HDL Bencher: 

1. Start the Xilinx Project Navigator by using the desktop shortcut or by using the Start     

Programs         Xilinx ISE. 

 

 
 

 

2. Create a new project. 

Select File menu and then select New project. 

 

Source 

window 

Process 

window 

Work space 

Transcript 
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Specify the project name and location in pop up window and click   NEXT. 

Select Device. Select the required family, device, package, speed grade, Synthesis tool 

Simulator from new project wizard pop up window. 

Click NEXT. Project summary will be displayed. 
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Click FINISH to start Project. 

 

3. To create new VHD file Right click on the device name and select NEW SOURCE. 
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Select VHDL MODULE in NEW SOURCE WIZARD and give suitable name for 

theProject. Click NEXT for the DEFINE MODULE Window. 

 

 
 

Assign required ports in this Window. The direction 
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4. Write the Behavioural VHDL Code in VHDL Editor 

Sample code is given below for this experiment. 

 

 
 

5. SIMULATION using ISE tool 

Creating a test bench file 

Verify the operation of your design before you implement it as hardware. Simulation can 

be done using ISE simulator. For this click on the symbol of FPGA device and then right 

click       Click on new source      Test Bench Waveform and give the name     Select 

entity      Finish. 
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The window to Select Clock, Duty Cycle will appear. Select required parameters and say 

FINISH 
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6. BEHAVIOURAL SIMULATION 

Select Behavioral Simulation from the scroll down list. 

 

 
 

7. Give wave pattern on the input signals as required. Then double click on Simulate 

Behavioral Model for simulating. 
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The wave form according to the inputs given will appear in the window. The wave 

formcan be analyzed for the correctness of functionality. 

 

 



CHAPTER 11: EXPERIMENTS USING Xilinx 
Software 

 
In this chapter some experiments related with university syllabus are described. These 

experiments will describe how to write a laboratory copy and how experiments will be 

performed. 

 

The three experiments are described as they belong to syllabus. These are 

1. Experiment No. 5: Design & Implementation of CMOS Full adder Circuit using 

VHDL  

2. Experiment No. 6: Design of CMOS D Flip flop using VHDL  

3. Experiment No. 7: Design of n bit synchronous Counter using VHDL  

4. Experiment No. 8: Design of shift register using VHDL. 
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    EXPERIMENT NUMBER:-                                                   Date:- 

 

 

Design & Implementation of Full Adder 
Circuit Using VHDL 

 
 

 
OBJECTIVE:- 
 

 Design and implementation of a Full Adder using VHDL with the help of Xilinx ISE. 

 

 

THEORY:- 
 

Full adder is the arithmetic circuit which adds two single bit input considering carry and 

produces sum bit and carry bit. Sum is obtained by XOR operation of the two inputs and the 

input carry. Considering the inputs as input1 & input2 and input carry as cin of Full Adder 

Circuit, and then sum can be expressed as- 

 

    sum = input1 XOR input2 XOR cin 

           = input1     input2     cin; 

 

And the output carry can be expressed as- 

 

carry = input1 AND input2 OR input1 AND  cin OR  input2 AND cin 

            = input1.input2 + input1.cin + input2.cin; 

 

 

Truth table: 
 

Cin=c Input1=a Input2=b Sum Carry=cout 

0 0 0 0 0 

0 0 1 1 0 

0 1 0 1 0 

0 1 1 0 1 

1 0 0 1 0 

1 0 1 0 1 

1 1 0 0 1 

1 1 1 1 1 
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Boolean Expression:- 

 

   sum = input1 XOR input2 XOR cin 

           = input1     input2     cin; 

 

    carry = input1 AND input2 OR input1 AND  cin OR  input2 AND cin 

             = input1.input2 + input1.cin + input2.cin; 

 

 

SCHEMATIC DIAGRAM OF THE CIRCUIT:- 

 

 

 
 

 
 

VHDL PROGRAM:- 
 

library IEEE; 

use IEEE.STD_LOGIC_1164.ALL; 

use IEEE.STD_LOGIC_ARITH.ALL; 

use IEEE.STD_LOGIC_UNSIGNED.ALL; 

 

entity fulladder is 

Port ( a : in std_logic; 

b : in std_logic; 

c : in std_logic; 



VLSI Design Lab                  (EC 792) 
 

Siliguri Institute of Technology | Department: Electronics and Communication Engineering 57 

 

sum : out std_logic; 

cout : out std_logic); 

end fulladder; 

 

architecture Behavioral of fulladder is 

signal s:std_logic_vector(5 downto 0); 

begin 

s(0)<=a xor b; 

s(1)<=s(0)xor c; 

s(2)<=a and b; 

s(3)<=b and c; 

s(4)<=c and a; 

s(5)<=s(2) or s(3) or s(4); 

sum<=s(1): 

cout<=s(5); 

end Behavioral; 

 

 

OUTPUT WAVEFORM:- 
 

 
 

CONCLUSION:- 
 

Full adder is the logic circuit which adds two logic input considering an input carry. The sum is 

as same as XOR of three inputs. And the output carry is AND of two inputs at time and OR of 

those. We have used VHDL language. Here we have used Behavioral modeling to build the 

program in Xilinx ISE. 
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EXPERIMENT NUMBER: -                                          Date:- 

 

REALIZATION OF D FLIPS FLOP USING XILINX SOFTWARE. 

 

 

OBJECTIVE:-  

 
Study & Realization of D flip flop. 

 

 

THEORY: 

 
The edge triggered D flip flop has only one i/p terminal. The D flip flop has only one 

synchronous control i/p in addition to the clk.This is known as D input. There are two types of D 

flip flop.  

 

              1.'+ve'edge triggered D flip flop. 

              2.'-ve'edge triggered D flip flop. 

 

Incase of '+ve' edge triggered D flip flop the o/p Q will go to the state that is present on the D i/p 

at the '+ve'going transition of the clk pluse.  

In case of '+ve' edge triggered D flip flop operates in the same way as '+ve' edge triggered D flip 

flop except that the change of state takes place at the '-ve' going edge of the clk pluse. 

 

CIRCUIT DIAGRAM:  
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TRUTH TABLE: 
 

           D          CLK       Q        QBAR COMMENTS 

           0         ‘+VE’       0      1 RESET 

           1         ‘+VE’       1        0 SET 

 

 

 

PROGRAM: 
 

library IEEE; 

use IEEE.STD_LOGIC_1164.ALL; 

use IEEE.STD_LOGIC_ARITH.ALL; 

use IEEE.STD_LOGIC_UNSIGNED.ALL; 

 

---- Uncomment the following library declaration if instantiating 

---- any Xilinx primitives in this code. 

--library UNISIM; 

--use UNISIM.VComponents.all; 

 

entity d_flip is 

    Port ( D : in std_logic; 

           clk : in std_logic; 

           rst : in std_logic; 

           Q : out std_logic; 

           QBAR : out std_logic); 

end d_flip; 

architecture Behavioral of d_flip is 

 signal state : std_logic; 

begin 

process(rst,clk,D) 

begin 

if(rst='0')then state<='0'; 

elsif(clk='1'and clk'event)then state<=D; 

end if; 

end process; 

Q<=state; 

QBAR<=not state; 

end Behavioral; 
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WAVEFORMS: 
 

         
CONCLUSIOS: 

 

From above waveforms we observed that experimental result perfectly matched  with TRUTH 

TABLE. 
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EXPERIMENT NUMBER:-                                             Date:- 

To design and implement up/down counter using 

VHDL. 

 

OBJECTIVE: 

 i) Design of up/down counter using VHDL. 

II) View and analyse the generated circuit. 

 

THEORY: 

In digital logic and computing, a counter is a device which stores (and sometimes displays) 

the number of times a particular event or process has occurred, often in relationship to a clock 

signal. In practice, there are two types of counters: 

 Up counters, which increase (increment) in value. 

 Down counters, which decrease (decrement) in value. 

The simplest counters use toggle flip-flops. These are made from D flip-flops as shown fig.1. 

This is why many circuits of counter’s show an XOR gate and an AND gate for each flip-

flop.                                                                                   

 

 

1. UP COUNTER: 

 

CIRCUIT DIAGRAM: 

 

 

http://en.wikipedia.org/wiki/Computing
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fig.1. Technology Schematic. 

 

 

VHDL CODE: 
 

library IEEE; 

use IEEE.STD_LOGIC_1164.ALL; 

use IEEE.STD_LOGIC_ARITH.ALL; 

use IEEE.STD_LOGIC_UNSIGNED.ALL; 

 

entity upcounter is 

    Port ( rst : in std_logic; 

           clk : in std_logic; 

           state : out std_logic_vector(3 downto 0)); 

end upcounter; 

 

architecture Behavioral of upcounter is 

signal seg:std_logic_vector(3 downto 0); 

begin 

process(rst,clk) 

begin 

if rst='0' then seg<="0000"; 

elsif clk='1' and clk'event then 

seg<=seg+1; 

end if; 

end process; 

state<=seg; 

end Behavioral; 

 

 

SIMULATION WAVEFORM: 
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2. DOWN COUNTER: 

 

CIRCUIT DIAGRAM: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

fig.2. Technology schematic 

 

VHDL CODE: 

 

library IEEE; 

use IEEE.STD_LOGIC_1164.ALL; 
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use IEEE.STD_LOGIC_ARITH.ALL; 

use IEEE.STD_LOGIC_UNSIGNED.ALL; 

 

entity downcounter is 

    Port ( rst : in std_logic; 

           clk : in std_logic; 

           state : out std_logic_vector(3 downto 0)); 

end downcounter; 

 

architecture Behavioral of downcounter is 

 signal seg:std_logic_vector(3 downto 0); 

begin 

process(clk,rst) 

begin 

if rst='0' then seg<="1111"; 

elsif clk='1' and clk'event then 

seg<=seg-1; 

end if; 

end process; 

state<=seg; 

end Behavioral; 

 

 

SIMULATION WAVEFORM: 
 

 

 

CONCLUSION: 
 

Up and Down counter is a asynchronous counter .And here counting sequence in continuous 

sequential in nature. So there is no overlapping in between in consecutive count in 4- bit. Due 

to predefined less precedence delay in the VHDL simulator, it actually causes no problems. 

But ,in the more higher bit counter’s ,  it may causes ambiguities like overlapping. Some 

counting sequence, and it is more effectively shown in the N-bit counter. From the synthesis 

report we can visualise about ckt’s latency, clk duration, power consumtion, total delay of 

signal  to pass through the whole ckt.   



VLSI Design Lab   (EC 792) 
 

Siliguri Institute of Technology | Department: Electronics and Communication Engineering 65 

 

EXPERIMENT NUMBER: -                                           Date:- 

 

 

Designing and implementation of Shift register. 
 

 
Objective: 

 
To design and implement shift registers (right, left, rotate right, rotate left)  

 

Theory: 
Shift registers are a type of sequential logic circuit, mainly for storage of digital data. They are a 

group of flip-flops connected in a chain so that the output from one flip-flop becomes the input 

of the next flip-flop. Most of the registers possess no characteristic internal sequence of states. 

All flip-flops are driven by a common clock, and all are set or reset simultaneously. They are 

used basically to storage and transform of digital data. 

  

Data may be shifted in or out of the register either in serial form or in parallel form. So 

there are four basic types of shift registers: serial in, serial out; serial in parallel out;

 parallel, in serial out; parallel in, parallel out. 

  

 Here in right shift data are shifted left to right and in left shift data are shifted right to left. 

In case of rotate shift register data are rotated either left to right or right to left. 
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Schematic Diagram & Circuit: 
 

(a) Right Shift Register: 

 

 
 

(b) Left Shift Register: 

 

 
 

 

 

 



VLSI Design Lab   (EC 792) 
 

Siliguri Institute of Technology | Department: Electronics and Communication Engineering 67 

 

Program: 
 

(a) Right Shift Register: 

library IEEE; 

use IEEE.STD_LOGIC_1164.ALL; 

use IEEE.STD_LOGIC_ARITH.ALL; 

use IEEE.STD_LOGIC_UNSIGNED.ALL; 

 

---- Uncomment the following library declaration if instantiating 

---- any Xilinx primitives in this code. 

--library UNISIM; 

--use UNISIM.VComponents.all; 

 

entityrightshift is 

    Port ( d : in std_logic; 

rst : in std_logic; 

clk : in std_logic; 

q : out std_logic_vector(7 downto 0)); 

endrightshift; 

 

architecture Behavioral of rightshift is 

signalstate:std_logic_vector(7 downto 0); 

begin 

 process(rst,clk,d) 

begin 

 if(rst='0')then  

 state<= "10011101"; 

 elsif (clk='1' and clk' event) then 

 state<=d & state(7 downto 1); 

 end if; 

 end process; 

 q<=state; 

 end  Behavioral; 

 

 

(b) Left Shift Register: 

library IEEE; 

use IEEE.STD_LOGIC_1164.ALL; 

use IEEE.STD_LOGIC_ARITH.ALL; 

use IEEE.STD_LOGIC_UNSIGNED.ALL; 

 

---- Uncomment the following library declaration if instantiating 

---- any Xilinx primitives in this code. 

--library UNISIM; 

--use UNISIM.VComponents.all; 
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entityrightshift is 

    Port ( d : in std_logic; 

rst : in std_logic; 

clk : in std_logic; 

q : out std_logic_vector(7 downto 0)); 

endrightshift; 

 

architecture Behavioral of rightshift is 

signalstate:std_logic_vector(7 downto 0); 

begin 

 process(rst,clk,d) 

begin 

 if(rst='0')then  

 state<= "10011101"; 

 elsif (clk='1' and clk' event) then 

 state<= state(6 downto 1) & d; 

 end if; 

 end process; 

 q<=state; 

 end  Behavioral; 

 

 

 

Waveform: 

 
(a) Right Shift Register: 
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(b)Left Shift Register: 

 

 
 

 
Conclusion: 
 

  Shift register is a very important building block. It has innumerable applications. 

So it is very important to know how to design it and implement a shift register. Here we have 

used Xlinix software to implement this circuit. This is a software part of the circuit which is later 

implemented on the hardware kit. In this way we can design a shift register. 



CHAPTER 12: IMPLEMENTATION OF 2:4 

DECODER USING XILINX ISE TOOL 

Introduction:- 
Discrete quantities of information are represented in digital systems with binary codes. Abinary 

code of n bits is capable of representing up to 2n distinct elements of the codedinformation. A 

Decoder is a combinational circuit that converts binary information from ninput lines to a 

maximum of 2n unique output lines. Decoder is similar to a Demultiplexerexcept that there is no 

data input. The only inputs are the control inputs A and B. 

 

In this chapter, the implementation of a 2:4 Decoder using Xilinx ISE Toolwill be described. 

 

 Write the functionality in the Xilinx project navigator. 

 

 Run a functional HDL simulation. 

 

 Synthesize your design with XST. 

 

 Take the synthesized design through the Xilinx implementation tools. 

 

 Download the bit stream file. 

 

 Check the performance of your design by applying binary inputs and verify the outputs. 

 

 

Objectives:- 
After completing this lab, student will be able to design the Decoder and validate it using 

CPLD/FPGAbased trainer kit. 

 

 

Design Description:- 

The Truth Table of 2:4 decoders is as below. 

 

Control Lines Output Lines 

A B Y0 Y1 Y2 Y3 

0 0 1 0 0 0 

0 1 0 1 0 0 

1 0 0 0 1 0 

1 1 0 0 0 1 
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The Block Diagram of 2:4 Decoderis as shown below. 

 

 

Steps to implement the 2:4 Decoder  

 
Step 1: Start the Xilinx Project Navigator by using the desktop shortcut or by using the 

Start       Programs     Xilinx ISE     Project Navigator 

Step 2: In the Project Navigator window go to FILE       New project         Select Device. 

 

Step 3: Click on the symbol of FPGA device and then right click       Click on new source 
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VHDL module and give the name Decoder_2_4       Define ports       Finish. 

 

Step 4: Generate the Behavioral VHDL Code for the Decoder_2_4. 

 

Step 5: Check syntax, and remove errors if present. 

 

Step 6: Simulate the design using Xilinx. 

 

Highlight decode2_4_tb.vhd file in the Sources in Project window. To run the Functional 

Simulation, Click on the symbol of FPGA device and then right click    Click on new source 

Click on test bench waveform    Give file name    Select entity       Finish      Give inputs. Click 

on simulate behavioral model          see the  output. 

 

 

Step 7: Synthesize the design using XST. 

Highlight decode2_4.vhd file in the Sources in Project window. To run thesynthesis, right-click 

on Synthesize, and choose the Run option, or double-click on Synthesize in the Processes for 

Current Source window. Synthesis will run,and a green check will appear next to Synthesize 
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when it is successfullycompleted. A yellow exclamation mark indicates that a warning was 

generated,and a red cross indicates an error was generated. Warnings are OK. 

 

 

If there are any errors, you can view the error through the console window otherwise continue 

on to the next step. 

 

Step 8: Following the procedure described in step 6 generate User Constraint file (ucf) by 

selecting the device in the source window and selecting the Implementation Constraints file. 

Select the corresponding .ucf file and open process window then select “user constraints” and 

then select “assign pakage pin” wherein the CPLD/FPGA package pins are oriented as per the 

hardware. Design object list window will appear. Select the inputs and outputs from the I/O 

bank. The pin configuration is given below in tabular form. In LOC field insert the required 

input/output pin in the format p51, p52… then click on save and OK. To edit the .ucf file click 

on process and then edit the constraints (test) file. The syntax is NET “a” LOC = “p51”, NET 

“b” LOC = “p50”  
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Dedicated Pin for CPLD module (XC9572-15 PC84) 

 

PIN NO FUNCTION 

8, 16, 27, 42, 49, 60 GND 

22, 38, 64,73, 78 5V 

28 TDI 

29 TMS 

30 TCK 

59 TDO 

 

For details interfacing the pin assignment section is referred which is included at the last of this 

manual. 

Step 9: Right-click on Implement Design, and choose the Run option, or double leftclickon 

Implement Design.Right-click on Generate Programming File, and choose the Run option, 

ordouble left-click on Generate Programming File. This will generate the Bitfile for FPGA or 

jed file for CPLD.  

Step 10: Double click on Configure Device. Impact dialog box will appearto download the bit 

stream. For interfacing the target device to parallel port of computer JTAG cable is required. For 

CPLD device the JTAG programmer is activated while programming. Then select cable auto 

connect option from “xxxx” menu. The software will search for JTAG interface and display the 

cable connection establishment. After this user can perform various operations like 

erase/program/verify/ID check/ blank check from the operation menu and proceed accordingly. 

For FPGA device tool will offer three options JTAG/Hardware Debugger/PROM Formatter. For 

downloading the design in FPGA device, user has to select “Hardware Debugger” option and 

then select the cable type Viz. parallel. Once the cable is sensed then download the design by 

using download option. If the device is configured properly the red LED given on the FPGA 

board will glow indicating proper configuration of the device. 

Step 11: Apply input through DIP Switches and output is displayed on LEDs. 
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Experimental Set up:- 

 

 

Conclusion:- 
Design of 2:4 Decoder is implemented in Protoboard and is verified according to the 

truthtable. 

 

TestCodes:- 

 
VHDL Code for 2:4 Decoder:- 

library IEEE; 

use IEEE.STD_LOGIC_1164.ALL; 

use IEEE.STD_LOGIC_ARITH.ALL; 

use IEEE.STD_LOGIC_UNSIGNED.ALL; 

entity Decoder is 

Port ( 

D_in : in std_logic_vector(1 

downto 0); 

D_out : out std_logic_vector(3 

downto 0)); 

end Decoder; 

architecture Behavioral of Decoder is 

begin 

D_out<= "0001" when D_in = "00" 

else 

"0010" when D_in = "01" 

else 

"0100" when D_in = "10" 

else 

“1000”; 

end Behavioral; 
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SILIGURI INSTITUTE OF TECHNOLOGY 
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RF & Microwave Engg LAB – EC 793A       Date: 
Experiment No.:  
1(a) NAME OF THE EXPERIMENT :  

Familiarisation of the X-Band Microwave Test Bench 

OBJECTIVE:  

• To study the overall function of X Band Microwave Test bench and different microwave 

components and sources. 

  

MICROWAVE TEST BENCH 

With the help of a typical X- band microwave test bench we can perform the following 

experiments.  

1. Study of the characteristics of klystron Oscillator and to determine its electronic tuning 

range.  

2. V-I characteristics of Gunn Diode. 

3. Following characteristics of Gunn Diode Oscillator  

(i) Output power and frequency as a function of voltage 

(ii)  Square wave modulation through Pin Diode. 

4. To determine the standing wave ratio (swr) and reflection coefficient.  

5. To measure an unknown impedance with Smith Chart.  

6. Calibration of a variable Attenuator. 

7. To determine the frequency & wavelength in a rectangular waveguide working on TE10 

mode. 

8. Square law behaviours of a microwave crystal detector. 
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9. To study the radiation pattern and determine different parameters of microwave antennas 

e.g., Slotted Broad Wall, Slotted Narrow Wall, Dielectric Antenna, H-Plane Sectorial 

Horn, Pyramidal Horn, Parabolic Dish etc.  

10. Measurements of Dielectric constant of Low-loss solid dielectrics and Liquid dielectrics.  

11. Phase shift measurements by using phase shifter. 

12. Study of E Plane Tee, H Plane Tee and Magic Tee. 

13. Study the function of Multihole Directional coupler by measuring the following 

parameters.  

 

Fig: Gunn based X-band Microwave Test bench (8.2 to 12.4 Ghz) 
 

MICROWAVE COMPONENTS 

Gunn Oscillators  

Gunn Oscillators are solid state microwave energy generators. These consist of waveguide cavity 

flanged on one end and micrometer driven plunger fitted on the other end. A Gunn-diode is 

mounted inside the Wave guide with BNC (F) connector for DC bias. Each Gunn oscillator is 

supplied with calibration certificate giving frequency vs micrometer reading. 
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PIN Modulators   

PIN modulators are designed to modulate the CW output of Gunn Oscillators. It is operated by 

the square pulses derived from the TNC connector of the Gunn power supply. These consist of a 

PIN diode mounted inside a section of Wave guide flanged on its both end. A fixed attenuation 

vane is mounted inside at the input to protect the oscillator.  

 

 

 

 Klystron Mount   

Klystron mounts are used to transmit microwave power from reflex klystron tube to rectangular 

waveguide. Klystron mounts are designed by a section of waveguide, one end of waveguide is 

fitted with a movable short plunger. A small hole on the broad wall of waveguide is provided 

through which coupling pin of reflex klystron tube enters into the waveguide. By moving 

plunger (matching the impedance of klystron tube and waveguide) maximum output can be 

achieved. 
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Isolators  

 The ferrites isolators and circulators are matched 2 port and 3 port devices respectively, which 

offer low insertion loss and high isolation over 1GHz band width. An isolator is a 2 port device 

which allows signals from port 1 to port 2 & provides maximum attenuation for transmission 

from port 2 to 1. A circulator is a three port device which has a peculiar property of coupling 

power to the adjacent port clockwise. 

 

Fixed Attenuators  
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Attenuators are required to adjust power or attenuate the power flowing in waveguide. There are 

two types of attenuators fixed and variable. Fixed attenuators are available in various range like 

3dB, 6dB, 10 dB etc. These attenuators are calibrated at center frequency of respective frequency 

band. By Variable attenuators power can be adjusted for different level. 

 

 

Variable Attenuator (10 Db/20 Db) 

 

 

Direct Reading Frequency Meter  
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Direct Reading frequency meters are used to measure the microwave frequency accurately. 

There long scale length and numbered calibration marks provide high resolution which is 

particularly useful when measuring frequency difference of small frequency changes. 

 

Slotted Section  

Slotted section is used to measure various measuring parameter in microwave, for example to 

determine standing wave pattern, VSWR, phase and impedances. These consist of a slot in center 

of waveguide in which we can connect a probe and probe can be moved in slot and position of 

probe can be measured by its Varnier scale. The travel of probe carriage is more than three times 

of half wavelength. 
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Tunable Probe  

Tunable probes are very useful devices to measure the SWR and Impedances. Tunable probe is 

consists of a crystal detector and a small wire antenna in coaxial housing. Its depth of penetration 

into the slotted section is variable. 

 

Matched Termination 

Matched terminations are used to terminate the waveguide transmission line operating at low 

average power. The loads are carefully designed to absorb all the applied power and VSWR of 

matched termination is low. These are used in the measurement of reflection coefficient and 

where the matched load is required. 

 

 

 

Wave Guide Detector Mount 
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The crystal detector can be used for the detection of microwave signal. At low level of 

microwave power, the response of each detector approximates to square law characteristics and 

may be used with a high gain selective amplifier having a square law meter calibration. 

 

 

 

Slide Screw Tuners  

Slide Screw Tuner is a very useful component in a microwave laboratory. It is mainly used for 

Impedance measurement. Its tuner can be adjusted for low and high impedance position. 
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E-Plane and H-plane Bends  

In measurements it is often necessary to bend a waveguide by some angle. Waveguide bends in 

E and H plane of 90° is normally available. Waveguide bends are designed by a section of 

rectangular waveguide and flange. 

  

 

Multihole Directional Coupler 

Directional coupler are designed to measure incident and reflected power values and also provide 

a signal path to a receiver or perform other desirable operation. In its most common form, the 

directional coupler is a four fort waveguide junction consisting of a primary main waveguide and 

a secondary auxiliary waveguide. These are available in 3, 6,10, 20, 40 dB coupling. 
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Cross Directional Coupler 

Cross Directional Coupler consists of two waveguide sectional joint at (90∘) with the coupling 

element mounted into the common broad wall. 

 
 

Tee 

Tees are used to combine power from two inputs or divided the microwave power from one input 

to two output lines. Tee is an intersection of three waveguides in the form of alphabet T. 
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E Plane Tee and H Plane Tee 

 

 

Magic Tee or E-H Tee 

 
 

Waveguide Antennas 

There are several types of microwave antennas like standard Gain, Pyramidial horn, Pick up 

horn, Dielectric antenna, Parabolic dish antenna etc. these are used to radiate microwave energy 

in the air and to receive the energy from air. 
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Precision Movable Short 

Movable shorts are used to obtain a phase reference in the calibration of various experimental 

setups .These are also used to vary the effective plane of reflection and therefore the phase of 

reflected wave. Movable shorts are used to measure the impedance of a device. Movable shorts 

are of two types one has no provision to record position of short in the waveguide and other type 

of movable short is precision movable short in which position of short can be accurately 

recorded from micrometer. 
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Phase Shifter  

Many applications require phase shift to be introduced between two given position in a 

waveguide system. It consists of a dielectric slab or vane specially shaped to minimize reflection 

effect. Phase shifter is used to change the effective electrical length of transmission line without 

changing its physical length. They are particularly useful in microwave bridge circuit where the 

phase and amplitude must be adjusted independently. 

 

 

 

 

 

 

 

REVIEW QUESTIONS   

  

What is microwave?  
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List some microwave frequency bands.  

List some of characteristic feature of microwave.  

List some of the application of microwave technology.  

Draw a simple microwave system.  

What are waveguide `Tees’?  

List the basic type of waveguide tees.  

What is an isolator?  

What is a circulator?  

What is a directional coupler?  

What is velocity modulation?  

Mention the Principle used in Klystron?  

When the o/p power of reflex klystron maximum?  

What is meant by attenuator?  
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Experiment No.: 1 

AIM:  Measurement of wavelength, guided wavelength and frequency using 

waveguide test bench. Calculation of broad wall dimension of waveguide and ω-β 

plot. 

OBJECTIVES: 

1. To determine the Frequency ( fo ) and wavelength (λ0 ) and guided-

wavelength (λg) of a microwave source in a rectangular waveguide on TE10 mode. 

2. To plot the ω-β diagram. 

APPARATUS USED: 

Sr. No. Name of the equipment Quantity Range/Rating Make 

1. 

2. 

3. 

4. 

5. 

6. 

7. 

8. 

9. 

10. 

11. 

12. 

Reflex Klystron/Gunn 

Oscillator 

Klystron Power 

Supply/Gunn Power 

Supply 

Pin Modulator 

Isolator 

Variable Attenuator 

Frequency Meter 

Slotted Section 

Tunable Probe 

VSWR Meter 

Movable Short 

CRO 

1 

1 

1 

1 

1 

1 

1 

1 

1 

1 

1 

1 

X – Band 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

SICO/ScienTech 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

 



THEORY: 

For dominant TE10 mode in rectangular wave-guide λ0, λg and λc are related as below. 

1/ λ0
2
    = 1/λg 

2
  +  1/λc

2  

 

Where λ0 is free space wavelength  

 λg is guide wavelength 

 λc is cutoff wavelength 

For  TE10 mode, λc = 2a is broad wall dimension of waveguide. The following 

relationship can be proved 

    

 f = c/λ = c√ (1/λg 
2
 + 1/λc

2
) 

Where c is velocity of light and  f is frequency. 

 

EXPERIMENTAL SETUP: 

 

Gunn 

Oscillator 

PIN 

Modulator 

Isolator

  

Frequency 

Meter 

Variable 

Attenuator 

Gunn Power 

Supply 

Movable 

Short 

Slotted 

Section 

Tunable 

probe  

VSWR 

meter 

Reflex 

Klystron 

Klystron 

power 

supply 



PROCEDURE: 

1. Set up the components and equipments as shown in fig. 1. 

2. Set the variable attenuator at maximum position. 

3. Keep the control knobs of VSWR meter as below: - 

Range db  -- 50 db position 

Input switch   -- Crystal Low Impedance 

Meter switch   -- Normal Position 

Gain (Coarse &Fine) -- Mid Position 

4. Keep the Control knobs of Klystron power supply as below 

 

Meter Switch  -- OFF 

MOD-Switch  -- AM 

Beam Voltage Knob -- Fully anti clockwise 

Repeller Voltage  -- Fully clockwise 

AM Amplitude Knob -- Around fully clockwise 

Mod Frequency Knob -- Around Mid Position 

5. Switch on the Klystron Power Supply, VSWR Meter and Cooling Fan. 

6. Turn the meter switch of the power supply to beam voltage position and set the 

beam voltage at 300 volts with the help of beam voltage control knob. 

7. Adjust the repeller voltage to some deflection in the VSWR Meter. 

8. Maximize the deflection with AM amplitude and frequency control knob of 

power supply. 



9. Tune the plunger of Klystron Mount for maximum deflection. 

10. Tune the repeller voltage knob for maximum deflection. 

11. Tune the probe for maximum deflection in VSWR meter. 

12. Tune the frequency meter knob to get a ‘dip’ on VSWR scale and note the 

frequency directly from the frequency meter 

13. Replace the termination with movable short and detune the frequency meter. 

14. Move the probe along the slotted line, the deflection in the VSWR meter will 

vary. Move the probe to a minimum deflection position. To get accurate reading, 

it is necessary to increase the VSWR meter range dB switch to higher position. 

Note and record the probe position. 

15. Move the probe to next minimum positions and record the probe positions. 

16. Calculate the guide wavelength as twice the distance between two successive 

minimum positions obtained as above. 

17. Measure the wave-guide inner broad wall dimension ‘a’ which will be around 

22.86 mm for X- band. 

18. Calculate the frequency by following equation: 

 

f = c/λ = c√ (1/λg 
2
 + 1/λc

2
) 

Where c = 3x10
8 

meter /sec. i.e. velocity of light. 

19. Verify the frequency obtained by frequency meter. 

20. Plot the graph between ω( = 2πf ) and  β( = 2π/ λg ). 

21. The above experiment can be verified at different frequencies. 

22. If the Gunn oscillator and PIN modulator is used instead of Klystron operating 

procedure of Gunn oscillator is to be followed. 

 

 



Observation Table: 

Sl. 

No. 

of 

Obs 

Frequency 

meter 

reading 

(GHz) 

Probe position at 

minima 

(cm) 

λg/2 

(cm) 

Av. 

λg 

(cm) 

λ0 

(cm) 

 

f0 

GHz 

ω 

 

 

β 

m1 m2 m3 m4 

(m
1

 ~
 m

2
) 

(m
2

 ~
 m

3
) 

(m
3

 ~
 m

4
) 

1.              

2.              

3.              

…              

…              

…              

 

 

CALCULATION AND RESULTS: 

 

CONCLUSION:     
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Experiment No.: 2 

AIM:  Measurement of Unknown Impedance (inductive, capacitive and resonant 

windows). 

OBJECTIV E:To measure the input impedance of a terminated waveguide using shift in 

minima technique and smith chart. 

APPARATUS USED: 

Sr. 
No. 

Name of the equipment Quantity Range/Rating Make 

1. 
 
2. 
 
 
3. 
4. 
5. 
6. 
7. 
8. 
 
10. 
11. 
12. 
13. 

Reflex Klystron/Gunn 
Oscillator 
Klystron Power 
Supply/Gunn Power Supply 
Pin Modulator 
Isolator 
Variable Attenuator 
Frequency Meter 
Slotted Section 
Tunable Probe 
S.S. tuner with matched 
termination/Load 
VSWR Meter 
Short 
CRO 
Cooling fan 

1 
 
1 
 
 
1 
1 
1 
1 
1 
 
1 
1 
1 
1 
1 

X – Band 
 
-do- 
 
 
-do- 
-do- 
-do- 
-do- 
-do- 
 
-do- 
-do- 
-do- 
0 – 20 MHz 
 

SICO/ScienTech 
 
-do- 
 
 
-do- 
-do- 
-do- 
-do- 
-do- 
 
-do- 
-do- 
-do- 

 

 



THEORY  

At very high frequencies, it is difficult to measure current and voltage because measuring 

devices become significant in size and every circuit becomes a transmission line. The slotted line 

is simple device used in determining the impedance of an unknown load at high frequencies up 

into the region of gigahertz. It can consist of a section of a rectangular waveguide with a slotted 

line along the mid of broadside where a detector probe can sample the E field and consequently 

measures the potential difference between the probe and its outer shield.  

The slotted line is primarily used in conjunction with the Smith chart to determine the standing 

wave ratio S(the ratio of maximum voltage to the minimum voltage) and the normalized load 

impedance ZL.The value of S is read directly on the VSWR meter when the load is connected. To 

determine ZL, we first find the position of the load by replacing the load by a short circuit and 

noting the locations of voltage minima (which are more accurately determined than the maxima 

because of the sharpness of the turning point) on the scale attached to the slotted line. Since the 

impedances repeat every half wavelength, any of the minima is selected as the reference point. 

We now determine the distance from the selected reference point to the load by replacing the 

short circuit by the load and noting the locations of voltage minima. The distance dmin (distance 

of Vmin toward the load) expressed in terms of λ (wave length) is used to locate the position of 

the load of an S– circle on the chart as shown in figure 2. We could also locate the load by using 

dmin, which is the distance of Vmin toward the generator. Either dmin or dmin
/may be used to locate 

ZL. Detailed steps for the impedance measurement of an unknown load using Smith chart are 

given in the PROCDURE chapter.  

 The value of normalized impedance of the load obtained with the help of Smith chart can 

be computed by using following important relations. 

1
1

+
−=Γ

s

s
L   ----------------------------------     (1) 

LLL φ∠Γ=Γ   ----------------------------------     (2)                 



πβφ −= min2 dL  ----------------------------------     (3) 

gλ
πβ 2=

  ----------------------------------     (4) 

ZL=     
L

L

O

L

Z

Z

Γ−
Γ+=

1

1
 ----------------------------------     (4) 

L

L
OL ZZ

Γ−
Γ+=

1

1
 ----------------------------------     (5) 

where, LΓ  is the complex Reflection coefficient of the complex load impedance LZ  with the 

phase angle Lφ . 

ZL =normalized impedance of the load 

LZ = load impedance. 

OZ = characteristics impedance of wave guide at an operating frequency corresponding to the 

guided wavelength gλ and free space wavelengthOλ  . 

gλ  = 2(distance between two successive minima or maxima) 

OZ may be calculated for TE10mode as  



    
o

g

r

r
O a

b
Z

λ
λ

ε
µ

377=  

a = 2.286 cm (broad-wall dimension of the x-band rectangular waveguide) 

b= 1.016 cm (narrow-wall dimension of the x-band rectangular waveguide) 

 

Load 

Short λ/2 λ/2 

dmin 

Vmin 

(dshift) 
ZL 

(dref) 
 

Fig1: Determining the location of the load ZL and Vmin on the. 
lotted line. 



 

 

Experimental Setup: 

 

Isolator
  

Frequency 
Meter 

Variable 
Attenuator 

Microwave 
Source 

Detector 
Probe 

VSWR 
Meter 

Slotted 
Line 

Load 

CRO 

Short 

ZL 

 

S - circle 
 

dmin 

 

Vmin 

 
S 

 

Fig2: Determination of the Load impedance from the Smith chart using the 
data obtained from the slotted line. 



PROCEDURE: 

1. Connect the equipment as shown in the set up 

2. Set the variable attenuator at maximum position. 

3. Keep the control knobs of VSWR meter as below. 

Range dB  : 50 dB position 

Input Switch  : Crystal low impedance 

Meter Switch  : Normal Position 

Gain (Coarse & fine) : Mid Position. 

4. Keep the Control knobs of Klystron power supply as below 

Meter Switch  -- OFF 

MOD-Switch  -- AM 

Beam Voltage Knob -- Fully anti clockwise 

Repeller Voltage  -- Fully clockwise 

AM Amplitude Knob -- Around fully clockwise 

Mod Frequency Knob -- Around Mid Position 

5. Switch ‘ON’ the Klystron power supply, VSWR meter and cooling fan. 

6. Turn the meter switch of power supply to beam voltage position and set the beam voltage 

at 300V with the help of beam voltage knob. 

7. Adjust the reflector voltage to get some reflection in VSWR meter. 
8. Maximize the deflection with AM amplitude and frequency control knob of power 

supply. 
9. Tune the reflector voltage knob for maximum deflection in VSWR meter. 



10. Tune the probe for maximum deflection in VSWR meter. 
11. Tune the Frequency meter knob to get dip on the VSWR scale, and note down the 

frequency directly from frequency meter. 
12. Connect a short circuit to the slotted line. Note down the positions ofsuccessive minima 

on the slotted line with the help of vernier scale attached to it. Take the first minima (near 

to the short) as the reference point. Let it be dref. 
13. Replace the short circuit with the S.S. tunerand Matched Termination.                                                          

14. Keep the depth of S.S. Tuner to around 3-4 mm and lock it. 
15. Move the probe toward the generator and locate the position of the shifted minima point. 

Let it be dshift. Then shift in minima, dmin= dshift - dref. 
16. Move the probe along the slotted line toward generator to get maximum deflection on the 

VSWR meter. 
17. Adjust VSWR meter gain control knobs and if required variable attenuator such that the 

meter indicates 1.0 on the normal upper SWR scale.Now move the probe toward 

generator to get minimum deflection (dip) on the meter. Note down the SWR = Son the 

scale. 
18. Remove the S.S. Tuner and Matched Termination and place movable short at slotted line. 

The plunger of short should be at zero. 
19. Note the position of two successive minima position. Let it be as d1andd2 . Hence                                                                                                                 

λg= 2(d1- d2) 
20. Calculate dmin /  λg 
21.  Find out the normalized impedance as described in the theory section. 
22.  Repeat the same experiment for other frequency if required.     

[SUMMRY:   The measurement is performed in following way: 

1. With the load (unknown impedance) connected to the slotted line, read Son the VSWR 

meter. With the value of S, draw the S-circle on the Smith chart. 

2. With the load replaced by a short circuit, locate a reference position for ZLat a voltage 

minimum point. 

3. With load on the line, note the position of Vmin and determine dmin. 



4. On the Smith chart, move toward the load a distance dmin (from the location of Vmin Find 

the ZLat that point. 

5. Check the result obtained by Smith chart with the calculated value through standard 

formulas.] 

Observation table:1 

 

S
l. 

N
o.

 o
f O

bs
 

Probe position at minima 

(cm) 

λg/2 

(cm) 

Av. 

λg 

(cm) 

λ0 

(cm) 

 

f0 

(GHz) 

m1 m2 m3 

(m
1 

~
 m

2)
 

(m
2 

~
 m

3)
 

m1
/ m1

// Avg 

m1 

m2
/ m2

// Avg 

m2 

m13
/ m3

// Avg 

m3 
               
               

Observation table:2 

dref 

(cm) 

dshift 

(cm) 

dmin 

(dref- dshift) 

(cm) 

dmin 

(dmin/ λ) 

(λ) 

SWR = 
S 

ZL 

 

ZL 

(Ω) 

       
 

CONCLUSION  
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Experiment No.: 3 

AIM:   KLYSTRON CHARACTERISTICS (static method and Dynamic Method) 

using power meter with bolometer and frequency meter. 

OBJECTIVES: 

(i) To study the variation of output power of a Reflex Klystron with the 

repeller voltage. 

(ii)  To study the variation of frequency of a Reflex Klystron with the repeller 

voltage.  

APPARATUS USED: 

Sr. 

No. 

Name of the equipment Quantity Range/Rating Make 

1. 

2. 

3. 

4. 

5. 

6. 

 

7. 

8. 

9. 

Reflex Klystron 

Klystron Power 

Supply 

Isolator 

Variable Attenuator 

Frequency Meter 

Coaxial to Waveguide 

Adapter 

Thermister mount 

Power Meter 

Oscilloscope 

1 

1 

1 

1 

1 

1 

 

1 

1 

1 

X – Band 

-do- 

-do- 

-do- 

-do- 

-do- 

 

-do- 

-do- 

-do- 

SICO/ScienTech 

-do- 

-do- 

-do- 

-do- 

-do- 

 

-do- 

-do- 

-do- 

 

 



THEORY : 

The Reflex Klystron makes the use of velocity modulation to transform a continuous 

electron beam into microwave power. Electrons emitted from the cathode are 

accelerated and passed through the positive resonator towards negative reflector, 

which retards and, finally reflects the electrons and the electrons turns back through 

the resonator. Suppose an RF field exists between the resonators the electrons 

traveling forward will be accelerated or retarded, as the voltage at the resonator 

changes in amplitude. The accelerated electrons leave the resonator at an increased 

velocity and the retarded electrons leave at the reduced velocity. The electrons leaving 

the resonator will need different time to return, due to change in velocities. As a 

result, returning electrons group together in bunches. As the electron bunches pass 

through resonator, they interact with voltage at resonator grids. If the bunches pass the 

grid at such a time that the electrons are slowed down by the voltage then energy will 

be delivered to the resonator; and Klystron will oscillate. The frequency is primarily 

determined by the dimensions of resonant cavity. Hence, by changing the volume of 

resonator, mechanical tuning of Klystron is possible. Also, a small frequency change 

can be obtained by adjusting the reflector voltage. This is called electronic tuning. 

SCHEMATIC BLOCK DIAGRAM:  The waveguide test bench is arranged as 

shown below. 
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PROCEDURE: 

1. Connect the components and equipments as shown in the figure. 

2. Set the attenuator at the maximum position. 

3. Set the Mode Switch of Klystron Power Supply to CW position, beam voltage 

control knob to full anti-clock wise and reflector (repeller)  voltage control 

knob to full clock wise and the Meter Switch to ‘OFF’ position. 

4. HT ON/OFF Switch to OFF position (SICO Model only). 

5. Rotate the knob of frequency meter at one side fully. 

6. Put the power meter in 10 mW range. 

7.  Switch on the power meter and set power display to zero reading with the 

help of coarse and fine control. 

8. Switch on the Klystron Power Supply and cooling fan. 

9. Put the HT ON/OFF Switch to ON position.  

10. Put the meter switch of KPS to beam voltage position and rotate beam voltage 

knob clockwise slowly up to 300 volts reading. Observe beam current on the 

meter by changing the meter switch to current position. “The beam current 

should not increase more than 30 mA.”  

11. Keep the meter switch of KPS at Repeller position. 

12.  Change the reflector voltage slowly from maximum negative value to -75 

volts in steps of 5 volts. Record the repeller voltage, output power and 

frequency in the observation table. The frequency is measured by tuning the 

frequency meter to have a dip in the output each time 

13. The frequency meter should be detuned each time while measuring power. 

14. Plot power/frequency versus repeller voltage to get mode curves.  

 

 

 

 

 



OBSEVATION TABLE : -- 

 REPELLER VOTAGE Vs POWER OUTPUT and FREQUENCY  

 

 

 

 

 

 

 

 

 

 

 

Repeller Voltage 

(volts) 

Output power 

(mW) 

Frequency (GHz) 

-250 … … 

-245 … … 

… … … 

… … … 

-80 … … 

-75 … … 



 

Fig: 1 . Frequency vs Power Output Characteristics Curve 

(sample)
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Fig (2) :--Repeller Voltage vs. Frequency Characteristics Curve (sample) 

 

CONCLUSION: -  
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SILIGURI INSTITUTE OF TECHNOLOGY 

DEPT. OF E.C.E 

RF & Microwave Engg LAB – EC 793A        Date: 

Experiment No.: 4 

AIM : Study of Characteristics of Gunn Oscillator using power meter with bolometer 

and frequency meter 

OBJECTIVES:  

(i) To study the characteristics of a Gunn diode oscillator by finding threshold 

voltage Vth and corresponding maximum current from the plot of bias 

voltage vs. diode current. 

(ii)  To plot the power output vs. frequency at bias voltage of 10 V. 

APPARATUS USED: 

Sr. 

No. 

Name of the equipment Quantity Range/Rating Make 

1. 

2. 

3. 

 

 

4. 

5. 

6. 

 

7. 

Gunn Oscillator 

Isolator 

PIN Modulator (if 

modulated output 

required) 

Variable Attenuator 

Frequency Meter 

Coaxial to Waveguide 

Adapter 

Power Meter 

 

1 

1 

1 

 

 

1 

1 

1 

 

1 

 

X – Band 

-do- 

-do- 

 

 

-do- 

-do- 

-do- 

 

-do- 

SICO/ScienTech 

-do- 

-do- 

 

 

-do- 

-do- 

-do- 

 

-do- 

 

 

 



THEORY: 

The Gunn Oscillator is based on negative differential conductivity effect in bulk 

semiconductors, which has two conduction bands minima separated by an energy gap 

(greater than thermal agitation energies). A disturbance at the cathode gives rise to 

high field region, which travels towards the anode. When this high field domain 

reaches the anode, it disappears and another domain is formed at the cathode and 

starts moving towards anode and so on the time required for domain to travel from 

cathode to anode (transit time) gives oscillation frequency. 

In a Gunn Oscillator, the Gunn diode is placed in a resonant cavity. In this case the 

oscillation frequency is determined by cavity dimension than diode itself. 

Although Gunn oscillator can be amplitude modulated with the bias voltage. We have 

used separate PIN modulator through PIN diode for square wave modulation. 

A measure of the square wave modulation capability is the modulation depth i.e. the 

output ratio between, ‘ON’ and ‘OFF’. 

EXPERIMENTAL SETUP:  
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OBSEVATION TABLE (1): Gunn diode Characteristics 

 

 

 

 

 

 

 

 

OBSEVATION TABLE (2):   Power Output vs. Frequency Plot 

Sl. No. of Obs. Freq.  

(GHz) 

O/P power 

 (mW) 

1 ..  

 2 … … 

3 … … 

4 … … 

5 … … 

PROCEDURE:  

1. Set the components and equipment as shown in the set up. 

2. Set the variable attenuator for maximum attenuation. 

3. Keep the control knob of Gunn Power Supply as below. 

Meter Switch  - OFF 

Gunn Bias Knob - Fully anticlockwise 

PIN bias Knob  - Fully anticlockwise 

PIN Mod frequency - Any position 

Sl. No. Bias Voltage (volts) Current (mA) 

1 0 0 

2 .5 … 

3 1 … 

… … … 

20 … … 

21 10 … 



4. Set the micrometer of Gunn Oscillator for required frequency of operation say 

9 GHz. 

5. Switch on the Gunn Power Supply and Cooling Fan. 

6. Turn the meter switch of Gunn Power Supply to voltage position. 

7. Change the Gunn Biasing in Steps of 0.5 V and record the corresponding 

current in observation table (read the Gunn bias and current in the panel meter 

of the Gunn Power Supply Unit). Maximum Gunn Bias Should be varied up to 

10 V. 

8. Draw the current – voltage characteristics curve and find the Threshold 

voltage Vth 

9. Set the Gunn bias at 9 Volts. Referring the calibration chart of the Gunn 

Oscillator set the micrometer Screw for a frequency the X- Band. Tune the 

wave meter to get a dip in the power meter reading. Read the frequency of the 

microwave carrier from the wavemeter and record in the observation table II. 

10. Mistune the wavemeter and read the power of the microwave signal and 

record in the observation table II. 

11. Draw the power vs. frequency characteristics curve of the Gunn oscillator. 

12. Draw the Conclusion. 

Note:- Do not keep the Gunn Bias Knob at threshold position for more than 10-

15 sec . Reading should be obtained as fast as possible. Otherwise due to 

excessive heating, Gunn diode may burn. 
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Fig.1: --a sample graph of I-V characteristics 
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Fig.2: -- A sample graph of power vs. frequency characteristics. 

 

 

CONCLUSION: 



SILIGURI INSTITUTE OF TECHNOLOGY 

DEPT. OF E.C.E 

RF & Microwave Engg LAB – EC 793A      Date: 

Experiment No.: 5 

AIM:   Measurement of coupling and directivity of a Multihole Directional 

Coupler. 

OBJECTIVES: 

a. To measure the main-line and auxiliary-line VSWR. 

b. To measure the coupling factor and directivity. 

APPARATUS USED: 

Sr. 

No. 

Name of the equipment Quantity Range/Rating Make 

1. 

 

2. 

 

 

3. 

4. 

5. 

6. 

7. 

8. 

9. 

10. 

11. 

12. 

13. 

14. 

15. 

Reflex Klystron/Gunn 

Oscillator 

Klystron Power 

Supply/Gunn Power 

Supply 

Pin Modulator 

Isolator 

Variable Attenuator 

Frequency Meter 

Slotted Section 

Tunable Probe 

Detector Mount 

Matched Termination 

Multi-hole Directional 

Coupler 

VSWR Meter 

Movable Short 

CRO 

1 

 

1 

 

 

1 

1 

1 

1 

1 

1 

1 

1 

1 

1 

1 

1 

1 

X – Band 

 

-do- 

 

 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

SICO/ScienTech 

 

-do- 

 

 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

 



THEORY: 

A directional coupler is a device with which it is possible to measure the incident and 

reflected wave separately. It consists of two transmission line, the main arm and 

auxiliary arm, electronically coupled to each other. Refer to the fig. no. 1.  The power 

entering port1 the main arm gets divided between port2 and 3 and almost no power 

comes out in port 4.  

 

                             Fig. 1:---Directional Coupler 

The coupling factor is defined as  

Coupling (dB) = 10 log10 [ P1/P3 ] where port 2 is terminated, 

Isolation (dB) = 10 log10 [P2/P3] where P1 is matched, 

With built in termination and power is entering at port 1. The directivity of the 

coupler is a measure of separation between incident and the reflected wave. It is 

measured as the ratio of two power outputs from the auxiliary line when a given 

amount of power is successively applied to each terminal of the main lines with the 

port terminated by material loads. 

Hence Directivity D (dB) = Isolation – Coupling = 10 log10 [ P2/P1 ]. 

 Main line VSWR is SWR measured looking into the main line input terminal when 

the matched loads are placed at all other ports. 

Auxiliary line VSWR is SWR measured in the Auxiliary line looking into the output 

terminal, when the matched loads are placed on other ports. 

Main line insertion loss is the attenuation introduced in transmission line by insertion 

of coupler. It is defined as  

Port 1 

Port 4 

Port 3 

Port 2 



Insertion Loss = 10 log10 [ P1/P2 ] when power is entering at port 1. 

  

Experimental Set Up 

 

Fig.1: – Set Up for the measurements of VSWR of MHD Coupler 

PROCEDURE:  

A. MAIN LINE SWR MEASUREMENT 

1. Set up the components and equipments as shown in fig. 1. 

2. Energize the microwave Source for particular frequency operation as scribed. 

(Procedures given in the operation of Klystron and Gunn Oscillator). 

3. Follow the procedure as described for VSWR measurement experiment (low 

and medium measurement). 

4. Repeat the same for other frequencies. 

Microwave 
Source 

Isolator Variable 
Attenuator 

Frequency 
Meter 

Tunable 
probe 

Slotted 
Line 

VSWR 
Meter 

MHD 
Coupler 

Matched 
Load 

Matched 

Matched 
Load 

Matched 
Load 

MHD  
Coupler 

1

3 

2 



 

B. AUXILLIARY LINE SWR MEASUREMENT 

1. Set up the components and equipments as shown in fig. 1. 

2. Energize the microwave Source for particular frequency operation as scribed 

operation of Klystron and Gunn Oscillator. 

3. Measure SWR as described in the experiment of SWR measurement (low and 

medium SWR measurement). 

4. Repeat the same for other frequencies. 

 

C. MEASUREMENT OF COUPLING FACTOR, INSERTION 

LOSS 

1. Set up the components and equipments as shown in fig. 1. 

2. Energize the microwave Source for particular frequency operation as 

scribed operation of Klystron and Gunn Oscillator. 

3. Remove the multihole directional coupler and connect the detector 

mount to the frequency meter. Tune the detector for the maximum 

output. 

4. Set any reference level of power on the VSWR meter with the help of 

variable attenuator, gain control knob of VSWR meter, and note down 

the reading. (Reference level let it be X). 

5. Insert the directional coupler as shown in second fig. with detector to the 

auxiliary port 3 and matched termination to port 2, without changing the 

position of variable attenuator and gain control knob of VSWR meter. 

6. Note down the reading on VSWR meter on the scale with the help of 

range-dB switch if required. (Let it be Y) 

7. Calculate coupling factor, which will be X-Y in dB. 

8. Now carefully disconnect the detector from the auxiliary port 3 and 

match termination from port 2 without disturbing the set-up. 

9. Connect the matched termination to the auxiliary port 3 and detector to 

port 2 and measure the reading on VSWR meter. Suppose it is Z. 

10. Compute insertion loss X-Z in dB. 

11. Repeat the step from 1 to 4. 



12. Connect the directional coupler in the reverse direction, i.e. port 2 to 

frequency meter side, matched termination to port 1 and detector mount 

to port 3, without disturbing the position of the variable attenuator and 

gain control knob of VSWR meter. 

13. Measure and note down the reading on VSWR meter, let it be Yd. 

14. Compute the directivity as Y- Yd. 

15. Repeat the same for other frequencies. 

Observation Table: 

Sl. No. Frequency 

(GHz) 

X 

(dB) 

Y 

(dB) 

Z 

(dB) 

Yd 

(dB) 

 

Coupling  

Factor  

(X-Y) 

(dB) 

Insertion  

Loss 

(X-Z) 

(dB) 

Directivity 

(Y- Yd) 

(dB) 

1         

2         

3         

4         

5         

 

 

CONCLUSION: -   

 

 

 



SILIGURI INSTITUTE OF TECHNOLOGY 

DEPT. OF E.C.E 

RF & Microwave Engg LAB – EC 793A      Date: 

Experiment No.: 6 

EXPERIMENT NO: AIM:  Study of Magic Tee 

OBJECTIVES: 

To Study isolation, coupling coefficients and input VSWRs of an E-H plane tee or magic tee 

APPARATUS USED: 

Sr. 

No. 

Name of the equipment Quantity Range/Rating Make 

1. 

2. 

3. 

4. 

5. 

6. 

7. 

8. 

9. 

10. 

11. 

12. 

13. 

14. 

15. 

Reflex Klystron/Gunn 

Oscillator 

Klystron Power Supply/Gunn 

Power Supply 

Pin Modulator 

Isolator 

Variable Attenuator 

Frequency Meter 

Slotted Section 

Tunable Probe 

Detector Mount 

Matched Termination 

Magic Tee 

VSWR Meter 

Movable Short 

CRO 

1 

1 

1 

1 

1 

1 

1 

1 

1 

1 

2 

1 

1 

1 

1 

X – Band 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

SICO/ScienTech 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

THEORY: 

The device magic Tee is a combination of the E-plane and H-plane Tee. Arm3, the H-arm 

forms an H-plane Tee and the E-arm forms an E-plane Tee in combination with arm 1 and 2 a 

side or collinear arms. If power is fed into arm 3 (H-arm) the electric field divides equally 

between arm 1 and 2 in the same phase, and no electric field exists in arm 4. Reciprocity 

demands no coupling in port 3 (H-arm). If power is fed in arm 4 (E-arm), it divides equally 



into arm 1 and 2 but out of phase with no power to arm 3. Further, if the power is fed from 

arm 1 and 2, it is added in arm 3 (H-arm), and it is subtracted in E-arm, i.e. arm 4.  

 

 

Fig:---- Magic Tee 

The basic parameters to be measured for Magic Tee are defined below 

A. INPUT VSWR 

Value of SWR corresponding to each port, as a load to the line while other ports are 

terminated in matched load is determined. 

B. ISOLATION  

The isolation between E and H arms is defined as the ratio of the power supplied by the 

matched generator connected to the E-arm (port 4), to the power detected in H- arm (port 3) 

by a matched detector  when collinear arms (1 and 2) are terminated in matched loads. It is 

expressed in dB. 

Hence, I34 = 10 log10 [P4/P3] 

P4 : Power incident in port 4 (E- arm) 

P3 : Power detected in port 3 (H- arm) 

Similarly isolation between other ports may also be defined and measured. 

E-arm 

H-arm 
1 

3 

2 

4 



C.COUPLING COEFFICIENT 

The voltage coupling coefficient from arm I to arm j is defined as 

 Cij = 10-α/20  

Where α is the attenuation in dB when i is the input and j is the output arm. 

Thus α (dB) = 10 log10 [Pi/Pj] 

Where Pi is the power delivered to i arm by a matched generator and Pj is power detected by a 

matched detector in j arm. 

In case of magic tee, there are 12 coupling constants, one for each of the arms as an input to 

each of the other three arms as an output. However, if we have a perfectly matched detector 

and generator, Cij = Cji   and the reciprocity desires C12 = C21, C32 = C31  and C41 = C42. 

EXPERIMENTAL SET UP  

 

Fig. 2.  Setup for the study of Magic Tee 
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Matched 
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Matched 
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1 

4 
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Matched 
Load 
 



PROCEDURE 

1. Assemble the set up as shown in the figure without the magic tee. 

2. Carefully remove the slotted section probe from the guide. 

3. Energize the power source and adjust it for maximum power indication on                

SWR meter. 

4. Adjust the coarse and fine control of the VSWR meter for reasonable power 

level say 20 dB and record this power level in the table as initial power 

5. Carefully remove the detector set up and insert magic tee as shown in the 

figure and connect the detector on one of the ports and terminate other ports with 

matched loads.  

6. Determine the attenuation and hence isolation in decibels by noting the change 

in the output level on the detector. 

7. Reverse terminals one by one, connecting one arm to the generator, other to 

the detector and rest terminated in matched loads and record various isolation 

parameters in the observation table. 

8. Determine coupling coefficients knowing attenuation in steps 6 and 7. 

9. Insert probe in the slotted section and terminate slotted section in one of the 

arms of the tee and determine input VSWRs following the procedure of VSWR 

measurement. 

10. Repeat step 9 each time for all other three ports taken as input arm and record 

in Table 2. 

 

 

 

 

 

 

 

 

 

 



Observation table:1 
______________________________________________________________ 

Sl.No. Orientation of   VSWR /Power meter  Isolation Couplings          
Magic tee   reading  (dB)  coefficient 

 ____________                     (dB/mW) 

           Input    output          ____________________     

 arm    arm                 initial           final          

1.    3        1                20 dB        23.8                    I31 = 3.8         C31 = 0.647 

          2                                 23.6                    I32 = 3.6         C32 = 0.661    

          4                              beyond 60 dB       I34 = more      C34 =         

                                                                                             than 31 dB  . 

2.    4        1                20 dB                                   I41 =               C41 =  

         2                                                             I42 =               C42 =    

         3                                                             I43 =               C43 =                                                                                        

3.    1         3             20 dB                                     I13 =               C13 =  

          4                                                            I14 =               C14 =    

          2                                                            I12 =               C12 =                                                                                            

4.    2        1                20 dB                                   I21 =               C21 =  

3                                                            I23 =                C23 =                
4                                                            I24 =                 C24 =      

___________________________________________________________________________
___(One set of observation is given in the table) 

Observation table 2 

Sl. No. Input arm VSWR 

1 1. Collinear arm  

2 2. Collinear arm  

3 3. H-arm  

4 4. E-arm  

 

CONCLUSION:   
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SILIGURI INSTITUTE OF TECHNOLOGY 

DEPT. OF E.C.E 

RF & Microwave Engg LAB – EC 793A              Date: 

Experiment No.: 8 

AIM:  Measurement of Dielectric Constant using wave-guide test Bench. 

OBJECTIV E: To measure the Dielectric Constant of a given Dielectric sample with 

the help of microwave test bench. 

APPARATUS USED: 

Sr. 

No. 

Name of the equipment Quantity Range/Rating Make 

1. 

2. 

3. 

4. 

5. 

6. 

7. 

8. 

9. 

10. 

11. 

12. 

Reflex Klystron/Gunn 

Oscillator 

Klystron Power Supply/Gunn 

Power Supply 

Pin Modulator 

Isolator 

Variable Attenuator 

Frequency Meter 

Slotted Section 

Tunable Probe 

VSWR Meter 

Movable Short 

Dielectric Sample 

1 

1 

1 

1 

1 

1 

1 

1 

1 

1 

1 

3 

X – Band 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

--- 

SICO/ScienTech 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 

-do- 
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Theory 

 In the wave guide method, a rectangular waveguide terminated by metal short acts as short 

circuit is connected to the output end of the slotted line. The voltage minima d1min  is located. 

The dielectric under test is shaped so as to fit into the waveguide. The sample of thickness t1 

is fitted into the waveguide end and is backed by a short circuit metal plate. The new voltage 

minimum d2min  is located. By using the impedance relation  

  Zdtan(βd d1min) = - Zotan(β d2min),      -----------(1) 

The following transcendental equation can be derived: 

  tan(βd t1)/ βd t1 = tan[β(∆1 + t1)]/ βt1,       -----------(2) 

where ∆1 = d1min -  d2min   is the shift in the position of minimum;  β = 2π/λg  and  βd denote the 

phase constants in the empty guide and in the dielectric, respectively. Equation (2) is solved 

for  βd t1 and the dielectric constant of the sample is calculated from the relation  

   

εεrr    ==  {{   ((aa//ππ))22 (βd t1/t1)
2 +1}/{(2a/λg )

2 + 1},   ----------(3) 

where a =  broad wall dimension of the waveguide.   

The solution of (3) gives us multiple roots. The measurement is repeated with a second and 

third sample of thickness t2 and t3, and βd  is determined. The correct solution is the common 

to the three measurements. The method is applicable for dielectrics with very low value of 

tanδ. The airgap between the shorting plate and the sample should be reduced to the 

minimum to obtain εεrr    tanδ accurately. 
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Experimental Setup: 

  

  

PPrr oocceedduurr ee::   

1. Connect the equipment as shown in the set up 

2. Energize the microwave source and obtain the suitable power level in the indicating 

meter. 

3. With no sample in the short circuited line, find the first position of voltage minima 

d1min , and record in the observation table with the help of slotted section and probe. 

4. Measure the guide wave length λg  by measuring the distance between two successive 

minima in the slotted line. 

5. Remove the short circuit, insert a sample dielectric and replace the short circuit in 

such a manner that it touches the end of the sample. 

6. Measure d2min  , the first position of minima in the slotted line. 

7.  Measure VSWR in the slotted line. 

8. Repeat steps (3) to (6) with sample having different lengths. 

9. Compute the dielectric constant of the given sample. 

 

Isolator
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Meter 
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Microwave 
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Observation table: 

(i) Wave guide dimension a = ------------ cm 
(ii)  Cut-off wavelength λc = 2a = -------------cm 
(iii)  Frequency of operation = -----------GHz 
(iv) Temperature = ---------oC 
(v) VSWR, S =-----------(with sample) 

                                                           

Sample Thickness

(t1) 

position of standing wave 

minima 

tan [β (∆1 + 

t1)]/ βt1 

(tanX)/X value of X 

 
Wave guide 

Unload 

(d1min) 

Wave guide loaded 

With Dielectric 

(d2min) 
1      X1 = 

X2 = 
X3 = 

2      X1 = 
X2 = 
X3 = 

3      X1 = 
X2 = 
X3 = 

 

Calculation: 

 

CONCLUSION: -   

 

 


